X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Adobe Flash Player will not run since installing Firefox 25.0 upgrade

Posted

Windows 7 Home Premium X64. My question says it all. Within Firefox's own system it says the flash player is update and enabled. Any place I go today and want to play something the page posts "Get Adobe Flash Player". I upgraded to Firefox 25.0 just before I retired for the night. Today Flash Player will not work. Within Tools>Options>Content the option to turn java off and on is no longer there. I believe you folks have CREATED A BIG BUG!!!!!

Post a Reply

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20913.0
  • Coupons, Inc. Coupon Printer 4.0.2.0
  • VLC media player Web Plugin 2.0.6
  • PDF-XChange Viewer Netscape Gecko Plugin
  • NPWLPG
  • Logitech Harmony Remote Plugin
  • Bitdefender QuickScan Web Netscape Plugin
  • np-mswmp

Application

  • Firefox 25.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0/WINNT/en-US/

Extensions

  • avast! Online Security 8.0.1497 (wrc@avast.com)
  • BetterPrivacy 1.68 ({d40f5e7b-d2cf-4856-b441-cc613eeffbe3})
  • Bitdefender QuickScan 0.9.9.119 ({e001c731-5e37-4538-a5cb-8168736a2360})
  • Cookie Monster 1.1.0 ({45d8ff86-d909-11db-9705-005056c00008})
  • Coupons at Checkout 1.3 (jid0-5R3LLpyrG0a1kPDXAA8ZKmM0bgM@jetpack)
  • CouponsHelper 1.1.8 ({239cc760-75a9-4276-b1fc-c0ceb963f373})
  • DoNotTrackMe 2.2.9.618 (donottrackplus@abine.com)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • Flagfox 4.2.14 ({1018e4d6-728f-4b20-ad56-37578a4de76b})
  • Ghostery 5.0.6 (firefox@ghostery.com)
  • HTTPS Finder 0.85 ({6bdc61ae-7b80-44a3-9476-e1d121ec2238})
  • IE View 1.5.6 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • LastPass 2.0.20 (support@lastpass.com)
  • Lightbeam 1.0.2 (jid1-F9UJ2thwoAm5gQ@jetpack)
  • NoScript 2.6.8.4 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Tab Mix Plus 0.4.1.2.02 ({dc572301-7619-498c-a57d-39143191b318})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WOT 20131030 ({a0d7ccb3-214d-498b-b4aa-0e8fda9a7bf7})
  • YouTube Lyrics by Rob W 3.6.3 (youtube-lyrics-by-rob-w@jetpack)
  • DVDVideoSoft YouTube MP3 and Video Download 4.2.1.9 ({ACAA314B-EEBA-48e4-AD47-84E31C44796C}) (Inactive)
  • FEBE 7.3.0.1 ({4BBDD651-70CF-4821-84F8-2B918CF89CA3}) (Inactive)
  • WCaptureX 1.0.0.0 (wcapturex@deskperience.com) (Inactive)
  • Xmarks 4.2.3 (foxmarks@kei.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-30-2013
  • driverDate2:
  • driverVersion: 8.15.10.2993
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.blockautorefresh: True
  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 51200
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 880640
  • browser.link.open_newwindow.override.external: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131025151332
  • browser.startup.homepage: https://login.yahoo.com/config/login?.pd=c%3DaMtFxUmp2e6zaBL942f2v6LoDw--&.src=my&.intl=us&.done=http%3A%2F%2Fmy.yahoo.com
  • browser.startup.homepage_override.buildID: 20131025151332
  • browser.startup.homepage_override.mstone: 25.0
  • browser.tabs.animate: False
  • browser.tabs.loadInBackground: False
  • browser.tabs.selectOwnerOnClose: False
  • browser.urlbar.autocomplete.enabled: False
  • dom.max_chrome_script_run_time: 60
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 25.0
  • font.internaluseonly.changed: False
  • gfx.direct2d.disabled: True
  • gfx.direct3d.checkDX10: False
  • gfx.direct3d.last_used_feature_level_idx: 1
  • keyword.URL: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=
  • layers.acceleration.disabled: True
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1383848584
  • places.history.expiration.transient_current_max_pages: 73519
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npnitromozilla: 0
  • plugins.load_appdir_plugins: True
  • privacy.cpd.cookies: False
  • privacy.cpd.extensions-tabmix: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.disable_button.openDeviceManager: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1383229158

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

I notice you have the NoScript extension installed. Can you double-check when you're on a problem page that you've allowed enough scripts on the NoScript menu? Note that sometimes video content will be hosted on a different server from the one shown in the address bar -- you may need to allow more than one server in order to get things to run.

Sometimes after a Firefox update, an extension will stop working normally. Could you test in Firefox's Safe Mode.? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash still works in Safe Mode)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Was this helpful to you? 4
Reply

Question owner

I went to NoScript and told it to temporarily all scripts on this page. Instead of showing the video it was still telling me to Get Adobe Flash Player. So I did the Safe Mode thing. Now YouTube videos will at least play. But that one video on The Blaze site still tells me to get Adobe Flash Player. Now I have to repeat the process, that seems to be getting done on a more regular basis every time Firefox updates, of going through and trying to find which one of my add-ons might be causing this issue. This is getting to be a ridiculous problem, and very time consuming. I guess the best thing might be to go back to IE as my default.

Was this helpful to you? 3
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi rocmar62, if sites can use the Flash Player in Safe Mode, one reasonable deduction is that one of your add-ons -- maybe not NoScript -- is interfering with sites using the player. Many sites use multiple domains (for example, youtube.com uses ytimg.com, facebook.com uses fbcdn.net). If you have extensions that block "third party" cookies or otherwise try to filter secondary servers sites use, those might also be causing this issue.

It could take some time to track down, but as a first step, try disabling ALL nonessential or unrecognized extensions. By nonessential, I mean you could live without it for 24 hours. To do that, open the Add-ons page using either:

  • Ctrl+Shift+a
  • orange Firefox button (or Tools menu) > Add-ons

In the left column, click Extensions.

Usually a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any difference?


You might also need to change your cookie setting to allow third party cookies in the Privacy options.

orange Firefox button (or Tools menu) > Options > Privacy

Was this helpful to you? 3
Reply

Question owner

The biggest issue here is that, so often, Firefox updates "break" its usage. I just don't understand that. As a long time user of NoScript - and lets use YouTube as the example here - I already have all those settings for YouTube set in NoScript. I already have all those items set to be allowed on YouTube, yet one evening, before I go to bed, I allow Firefox to be updated. The next day I can no longer watch a single video on YouTube. WHY???? The only thing that has changed was the Firefox update. I shut my computer down after the update completed, and restarted it the next morning. Nothing happened to it overnight. There have not been any recent updates of any kind, and there have been no recent new installations. Yet Firefox is "broke" when it comes to YouTube. WHY?????? And this happens more often than not. Why??? This, along with the fact that some recent browser comparisons show that IE is a now a little faster than Firefox are really making it hard to keep using Firefox. Those comparisons are also showing that for all practical purposes they are pretty much equal in regard to Safety. But to have to go through the process of figuring out why your browser is broken due to the most recent update practically every time an update comes, makes it very cumbersome to use. I've enjoyed using Firefox, every since its very, very early versions. I haven't even minded the fact that oftentimes it told me that one or more of my extensions were no longer compatible with it, and I could no longer use it, while hopefully someone upgraded so that it was compatible. Upgrades, especially major ones, seem to be coming more quickly any more. And maybe that is the major issue behind "breaking" it for users. I haven't had any messages over the last several upgrades that I have incompatible extensions. In fact, over the last several upgrades I don't even remember it saying that it (the upgrade) is checking my extensions for compatibility???? This makes it impossible for me to say that My Problem Was Solved until I see what the next upgrade happens!!!

Was this helpful to you? 1
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi rocmar62, a lot of site breakage issues are identified during pre-release testing, and obviously many beta users would be visiting Youtube, but one of the strengths/weaknesses of Firefox is extensibility, with the result that there are at least thousands, maybe tens of thousands of unique combinations of add-ons and customizations.

I can't tell from your last reply whether you were able to figure out the problem in this case, but your input on that may help the next user searching for the same solution, so please report your findings when you can.

Was this helpful to you? 0
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi rocmar62, I missed that Firefox 25 turned on "click to play" as the default behavior for plugins. I assume you prefer to have Flash run automatically if you've approved the site in NoScript.

In case this change corrupted your setting for the Shockwave Flash plugin, try toggling it. Here's what I mean:

(1) Open the Add-ons page to the Plugins section

  • Ctrl+Shift+a > Plugins
  • orange Firefox button (or Tools menu) > Add-ons > Plugins

(2) Change the setting for Shockwave Flash to "Never Activate" and pause while Firefox updates the setting

(3) Change the setting for Shockwave Flash to "Always Activate" and pause while Firefox updates the setting

Does that make any difference?

Was this helpful to you? 1
Reply

Helpful Reply

Ah!!!!! Now we come to a better understanding about why 25 may cause some systems to "break". Something that "Firefox" knew that it was, or could do to its settings. Something that users were not aware of beforehand. Do we all have to go somewhere and read all about the various changes that are going to happen when these updates happen??? And how many are even if we know we are supposed to. And some will have their systems to go ahead and automatically update their system as soon as the update becomes available - whether they go look to see what the changes are or not. Might it not be better to do something similar to Windows updates? Include information about the update along with the update itself. What I did is go through and disabled SEVERAL of my addons and for whatever reason YouTube worked. Since Firefox did not tell me any of these are no longer compatible with Firefox, I have to go through the process of seeing which one MIGHT have "broke" it. Now you tell me about this "toggling" of settings, and maybe that is the problem to begin with. I reviewed all these settings, and it is "always activate", but no, I did not toggle it. I didn't know I needed to, or might need to. Obviously, it is something that was known about. Why didn't you let me know beforehand. I have not yet started working towards re-enabling my extensions yet, so I can't tell you if that was it or not. It just happens I am presently working on a high school class reunion involving about 700 people, and getting to the bottom of this Firefox issue is not on the top of my list. Especially not when I can use IE, if necessary. Thanks for letting me know what the real issue may have been, though.

Was this helpful to you? 1
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi rocmar62, the suggestion to toggle the Always Activate/Never Activate setting was just a guess, not a solution I've ever heard of before, in relation to plugins not working. On rare occasions, volunteers have seen cases where a dialog will say A but the truth is B, and switching the settings back and forth fixes the corrupted setting. The odds of a corrupted setting are low, but I suggested it in case everything else checked out and we were down to chasing gremlins.

When Firefox checks compatibility for extensions, it is checking for stated compatibility (i.e., the extension lists a range of compatible version and whether the upper bound should be strictly enforced). There are times that the author becomes aware, before or after release, that there is a functionality problem in a new version of Firefox. Firefox's compatibility check has no access to this information which may appear in reviews, or on a separate website. Mozilla sometimes issues a block on an add-on if it causes a lot of crashes, but otherwise, the problem is left to the add-on's author to solve.

While Microsoft's documentation is admirable, it definitely is not complete. Earlier this year, one of Microsoft's updates was found to ruin font rendering in many configurations of Firefox. I'm pretty sure that wasn't in the the Technet or MSKB documentation, and the fact that it routinely gets installed when IE9 users install IE10 further disguises the source of the problem.

But I digress... a great place to keep up with Firefox changes is this blog: http://www.ghacks.net/category/firefox/

Was this helpful to you? 1
Reply

Helpful Reply

Your statement: "I missed that Firefox 25 turned on "click to play" as the default behavior for plugins. I assume you prefer to have Flash run automatically if you've approved the site in NoScript." I didn't read anything anywhere, nor was I aware of the fact that Firefox may have changed "my" plugin settings, or broken them. How many users do you think there might be that have NoScript set this way for one or more sites. I'm just saying it might have been nice to have been forewarned about this - obviously something that was KNOWN that the update was going to do!!!!!!!!!!!!!!!

Was this helpful to you? 1
Reply
jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi rocmar62, I did say Firefox 25 turned on "click to play" as the default behavior for plugins. What wasn't clear from that statement was that the upgrade was designed to preserve your existing choice between Always Active and Never Activate for your presently installed plugins, while adding the third choice of Ask to Activate. I did not personally notice any of my plugins changing behavior from before the update to after, and I can't recall seeing any threads where that has come up as a problem. It seem the conversion went smoothly in most cases, but any conversion involves the possibility of corruption, i.e., results not matching intent, so I suggested a workaround for that possible scenario. Forget I mentioned it.

Was this helpful to you? 1
Reply
porkchop94 0 solutions 1 answers

Thanks, I was having the same issue, and sure it enough. It was a extention blocking app that was messing up things. uninstalled it and works fine now. Thks :)

Was this helpful to you? 0
Reply
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.