X
Tap here to go to the mobile version of the site.

Support Forum

Weird issues with YouTube navigation

Posted

Hi,

I'm a new Firefox user and I did a fresh install of the latest version today, as well as installing some extensions. Everything is working great, except I have some navigation issues with YouTube.

If I go to the YouTube homepage, then I press the back button to go back to the previous site I was on, it doesn't work. What happens is, I stay on YouTube, except now both the back and forward buttons light up in the toolbar. If I press back again, I go back to the site I was on previously, so I have to hit back twice every time. If I hit forward, I stay on the page I'm on, but the forward button greys out.

Also, let's say that I am on the YouTube homepage and I click on a video to watch it. At that point, I can click back to go back and it works as normal, but when I do that, the forward button is not lit up, so I can't go forward to the video that I just watched.

These issues only affect YouTube. I've been browsing around the web using Firefox for a few hours and all other sites seem to work just fine.

Any ideas? Thanks.

Hi, I'm a new Firefox user and I did a fresh install of the latest version today, as well as installing some extensions. Everything is working great, except I have some navigation issues with YouTube. If I go to the YouTube homepage, then I press the back button to go back to the previous site I was on, it doesn't work. What happens is, I stay on YouTube, except now both the back and forward buttons light up in the toolbar. If I press back again, I go back to the site I was on previously, so I have to hit back twice every time. If I hit forward, I stay on the page I'm on, but the forward button greys out. Also, let's say that I am on the YouTube homepage and I click on a video to watch it. At that point, I can click back to go back and it works as normal, but when I do that, the forward button is not lit up, so I can't go forward to the video that I just watched. These issues only affect YouTube. I've been browsing around the web using Firefox for a few hours and all other sites seem to work just fine. Any ideas? Thanks.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.9 r900
  • 5.1.20913.0
  • PDF-XChange Viewer Netscape Gecko Plugin
  • NPWLPG

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-GB/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Search Bar 2.0 (add-to-searchbox@maltekraus.de)
  • All-in-One Sidebar 0.7.20 ({097d3191-e6fa-4728-9826-b533d755359d})
  • Context Search 0.6.2 ({902D2C4A-457A-4EF9-AD43-7014562929FF})
  • Download YouTube Videos as MP4 1.7.9 ({b9bfaf1c-a63f-47cd-8b9a-29526ced9060})
  • Duplicate This Tab 1.3 (duplicate-this-tab@mozilla.org)
  • FireGestures 1.7.14 (firegestures@xuldev.org)
  • FVD Speed Dial with Full Online Sync 4.4.9 (pavel.sherbakov@gmail.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Undo Closed Tabs Button 3.8.4.3 (undoclosedtabsbutton@supernova00.biz)
  • URL Tooltip 1.2.1 (url-tooltip@timothytate.net)
  • Zoom Page 7.0 (zoompage@DW-dev)
  • All-in-One Gestures 0.26 ({8b86149f-01fb-4842-9dd8-4d7eb02fd055}) (Inactive)
  • Speed Dial 0.9.6.16 ({64161300-e22b-11db-8314-0800200c9a66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 670
  • adapterDescription2:
  • adapterDeviceID: 0x1189
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 2048
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.16384
  • driverDate: 10-15-2013
  • driverDate2:
  • driverVersion: 9.18.13.3158
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 670 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: chrome://fvd.speeddial/content/fvd_about_blank.html
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.max_tabs_undo: 30
  • browser.startup.homepage: https://www.google.co.uk
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.loadInBackground: False
  • browser.urlbar.maxRichResults: 15
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • general.autoScroll: False
  • gfx.direct3d.last_used_feature_level_idx: 0
  • mousewheel.acceleration.start: 1
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No

Question owner

Here's a GIF that demonstrates the above issues: -

http://i.minus.com/ib1VommMvu0r4Y.gif

So I start from my speed dial page and click on YouTube. I then click the back button and you can see that it causes the forward button to light up, but it does not go back. I then click back again and it goes back to the speed dial.

I then go back to YouTube and click on the Doctor Who video. Then I click back and you can see that the forward button lights up briefly, but then greys out, so I can't go forward and get to the video I just watched.

Here's a GIF that demonstrates the above issues: - http://i.minus.com/ib1VommMvu0r4Y.gif So I start from my speed dial page and click on YouTube. I then click the back button and you can see that it causes the forward button to light up, but it does not go back. I then click back again and it goes back to the speed dial. I then go back to YouTube and click on the Doctor Who video. Then I click back and you can see that the forward button lights up briefly, but then greys out, so I can't go forward and get to the video I just watched.
Nellus 68 solutions 634 answers

Hello djsigma and thank you to use firefox,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello djsigma and thank you to use firefox, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Helpful Reply

Thanks for the reply.

I tried Safe Mode and that fixes the first issue I mentioned in post 1 with me having to click the back button twice to go back, however, it does not fix the second issue. If I go to the YouTube homepage, click on a video, then go back to the homepage again, the forward button flickers on briefly, but then is greyed out so I can't go forward.

Can I try a fresh installation of Firefox in a different directory, so I can test it with totally default settings?

Thanks for the reply. I tried Safe Mode and that fixes the first issue I mentioned in post 1 with me having to click the back button twice to go back, however, it does not fix the second issue. If I go to the YouTube homepage, click on a video, then go back to the homepage again, the forward button flickers on briefly, but then is greyed out so I can't go forward. Can I try a fresh installation of Firefox in a different directory, so I can test it with totally default settings?
Nellus 68 solutions 634 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

Thank you.

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. <br> '''Note''': ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us! Thank you.

Question owner

AdBlock Plus is what's causing the back button issue. With that extension disabled, I do not have to click back twice on YouTube.

But I really don't want to reset Firefox to factory settings to try fixing the other issue if I can help it. I've spent ages getting the program set up how I like it and I really don't want to start over. Is it not possible just to install a second instance of Firefox in a different directory, just to see if it happens with that too?

AdBlock Plus is what's causing the back button issue. With that extension disabled, I do not have to click back twice on YouTube. But I really don't want to reset Firefox to factory settings to try fixing the other issue if I can help it. I've spent ages getting the program set up how I like it and I really don't want to start over. Is it not possible just to install a second instance of Firefox in a different directory, just to see if it happens with that too?

Question owner

OK, I tried the factory reset of Firefox and the forward issue still persists on YouTube. How annoying.

OK, I tried the factory reset of Firefox and the forward issue still persists on YouTube. How annoying.
Nellus 68 solutions 634 answers

Helpful Reply

sorry but only now i see your reply. you can create a new firefox profile as you wrote in the post before, sorry my bad. See Profile Manager - Create, remove, or switch Firefox profiles

sorry but only now i see your reply. you can create a new firefox profile as you wrote in the post before, sorry my bad. See [[Use the Profile Manager to create and remove Firefox profiles]]

Question owner

Thanks for the reply, but I already reset Firefox to the default settings and the issue still persists. It must be a bug in the program.

Thanks for the reply, but I already reset Firefox to the default settings and the issue still persists. It must be a bug in the program.
Nellus 68 solutions 634 answers
Create a new profile. see [[Use the Profile Manager to create and remove Firefox profiles]]

Question owner

Nope, that doesn't fix it either.

Here's a GIF that shows the issue occurring with a fresh profile: -

http://i.imgur.com/OhpEDfX.gif

Steps to reproduce: -

1. Visit the YouTube homepage. 2. Click on any video and watch a bit of it. 3. Click the back button to go back to the homepage. 4. The forward button while light up briefly, but then will be greyed out so it's not clickable.

Nope, that doesn't fix it either. Here's a GIF that shows the issue occurring with a fresh profile: - http://i.imgur.com/OhpEDfX.gif Steps to reproduce: - 1. Visit the YouTube homepage. 2. Click on any video and watch a bit of it. 3. Click the back button to go back to the homepage. 4. The forward button while light up briefly, but then will be greyed out so it's not clickable.
Nellus 68 solutions 634 answers

You can check for problems with the places.sqlite database file in the Firefox profile folder.

 1.  http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox
  2. https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file

You can try to check and repair the places database with this extension:

   https://addons.mozilla.org/firefox/addon/places-maintenance/
You can check for problems with the places.sqlite database file in the Firefox profile folder. 1. http://kb.mozillazine.org/Bookmarks_history_and_toolbar_buttons_not_working_-_Firefox 2. https://support.mozilla.org/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file You can try to check and repair the places database with this extension: https://addons.mozilla.org/firefox/addon/places-maintenance/

Modified by Nellus

Question owner

That extension found no issues, but I ran it again with "all" checked, but the problem still persists.

That extension found no issues, but I ran it again with "all" checked, but the problem still persists.
Andrew
  • Moderator
321 solutions 4041 answers

Hello,

Are cookies and cache enabled as well as history? Try clearing cache and cookies:

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Are cookies and cache enabled as well as history? Try clearing cache and cookies: Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back to us! Thank you.
jscher2000
  • Top 10 Contributor
8690 solutions 71031 answers

The first GIF seemed to be redirecting from an HTTP history entry to an HTTPS page, which if not done using the window.replace() script command will add a history entry (i.e., an extra click on the back button would be required).

In the second GIF, does that language selection thing appear every time? Can you find a way to accept or dismiss that to make sure it isn't causing the problem?

The first GIF seemed to be redirecting from an HTTP history entry to an HTTPS page, which if not done using the window.replace() script command will add a history entry (i.e., an extra click on the back button would be required). In the second GIF, does that language selection thing appear every time? Can you find a way to accept or dismiss that to make sure it isn't causing the problem?
cor-el
  • Top 10 Contributor
  • Moderator
17469 solutions 157871 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History).

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

(note that a reset tries to import cookies and thus can carry over issues with cookies)

Make sure that you do not run Firefox in (permanent) Private Browsing mode (Never Remember History). *https://support.mozilla.org/kb/Private+Browsing *Tools > Options > Privacy > Firefox will: "Use custom settings for history" *Deselect: [ ] "Always use private browsing mode" ---- If clearing cookies doesn't work then it is possible that the <i>cookies.sqlite</i> file that stores the cookies is corrupted. Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookie files like <b>cookies.sqlite-journal</b> in the Firefox profile folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies ''(note that a reset tries to import cookies and thus can carry over issues with cookies)''

Modified by cor-el