X
Tap here to go to the mobile version of the site.

Support Forum

Firefox shows a blinking "edit" cursor in the body of all websites when I click.

Posted

Clicking a button within a webpage puts a blinking text cursor in the body of the site, as if editing a Word document. It's not causing any other problems besides being really annoying and distracting, but it only just started today. I've tried restarting Firefox with add-ons disabled, as well as reinstalling Firefox clean.

Clicking a button within a webpage puts a blinking text cursor in the body of the site, as if editing a Word document. It's not causing any other problems besides being really annoying and distracting, but it only just started today. I've tried restarting Firefox with add-ons disabled, as well as reinstalling Firefox clean.

Chosen solution

In addition to the above:

This is likely caused by switching on caret browsing and you can toggle caret browsing on/off by pressing F7 (Mac: fn + F7).

Note that this is an accessibility feature of Firefox.

  • Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"
Read this answer in context 17

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Google Update
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.7.0.15362
  • 5.1.20913.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • EasyAccent 0.65 ({c83e39e0-6f38-4bea-9809-eaf31172c46a})
  • NoScript 2.6.8.3 ({73a6fe31-595d-460b-a920-fcc0f8843232})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • HP Smart Web Printing 4.60 (smartwebprinting@hp.com) (Inactive)
  • Norton Toolbar 2013.4.3.7 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.0.2.8 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)
  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2: NVIDIA GeForce GT 540M
  • adapterDeviceID: 0x0116
  • adapterDeviceID2: 0x0df4
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumdx32 igd10umd32 igd10umd32
  • adapterDrivers2: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterRAM: Unknown
  • adapterRAM2: 1023
  • adapterVendorID: 0x8086
  • adapterVendorID2: 0x10de
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-26-2011
  • driverDate2: 10-16-2012
  • driverVersion: 8.15.10.2430
  • driverVersion2: 9.18.13.721
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.browsewithcaret: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=714647
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • keyword.URL: http://search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&ilc=12&type=714647&p=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1382232986
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1381707802

Misc

  • User JS: No
  • Accessibility: No
firefoxmunchkin 0 solutions 2 answers

Helpful Reply

1. try pressing F7 2. system restore

1. try pressing F7 2. system restore
cor-el
  • Top 10 Contributor
  • Moderator
13043 solutions 119425 answers

Chosen Solution

In addition to the above:

This is likely caused by switching on caret browsing and you can toggle caret browsing on/off by pressing F7 (Mac: fn + F7).

Note that this is an accessibility feature of Firefox.

  • Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages"
In addition to the above: This is likely caused by switching on caret browsing and you can toggle caret browsing on/off by pressing F7 (Mac: fn + F7). *http://kb.mozillazine.org/accessibility.browsewithcaret Note that this is an accessibility feature of Firefox. *Tools > Options > Advanced > General > Accessibility: [ ] "Always use the cursor keys to navigate within pages" *http://kb.mozillazine.org/Scrolling_with_arrow_keys_no_longer_works *http://kb.mozillazine.org/Accessibility_features_of_Firefox