X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox is my default browser but when I click on a link in mail it no longer will open.

Posted

Firefox is my default browser. It always opened links from email in Firefox. Now, suddenly, when I click on a link in email, it no longer opens. If I make Chrome default, it will open in that browser. I've tried switching back a couple of times after reboot, but links no longer open in firefox. I don't know what happened to change it.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 r900
  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • GEPlugin
  • 5.1.20513.0
  • Coupons, Inc. Coupon Printer Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Aniello 75 solutions 633 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information.
Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

I tried resetting Firefox already and then tried to see if a link from email would open in Firefox, but they still don't open. I switched back to chrome and they open. Switch back to Firefox as default and they don't open.

Resetting didn't fix the problem.

Aniello 75 solutions 633 answers

The symptoms sound like Firefox thinks its the default browser, but it actually isn't. Try setting IE as the default browser then reboot your pc, verify that works with Thunderbird, and then reset Firefox as the default browser and reboot again your pc. See http://kb.mozillazine.org/Default_browser

Question owner

I don't use IE. I have done that with Chrome. I set Chrome as my default browser and have rebooted and links open in Chrome. Then I set it back to Firefox and it doesn't work.

Question owner

I also used the force Firefox to make itself default instructions and that didn't work either. I guess I'm stuck with Chrome as my default.

Aniello 75 solutions 633 answers

Select the link and then right click on it,choose "open with.." and select firefox.

Question owner

When I right click a link in email I don't get that option. I'm using Incredimail in case that makes a difference.

Aniello 75 solutions 633 answers

My personally advise is to download thunderbird and use it for your email .... the onely negative is their is no way to copy anything from Incredimail to another software ...

i found this thread,maybe solve the problem

To make Firefox use Incredimail for mailto links, do the following.

1. find the path to Incredimail on my Windows 7 machine it's: "C:\Program Files (x86)\IncrediMail\Bin\IncMail.exe" (you can find this by right clicking on the desktop Incredimail Icon and selecting Properties. Copy this address))

2. Type about:config into your Firefox location bar and hit enter. If you've never edited used about:config before, you'll see a warning.

3. Click "I'll be careful, I promise!" This will bring you to the about:config window.

4. In the filter field type "gecko". Find the entry gecko.handlerService.schemes.mailto.0.name;

5. Right click and select Modify.

6. Paste or type the Incredimail path in the field provided "C:\Program Files (x86)\IncrediMail\Bin\IncMail.exe" (the qoutes are required)

7. Make sure that network.protocol-handler.external.mailto; is set to true.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

If you use an external password manager, a problem has been noted with some versions where there is either a very long delay in opening an external link or it never opens at all. Threads on that:

Question owner

I appreciate all the help, but nothing seems to be working.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can check the network.protocol-handler.external.mailto prefs on the about:config page.

If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

Question owner

I tried that and reset them all to default. Still won't work. But thanks.

Calumet 0 solutions 2 answers

Helpful Reply

Holy Mackerel, I may have solved the problem!

The key appears to be Windows 7, not Explorer or Firefox.

Go to Start menu and pick "Default Programs" Choose "Set Your Default Programs". Select "Firefox" from the list to the left Click on "Set this program as default"

Without exiting window, choose "Thunderbird" from same list at the left. Click "Set this program as default"

Then click "OK" button at bottom right of window.

I did not have to reboot. Hope this works for you!

thezorg 0 solutions 1 answers

Helpful Reply

This problem just arose for me today. Very frustrating. Tried all of the suggestions here without success. Then a very simple solution came to me:

UNINSTALL CHROME. I haven't used Chrome for a long while anyway since it seems to have chronic problems of one sort or another. Firefox does 95% of what I need, and Internet Explorer can handle the other 5%.

After uninstalling Chrome I clicked a mailto link. It asked me what program to use and did not list Firefox as an option for some reason. In the Tools menu, I chose "Options" and went to the "Applications" tab. Searched for "mailto". There was a single entry - when Chrome was installed it gave me no options to switch. After uninstalling Chrome I was able to change that. It still did not list Firefox, but it did list "Gmail". Selecting that causes my Gmail to open in Firefox.

I have no idea whether Google or Microsoft is responsible for this, but I'm inclined to give the hairy eyeball to Google for this one. It's the sort of stunt they'd pull on Microsoft, then pretend it was just a mistake. Just one guy's opinion, of course.

Snapafun 0 solutions 6 answers

When reading this I went to the config editor in thunderbird and found that two network.protocols had been 'customized'. I reset these and now things are working again. Type a search query inside config editor "network.protocol-handler.external" (no quotes) and anything in bold black has been customized. Right click on them and select 'Reset'. Close the editor and try another link. This of course assumes that you have ensured all the default browser stuff has been done.

susankuchinskas 0 solutions 2 answers

Resetting FIrefox didn't work for me, either. BTW, the email is a red herring, because formerly I could control-click live links from word docs and that's not working, either.

"Use a different program" or "take more steps to get the same result" are really unsatisfactory answers. BTW right-clicking the link in Word and choosing "open" doesn't work, either.

I hope this isn't some "upgrade" to Firefox.

jscher2000
  • Top 10 Contributor
2368 solutions 20966 answers

Hi susankuchinskas, there are several different suggestions offered by different posters in this thread relating to everything from add-ons to other browsers. If none of those is helpful, please start a new question at the following link. Scroll down past the suggestions to continue with the form (I think it has 3 different screens). https://support.mozilla.org/en-US/questions/new/desktop/fix-problems

susankuchinskas 0 solutions 2 answers

Thanks for the tip on how best to use the forum, jscher2000. I've tried everything here on the list; links do not open from Outlook nor Word; they do open from within webmail on Firefox. I don't understand why asking the question again would be good. But I appreciate the forum and the discussion?

listert 0 solutions 1 answers

I had this problem on my new macbook Solved it by going to Thunderbird, preferences, attachments and changing http/https settings from Firefox(default) to my actual Firefox app. I'd copied my profile over from PC so that may have been an issue

Newbeak 1 solutions 42 answers

I have had the same problem,and clicking on links in TB opens them in Opera.I have Win 7,and set my default programs to Firefox and Thunderbird,clicked "Ok",and that fixed it!