Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open links in Firefox

  • 5 replies
  • 20 have this problem
  • Last reply by Calumet

more options

I have Firefox 24.0 & Windows 7.

Recently, yesterday or the day before, some problems developed with Firefox. 1. Formerly, if I clicked a link in Word, it would open in Firefox. Now, when I hover over a link in Word, the arrow changes to a hand, the box appears showing the URL of the link, I click, the link changes colors, but nothing opens in FIrefox.

2. The same problem occurs with links in emails. (I use Outlook 2000 by the way.)

3. This problem may or may not be related. I was having a problem with Firefox crashing alot & also some other problem. So I uninstalled it & redownloaded it, & re-installed it. But when I opened it up, it was just the same thing. But a few weeks ago, for some reason all of a sudden Firefox 24.0 appeared.

Formerly, I had Lastpass installed in Firefox. But it isn't in the upgraded 24.0. So I tried installing it according to directions received from Lastpass. I go through the whole wizard & it says it installed successfully. But it isn't there. It still isn't in Firefox.

I went to & logged in. There was a message that said I needed to install the plugin to have full functionality. So I clicked on the link & clicked any subsequent clicks I needed to click, thinking that maybe this would solve the problem. Again, it said installation was successful, but it still is not in Firefox.

So, I'm having two problems basically. First, links in Word & emails are not opening in Firefox. Secondly, Lastpass is not installing, even though it says it is.

Thanks. PS: Automatically adding the troubleshooter just now didn't work either, even though it said it did, just like with Lastpass. So, I copied and pasted all the stuff in the next window manually from

All Replies (5)

more options
more options

Your LastPass extension is set to Disabled for some reason. You can re-enable it here:

orange Firefox button (or Tools menu) > Add-ons > on the left side click Extensions

Does that work (use the link to restart if that appears above the extension)?

Edit: Forgot to mention, disabled extensions cluster at the bottom below all the enabled extensions (A-Z, A-Z again).

Modified by jscher2000

more options

Regarding links in external programs and LastPass, a recent thread might be relevant: Firefox very slow to open external links when Dashlane, Lastpass or eWallet extensions are installed. Not solved, unfortunately.

more options

Thank you very much. It works now. Here is what happened:

I uninstalled Lastpass from my programs folder. It wasn't installed in FF, but it was in the programs folder. After uninstalling, my links in Word & in my emails worked--FF opened when I clicked them. So I thought I might have to do without Lastpass. But I thought I would try it one more time.

So I downloaded the Lastpass installation file again. It is named the same as what I already have on my computer, lastpass_x64.exe. There must have been something wrong with the one that I had downloaded previously because this time, when I used the newly downloaded file to install Lastpass, there was an extra step at the end of the process that didn't appear before.

I had to click a link that opened a browser window that had a button in it. The button said to click it to install Lastpass. I did and I don't remember the whole thing now, but I had to do a few clicks individually for FF & Chrome. None of this happened previously when I installed Lastpass. And Lastpass wasn't appearing or working in either FF or Chrome.

Now I have Lastpass installed in both FF & Chrome & all my links in Word & in my emails still work too! Thanks again.

more options

The key might be Windows 7, not Explorer or Firefox.

Go to Start menu and pick "Default Programs" Choose "Set Your Default Programs". Select "Firefox" from the list to the left Click on "Set this program as default"

Without exiting window, choose "Thunderbird" from same list at the left. Click "Set this program as default"

You can do this with as many programs as you like.

Then click "OK" button at bottom right of window.

I did not have to reboot. Hope this works for you!