X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't open links in Firefox

Posted

I have Firefox 24.0 & Windows 7.

Recently, yesterday or the day before, some problems developed with Firefox. 1. Formerly, if I clicked a link in Word, it would open in Firefox. Now, when I hover over a link in Word, the arrow changes to a hand, the box appears showing the URL of the link, I click, the link changes colors, but nothing opens in FIrefox.

2. The same problem occurs with links in emails. (I use Outlook 2000 by the way.)

3. This problem may or may not be related. I was having a problem with Firefox crashing alot & also some other problem. So I uninstalled it & redownloaded it, & re-installed it. But when I opened it up, it was just the same thing. But a few weeks ago, for some reason all of a sudden Firefox 24.0 appeared.

Formerly, I had Lastpass installed in Firefox. But it isn't in the upgraded 24.0. So I tried installing it according to directions received from Lastpass. I go through the whole wizard & it says it installed successfully. But it isn't there. It still isn't in Firefox.

I went to www.lastpass.com & logged in. There was a message that said I needed to install the plugin to have full functionality. So I clicked on the link & clicked any subsequent clicks I needed to click, thinking that maybe this would solve the problem. Again, it said installation was successful, but it still is not in Firefox.

So, I'm having two problems basically. First, links in Word & emails are not opening in Firefox. Secondly, Lastpass is not installing, even though it says it is.

Thanks. PS: Automatically adding the troubleshooter just now didn't work either, even though it said it did, just like with Lastpass. So, I copied and pasted all the stuff in the next window manually from https://support.mozilla.org/en-US/questions/new/desktop/get-started/form?search=Can%27t+open+links+in+Firefox&step=aaq-question#troubleshooting-help

Additional System Details

Application

  • User Agent:

More Information

* Shockwave Flash 11.9 r900
* Shockwave Flash 11.8 r800
* Next Generation Java Plug-in 10.40.2 for Mozilla browsers
* NPRuntime Script Plug-in Library for Java(TM) Deploy
* Adobe PDF Plug-In For Firefox and Netscape 10.1.8
* VLC media player Web Plugin 2.0.6
* Google Update
* GEPlugin
* Citrix Online App Detector Plugin
* 5.1.20513.0
* NPWLPG
* The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
* The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
* The plug-in allows you to open and edit files using Microsoft Office applications
* Office Authorization plug-in for NPAPI browsers
{
"application": {
"name": "Firefox",
"version": "24.0",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0",
"supportURL": "https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/"
},
"modifiedPreferences": {
"accessibility.typeaheadfind.flashBar": 0,
"browser.cache.disk.capacity": 358400,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage_override.mstone": "24.0",
"browser.startup.homepage": "https://www.google.com/",
"browser.startup.homepage_override.buildID": "20130910160258",
"dom.mozApps.used": true,
"extensions.lastAppVersion": "24.0",
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_current_max_pages": 104858,
"places.database.lastMaintenance": 1381246357,
"plugin.importedState": true,
"plugin.disable_full_page_plugin_for_types": "application/pdf,audio/x-m4b",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_right": "0.5",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_bgimages": false,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_right": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_reversed": false,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_resolution_name": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_plex_name": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_size_unit": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_right": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_top": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_height": " 11.00",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_bgcolor": false,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_evenpages": true,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_headerright": "&U",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_bottom": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_in_color": true,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_top": "0.5",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_command": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_footerright": "&D",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_left": "0.5",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_width": " 8.50",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_downloadfonts": false,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_resolution": 388766556,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_name": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_headercenter": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_left": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_shrink_to_fit": true,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_scaling": " 1.00",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_footercenter": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_duplex": -920413904,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_footerleft": "&PT",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_bottom": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_headerleft": "&T",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_margin_bottom": "0.5",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_data": 1,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_edge_left": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_paper_size_type": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_page_delay": 50,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_unwriteable_margin_top": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_colorspace": "",
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_orientation": 0,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_to_file": false,
"print.printer_HP_LaserJet_Professional_M1212nf_MFP.print_oddpages": true,
"privacy.sanitize.migrateFx3Prefs": true,
"storage.vacuum.last.places.sqlite": 1380648841,
"storage.vacuum.last.index": 1
},
"graphics": {
"numTotalWindows": 2,
"numAcceleratedWindows": 2,
"windowLayerManagerType": "Direct3D 9",
"windowLayerManagerRemote": false,
"adapterDescription": "ATI Radeon HD 4200 ",
"adapterVendorID": "0x1002",
"adapterDeviceID": "0x9710",
"adapterRAM": "256",
"adapterDrivers": "aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64",
"driverVersion": "8.733.0.0",
"driverDate": "5-11-2010",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": false,
"directWriteEnabled": false,
"directWriteVersion": "6.2.9200.16571",
"direct2DEnabledMessage": [
"tryNewerDriver",
"10.6"
],
"webglRenderer": "Google Inc. -- ANGLE (ATI Radeon HD 4200 Direct3D9Ex vs_3_0 ps_3_0)",
"info": {
"AzureCanvasBackend": "skia",
"AzureFallbackCanvasBackend": "cairo",
"AzureContentBackend": "none"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.10",
"version": "4.10"
},
"NSS": {
"minVersion": "3.15.1 Basic ECC",
"version": "3.15.1 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.15.1",
"version": "3.15.1"
},
"NSSSSL": {
"minVersion": "3.15.1 Basic ECC",
"version": "3.15.1 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.15.1 Basic ECC",
"version": "3.15.1 Basic ECC"
}
},
"userJS": {
"exists": false
},
"extensions": [
{
"name": "Add to Amazon Wish List Button",
"version": "1.10",
"isActive": true,
"id": "amznUWL2@amazon.com"
},
{
"name": "ColorZilla",
"version": "2.8",
"isActive": true,
"id": "{6AC85730-7D0F-4de0-B3FA-21142DD85326}"
},
{
"name": "OutWit Hub",
"version": "2.1.2.23",
"isActive": true,
"id": "outwit-hub-1110@outwit.com"
},
{
"name": "SeoQuake",
"version": "2.8.12.1",
"isActive": true,
"id": "{317B5128-0B0B-49b2-B2DB-1E7560E16C74}"
},
{
"name": "Troubleshooter",
"version": "1.1a",
"isActive": true,
"id": "troubleshooter@mozilla.org"
},
{
"name": "Web Developer",
"version": "1.2.5",
"isActive": true,
"id": "{c45c406e-ab73-11d8-be73-000a95be3b12}"
},
{
"name": "LastPass",
"version": "2.5.0",
"isActive": false,
"id": "support@lastpass.com"
}
]
}

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Make sure that Firefox is set correctly as the default browser.

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Your LastPass extension is set to Disabled for some reason. You can re-enable it here:

orange Firefox button (or Tools menu) > Add-ons > on the left side click Extensions

Does that work (use the link to restart if that appears above the extension)?

Edit: Forgot to mention, disabled extensions cluster at the bottom below all the enabled extensions (A-Z, A-Z again).

Modified by jscher2000

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Helpful Reply

Regarding links in external programs and LastPass, a recent thread might be relevant: Firefox very slow to open external links when Dashlane, Lastpass or eWallet extensions are installed. Not solved, unfortunately.

Helpful Reply

Thank you very much. It works now. Here is what happened:

I uninstalled Lastpass from my programs folder. It wasn't installed in FF, but it was in the programs folder. After uninstalling, my links in Word & in my emails worked--FF opened when I clicked them. So I thought I might have to do without Lastpass. But I thought I would try it one more time.

So I downloaded the Lastpass installation file again. It is named the same as what I already have on my computer, lastpass_x64.exe. There must have been something wrong with the one that I had downloaded previously because this time, when I used the newly downloaded file to install Lastpass, there was an extra step at the end of the process that didn't appear before.

I had to click a link that opened a browser window that had a button in it. The button said to click it to install Lastpass. I did and I don't remember the whole thing now, but I had to do a few clicks individually for FF & Chrome. None of this happened previously when I installed Lastpass. And Lastpass wasn't appearing or working in either FF or Chrome.

Now I have Lastpass installed in both FF & Chrome & all my links in Word & in my emails still work too! Thanks again.

Calumet 0 solutions 2 answers

The key might be Windows 7, not Explorer or Firefox.

Go to Start menu and pick "Default Programs" Choose "Set Your Default Programs". Select "Firefox" from the list to the left Click on "Set this program as default"

Without exiting window, choose "Thunderbird" from same list at the left. Click "Set this program as default"

You can do this with as many programs as you like.

Then click "OK" button at bottom right of window.

I did not have to reboot. Hope this works for you!