X
Tap here to go to the mobile version of the site.

Support Forum

JavaScript blocked or failed to load

Posted

Hello, Sometime ago I suddenly realized that JavaScript was not working in my Firefox. I get a very explicit error message from Stack Overflow:

"Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load."

Many other websites also do not work.

I currently am running Windows 7 and on typing "java -version", I get the following output:

java version "1.7.0_40" Java(TM) SE Runtime Environment (build 1.7.0_40-b43) Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

I know Java is installed and working because I can compile and run .java files from NetBeans.

I am in a fix as I have spent many hours troubleshooting this problem but could not solve it. I am very hopeful for a solution here.

Thanks

Hello, Sometime ago I suddenly realized that JavaScript was not working in my Firefox. I get a very explicit error message from Stack Overflow: "Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load." Many other websites also do not work. I currently am running Windows 7 and on typing "java -version", I get the following output: java version "1.7.0_40" Java(TM) SE Runtime Environment (build 1.7.0_40-b43) Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode) I know Java is installed and working because I can compile and run .java files from NetBeans. I am in a fix as I have spent many hours troubleshooting this problem but could not solve it. I am very hopeful for a solution here. Thanks

Chosen solution

cor-el I was experimenting and installed Firefox 25 Beta 3 and all JavaScript are working fine.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.9 d900
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The plugin allows you to have a better experience with Microsoft Lync
  • VLC media player Web Plugin 2.0.6
  • Nokia Suite Enabler Plugin
  • Shockwave Flash 11.7 r700
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • The plugin allows you to have a better experience with Microsoft SharePoint

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Adblock Plus Pop-up Addon 0.9.1 (adblockpopups@jessehakanen.net)
  • DownloadHelper 4.9.21 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • DownThemAll! 2.0.16 ({DDC359D1-844A-42a7-9AA1-88A850A938A8})
  • LastPass 2.0.20 (support@lastpass.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Xmarks 4.2.1 (foxmarks@kei.com)
  • avast! Online Security 8.0.1489 (wrc@avast.com) (Inactive)
  • IDM CC 7.3.59 (mozilla_cc@internetdownloadmanager.com) (Inactive)
  • Skype Click to Call 6.10.0.13089 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)
  • WordWeb one-click lookup 5.0.1701 (wcapturex@deskperience.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 3000
  • adapterDescription2:
  • adapterDeviceID: 0x0116
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 3-8-2013
  • driverDate2:
  • driverVersion: 9.17.10.3062
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 24.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1380776007
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 0
  • storage.vacuum.last.places.sqlite: 1380755555

Misc

  • User JS: No
  • Accessibility: No
user830406 17 solutions 209 answers

For your information Java and Javascript are completely different, so having java in doesn't gives any advantage for javascript nor it needs java.

Coming on to you problem


I think you have problem with Cross-domain Content Scripts

By default, content scripts don't have any cross-domain privileges. In particular, they can't:

  1. access content hosted in an iframe, if that content is served from a different domain
  2. make cross-domain XMLHttpRequests

Check this article on mozilla addons for additional info Cross-domain Content Scripts

For your information Java and Javascript are completely different, so having java in doesn't gives any advantage for javascript nor it needs java. Coming on to you problem ------------------------------------ I think you have problem with '''Cross-domain Content Scripts''' By default, content scripts don't have any cross-domain privileges. In particular, they can't: # access content hosted in an iframe, if that content is served from a different domain # make cross-domain XMLHttpRequests Check this article on mozilla addons for additional info [https://addons.mozilla.org/en-US/developers/docs/sdk/Firefox-24/dev-guide/guides/content-scripts/cross-domain.html Cross-domain Content Scripts]
jscher2000
  • Top 10 Contributor
3260 solutions 29723 answers

Helpful Reply

Firefox has a single global setting for JavaScript: either it's enabled or it isn't. If JavaScript works on any site, then that setting should be fine. If you're not sure, you can check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste java and pause while the list is filtered

(3) If javascript.enabled is not set to its default value of true, double-click it to switch it back to true.


Firefox does not have a user interface for applying site-specific scripting restrictions, but this can be done using extensions or using "capability" preferences. I don't see the best known script blockers on your extension list (NoScript, YesScript, Controle De Scripts) so I suggest checking for the hidden preferences first.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Scroll down to prefs.js and open it in a text editor (note: you can't save changes while Firefox is running, but you can exit Firefox if you find something you need to edit out)

Search for capab (the beginning of the word capability). Do you find any preferences that contain capability and javascript and noAccess? If so, that may explain why scripts cannot run on some sites. Feel free to post those lines here for analysis.


To test the extension possibility, could you try some of the problem sites in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any change?

Firefox has a single global setting for JavaScript: either it's enabled or it isn't. If JavaScript works on any site, then that setting should be fine. If you're not sure, you can check here: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''java''' and pause while the list is filtered (3) If '''javascript.enabled''' is not set to its default value of true, double-click it to switch it back to true. ---- Firefox does not have a user interface for applying site-specific scripting restrictions, but this can be done using extensions or using "capability" preferences. I don't see the best known script blockers on your extension list (NoScript, YesScript, Controle De Scripts) so I suggest checking for the hidden preferences first. Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show Folder" button Scroll down to prefs.js and open it in a text editor (note: you can't save changes while Firefox is running, but you can exit Firefox if you find something you need to edit out) Search for '''capab''' (the beginning of the word capability). Do you find any preferences that contain capability and javascript and noAccess? If so, that may explain why scripts cannot run on some sites. Feel free to post those lines here for analysis. ---- To test the extension possibility, could you try some of the problem sites in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any change?

Question owner

anushbmx, thanks for the article, and yes are right Java and JavaScript are different. So I wasn't able to derive any meaning from all that. Still stuck.

jscher2000 I could not find anything related to capab in pref.js . And I have already tried to Troubleshoot Firefox issues using Safe Mode. It didn't work out. Thanks for the help anyway.

So, is there any other way possible? I'm ready to try anything.

anushbmx, thanks for the article, and yes are right Java and JavaScript are different. So I wasn't able to derive any meaning from all that. Still stuck. jscher2000 I could not find anything related to capab in pref.js . And I have already tried to Troubleshoot Firefox issues using Safe Mode. It didn't work out. Thanks for the help anyway. So, is there any other way possible? I'm ready to try anything.

Modified by vijendra4

cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

You can try to set the security.csp.enable pref temporarily to false on the about:config page to see if that helps.

You can try to set the security.csp.enable pref temporarily to false on the <b>about:config</b> page to see if that helps. *http://kb.mozillazine.org/about:config

Question owner

cor-el, not setting security.csp.enable to false did not work.

cor-el, not setting security.csp.enable to false did not work.
ideato
  • Top 25 Contributor
715 solutions 5228 answers

Hello, is it possible Adblock Plus or Adblock Plus Pop-up to blocks javascript ? I don't use it and i don't known ! just a guess ?!

thank you

Hello, is it possible Adblock Plus or Adblock Plus Pop-up to blocks javascript ? I don't use it and i don't known ! just a guess ?! thank you
cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked.

You can use the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) to check the Net log to see if any content is blocked or fails to load.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes ---- If content is missing or otherwise not working when a secure https connection is used then check if there is a shield icon to the left of the "Site Identity Button" (globe/padlock) on the location bar indicating that content is blocked. You can use the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K) to check the Net log to see if any content is blocked or fails to load.
user830406 17 solutions 209 answers

ideato can be correct, ad blocker or Ad blocker plus will block javascript if the domain from which it's served from is listed in block list, try to use the website with these disabled or use incognito window.

ideato can be correct, ad blocker or Ad blocker plus will block javascript if the domain from which it's served from is listed in block list, try to use the website with these disabled or use incognito window.

Question owner

cor-el and anushbmx, I checked in safe mode also, still gives the same error message.

NOTE: I checked on 3 of my friends, there Firefox 24 ALSO shows the same warning given by Stack Overflow. How is that possible?

cor-el and anushbmx, I checked in safe mode also, still gives the same error message. NOTE: I checked on 3 of my friends, there Firefox 24 ALSO shows the same warning given by Stack Overflow. How is that possible?
cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Can you post a link to a publicly accessible page that doesn't require authentication (signing on)?

Question owner

cor-el, I'm not sure why you are asking this, but I found these: http://www.omegle.com/

http://keepvid.com/

cor-el, I'm not sure why you are asking this, but I found these: http://www.omegle.com/ http://keepvid.com/

Modified by vijendra4

user830406 17 solutions 209 answers

I don't know what omegle.com is but keepvid.com is a video downloader that requires java runtime installed on your machine to make the video download link.

This is not a problem with firefox

I don't know what omegle.com is but keepvid.com is a video downloader that requires java runtime installed on your machine to make the video download link. This is not a problem with firefox

Question owner

anushbmx, cor-el asked me to post a link to a publicly accessible page that doesn't require authentication (signing on).

He did not mention Java or JavaScript or a website that is problematic with Firefox at all.

If you want, then

http://stackoverflow.com/ gives me error - "Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load."

And I cannot see search results, cannot post question in http://answers.semanticweb.com/ because JavaScript is disabled.

anushbmx, cor-el asked me to post a link to a publicly accessible page that doesn't require authentication (signing on). He did not mention Java or JavaScript or a website that is problematic with Firefox at all. If you want, then http://stackoverflow.com/ gives me error - "Stack Overflow requires external JavaScript from another domain, which is blocked or failed to load." And I cannot see search results, cannot post question in http://answers.semanticweb.com/ because JavaScript is disabled.
cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

Do you see any blocked files in the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K)?

You can open the Network tab in the Web Console and refresh the page via F5 to see if there are any files not loaded.

Do you see any blocked files in the Web Console (Firefox/Tools > Web Developer;Ctrl+Shift+K)? *https://developer.mozilla.org/en/Tools/Web_Console You can open the Network tab in the Web Console and refresh the page via F5 to see if there are any files not loaded.

Question owner

This is what I got after pressing F5 on stackoveflow.com in Network tab.

This is what I got after pressing F5 on stackoveflow.com in Network tab.
cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

Hmm. This looks that you are experiencing some circular redirect or you might be blocking files from some locations.

Did you try to click those items to check the server response?

Hmm. This looks that you are experiencing some circular redirect or you might be blocking files from some locations. Did you try to click those items to check the server response?

Modified by cor-el

jscher2000
  • Top 10 Contributor
3260 solutions 29723 answers

The host ironport6 sounds like a proxy that companies may use for content filtering. ??

The host ironport6 sounds like a proxy that companies may use for content filtering. ??
cor-el
  • Top 10 Contributor
  • Moderator
12331 solutions 114053 answers

Why doesn't ajax.googleapis.com work?

Does this work in other browsers?

Did you check the hosts file?

Why doesn't ajax.googleapis.com work? Does this work in other browsers? Did you check the hosts file? *http://kb.mozillazine.org/Error_loading_websites

Chosen Solution

cor-el I was experimenting and installed Firefox 25 Beta 3 and all JavaScript are working fine.

cor-el I was experimenting and installed Firefox 25 Beta 3 and all JavaScript are working fine.
TheDarkPassenger 0 solutions 1 answers

I have the same problem on the same website as above, but using Firefox 26.0. Have tried adding the site to add-block's 'white'-list etc - no luck.

Any new ideas?

I have the same problem on the same website as above, but using Firefox 26.0. Have tried adding the site to add-block's 'white'-list etc - no luck. Any new ideas?