X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do i make Firefox STOP frequently logging me out of sites when I chose "remember me"?

Posted

I have FF 24.0 now but this has happened through multiple versions, and its getting more and more frequent. (Win 7x64, 8G ram, 1T drive)

I always check "remember me" and "save this password" yet sites like Facebook, Google+ and many others keep logging me out, at *least* every other day and sometimes multiple times a day, so I have to login all over again- today I had the frustration of being logged out of a forum with each refresh of a page! (I'm logged in, hit "reply" and suddenly, "sorry you must login to do that!" HUH?)

I dont care if cookies never expire, and no one else but my husband has access to my computer and we know each other's passwords anyway.

I am hoping I can fix this without either reinstalling firefox or deleting the profile, because I have a pretty large bookmark file and about 9 add ons to reinstall, plus various plug ins!

I am starting to suspect its related to running out of cache space- sites can't seem to remember me when the cache is full?! , since its frequently at max (it was saying 350 max, now it says 500), I clear the cache whenever I notice its full. I did not clear it today until after it logged me out multiple times.

Chosen solution

Firefox should automatically trim the cache for you when it nears fullness. This wouldn't affect your cookies.

One possibility is that cookies are being cleared or expired out at certain intervals by an add-on or by external software.

Another possibility is that there is some kind of conflict or corruption with your cookies. You can delete all the cookies for a particular site (e.g., Google) using the Page Info dialog. While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Hopefully after your next login any conflict or corruption will be resolved.

I also notice you have an extension that presumably logs into to Gmail on your behalf. As a test, try disabling X-notifier here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Usually a link will appear above a disabled extension to restart Firefox. If so, that is necessary for the change to take effect.

Any improvement?


Some sites not only check the cookie but also other details of your connection such as your computer's IP address. If it changes then you may be required to re-authenticate. This has been reported in some cases with Yahoo or AOL-network sites (including Huffington Post) when Firefox's connection setting is set to "Auto-detect". You can check that here:

orange Firefox button (or Tools menu) > Options > Advanced > "Network" mini-tab > "Settings" button

The default setting is "Use system proxy settings" and you also could try "No proxy."

If you use an anonymizing service or private VPN to disguise your true IP address, that also could be an issue.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Foxit Reader Plug-In For Firefox and Netscape
  • Garmin Communicator Plug-In 4.0.4.0
  • Garmin Communicator Plug-In 2.9.2.0

Application

  • Firefox 24.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0
  • Support URL: https://support.mozilla.org/1/firefox/24.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.3.2 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Garmin Communicator 4.0.4 ({195A3098-0BD5-4e90-AE22-BA1C540AFD1E})
  • Greasemonkey 1.11 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • Reddit Enhancement Suite 4.3.0.4 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Remember Passwords 1.1 (remember-passwords@stanimir-stamenkov.addons.mozilla.org)
  • ReminderFox 2.1.2 ({ada4b710-8346-4b82-8199-5de2b400a6ae})
  • Social Fixer 7.801 (socialfixer@mattkruse.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • URL Fixer 4.1 ({0fa2149e-bb2c-4ac2-a8d3-479599819475})
  • X-notifier 3.3.4 ({37fa1426-b82d-11db-8314-0800200c9a66})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6450
  • adapterDescription2:
  • adapterDeviceID: 0x6779
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6450 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.casesensitive: 1
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 512000
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.restore_on_demand: False
  • browser.startup.homepage_override.buildID: 20130910160258
  • browser.startup.homepage_override.mstone: 24.0
  • browser.tabs.loadInBackground: False
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 24.0
  • font.size.variable.x-western: 14
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1379899012
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.npctrl: 0
  • plugin.state.npgoogleupdate: 0
  • plugin.state.npwlpg: 0
  • plugin.state.npzylomgamesplayer: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • security.default_personal_cert: Select Automatically
  • security.disable_button.openCertManager: False
  • security.disable_button.openDeviceManager: False
  • security.OCSP.disable_button.managecrl: False
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378847983

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2367 solutions 20952 answers

Chosen Solution

Firefox should automatically trim the cache for you when it nears fullness. This wouldn't affect your cookies.

One possibility is that cookies are being cleared or expired out at certain intervals by an add-on or by external software.

Another possibility is that there is some kind of conflict or corruption with your cookies. You can delete all the cookies for a particular site (e.g., Google) using the Page Info dialog. While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Hopefully after your next login any conflict or corruption will be resolved.

I also notice you have an extension that presumably logs into to Gmail on your behalf. As a test, try disabling X-notifier here:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

Usually a link will appear above a disabled extension to restart Firefox. If so, that is necessary for the change to take effect.

Any improvement?


Some sites not only check the cookie but also other details of your connection such as your computer's IP address. If it changes then you may be required to re-authenticate. This has been reported in some cases with Yahoo or AOL-network sites (including Huffington Post) when Firefox's connection setting is set to "Auto-detect". You can check that here:

orange Firefox button (or Tools menu) > Options > Advanced > "Network" mini-tab > "Settings" button

The default setting is "Use system proxy settings" and you also could try "No proxy."

If you use an anonymizing service or private VPN to disguise your true IP address, that also could be an issue.

Question owner

Incidentally, even replying by using the email link, I was logged out of this site already too, but not sure if that's default behavior or not.

It could be coincidence on the cache size because I don't constantly check it, but the times I have, it has fit that "theory", so I had to suspect it. It does seem with a clear cache, it takes longer before I get "forgotten".

None of my addons are specifically designed to clear cookies, and I don't think my security software (Bitdefender) is doing it either, as this issue far predated that particular installation.

Have done the "remove relevant cookies" thing a couple times before (I have been dealing with this for a very long time!) but it doesn't change the behavior.

I believe my ISP uses a dynamic IP setting for our DSL connection, changing a bit each time the modem restarts, and obviously there's nothing I can do about that. :( However, I most certainly did not change IP addresses between clicks of that forum I mentioned earlier! It happens at sites that are unrelated to Yahoo or AOL, in fact Yahoo is actually a lot better about leaving me logged in, I'm rarely logged out there when I don't ask to be.

My connection setting was default as you noted: "use system proxy settings" but I changed it to "no proxy" on your suggestion. I do not use anything that intentionally messes with or disguises my IP as far as I am aware.

X notifier does check all my email providers for new mail- Yahoo & Hotmail as well as Gmail, although Gmail is the only one of those that usually makes me log back in frequently. I can turn it off, but it would impossible to know immediately if it helped, because I can't predict exactly when I'll get logged out or not. Sometimes I can stay logged into a site for 2-3 days, (through browser closes and windows restarts) and sometimes only until I leave the site or close the browser. Or sometimes when I refresh the page apparently! Its just annoyingly often.

The "remember passwords" addon is also just a recent addition, this problem far preceded it, in case that makes anyone wonder.

I will delete the cookies for the sites that have recently dumped me, and disable my mail checker  :cry: and let you know how soon/if I am logged out against my will again.

jscher2000
  • Top 10 Contributor
2367 solutions 20952 answers

If the email sites are not a big problem (every other day is tolerable) then you could skip the suggestion about the email notifier.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

Check the date and time in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

This can be caused by corrupted cookies or cookies that are blocked (check the permissions on the about:permissions page).

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Question owner

Haven't been logged out yet, but then, coincidentally? the cache isnt full yet either. It may take a bit to see if it/anything works, because it was unpredictable- sometimes right away, sometimes a couple days, but in the end it shouldnt be happening for a pretty long time- my husband is almost never logged out of Facebook unless he deliberately logs out. Almost never is good. :) Ironic to have the problem apparently most users wish they would have because they don't want to stay logged in! lol

I use only the default theme. The system time is fine, (I like to check it by the USNO Master clock periodically) and the cookie permissions are correct, I went over the permissions before posting. If they go back to dumping me out in day or so then I will try deleting that sqlite file(s) and advise.

Question owner

I can't believe it, how could the mail checker be related? And yet until now I had not been logged out of anywhere, pretty much a record of late. Having really missed my mail announcements I enabled my mail checker (found I forgot to check hotmail & had 8 new mails!!) and then (after seeing my cache still isnt full!) just for kicks, hit my bookmark for facebook - and boom- "you must login to see this page". No way!! =( It can't just be coincidence, but then, my husband uses the same mail checker on his computer, and doesn't get logged out of his facebook!? <pout> I seriously hate to give up my mail checker, can try different ones I guess, but until I see otherwise I have to assume the mail checker was what was messing with my login cookies. Even though the checker should have nothing to do with Facebook. Thanks for your assistance.

Modified by EdenBlessing

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96861 answers

You can get logged out if the extension doesn't send the cookies to the server when checking for mail. When the server then responds with a request to create (new) cookies then you will get logged of. If this doesn't happen on another computer then you may need to check (compare) the settings in the extension and the cookie settings in Firefox (you may need to check the third-party cookie settings as well).

Question owner

Here's the thing- that mail checker wasn't even going to Facebook or any of the places I was being logged out of. There isn't really a problem with being logged out of any mail servers except Gmail. I just found out it *can* do Facebook via a script, which i tested in case it would solve the conflict, but when i go there through x-notifier it won't load another extension (Social Fixer) which makes Facebook usable to me, so that's unacceptable. So it should never have been communicating with the same servers to begin with. Unless you mean my ISP server? Which I dont think is involved but Im not all that savvy about the technical side.

I am working on checking through that extension's forums and found some hidden "about:config" preferences related to cookies for that extension, and it worked for a bit but that was yesterday, after being logged in when I got on the computer today, but having left the site Im logged out again. if I can figure that forum out (it keeps telling me I cant post even though i registered) I will see if I can bug it or ask for help there.