X
Tap here to go to the mobile version of the site.

Support Forum

When I click on "email a link" why doesn't Firefox actually copy the link and take it to my email client instead of just opening the email client?

Posted

I expected sending an email link would actually set up the email link in a new email, like many other browsers do, but all Firefox does is open Windows Live Mail. I then have to go back to the page I wanted to send, copy the address, go back to email and open a new, black email to paste the link in. I've been away on a Mac for a few months so I may be remembering wrongly, but I think Firefox used to do this. I'm using Firefox 24.0 on Windows 7.

I expected sending an email link would actually set up the email link in a new email, like many other browsers do, but all Firefox does is open Windows Live Mail. I then have to go back to the page I wanted to send, copy the address, go back to email and open a new, black email to paste the link in. I've been away on a Mac for a few months so I may be remembering wrongly, but I think Firefox used to do this. I'm using Firefox 24.0 on Windows 7.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.8
  • 5.1.20513.0
  • Yahoo Application State Plugin version 1.0.0.7
  • Best Buy pc app Detector Plug-in
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

Wesley Branton
  • Top 10 Contributor
649 solutions 5256 answers

What is the default email service set for your operating system?

What service/program are you attempting to open?

What is the default email service set for your operating system? What service/program are you attempting to open?

Question owner

My default email client is Windows Live Mail and I want clicking on "Email Link" in Firefox's homebox to take me to that client (which it does) AND open a blank email into which it puts the link I want to send.

My default email client is Windows Live Mail and I want clicking on "Email Link" in Firefox's homebox to take me to that client (which it does) AND open a blank email into which it puts the link I want to send.
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

I'm never clear on whether Windows Live Mail means a program that runs externally to Firefox or the website formerly known as Hotmail and more recently known as Outlook.com... which one are you using?

To refresh Firefox's setting, you could try the following double switch: change your mailto handler to Gmail, OK that, then change it back to Windows Live Mail. This article shows the dialog: Change the program used to open email links.

I'm never clear on whether Windows Live Mail means a program that runs externally to Firefox or the website formerly known as Hotmail and more recently known as Outlook.com... which one are you using? To refresh Firefox's setting, you could try the following double switch: change your mailto handler to Gmail, OK that, then change it back to Windows Live Mail. This article shows the dialog: [[Change the program used to open email links]].

Question owner

Windows Live Mail is a part of Windows Essentials and is different from Hotmail/Outlook.com. This client is resident on an individual computer and is not web based.

Your suggestion only gets me part way. Firefox will open Windows Live Mail, but that's it, it stops right there. I have used other programs that, when asked to send a link, would open the email client AND open a blank email and put the link in the body of the email. Then all I had to do is type in an address. I THOUGHT Firefox used to do that but now I'm not sure it did. If not, it should, because it's a very nice feature and the competition has it. Thanks for the help, though!

Windows Live Mail is a part of Windows Essentials and is different from Hotmail/Outlook.com. This client is resident on an individual computer and is not web based. Your suggestion only gets me part way. Firefox will open Windows Live Mail, but that's it, it stops right there. I have used other programs that, when asked to send a link, would open the email client AND open a blank email and put the link in the body of the email. Then all I had to do is type in an address. I THOUGHT Firefox used to do that but now I'm not sure it did. If not, it should, because it's a very nice feature and the competition has it. Thanks for the help, though!
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi lawallen, if you click someone's email address, does that launch a new message (with the email address) or do you still not get a new message?

Could you test from the Windows 7 search box (copy the line and paste in the search box and press Enter):

(Default client)

mailto:user@example.com?subject=subject&body=message%20body

(Windows Live Mail)

wlmail.exe /mailurl:mailto:user@example.com?subject=subject&body=message%20body

Any difference?

I think the behavior of the mail program is determined by some information in the Windows registry. To update that information, you might make a switch in the Default Programs control panel. Not sure what you can switch to, but the idea is to change from Windows Live Mail to another email program, then change back, to refresh the registry settings.

Hi lawallen, if you click someone's email address, does that launch a new message (with the email address) or do you still not get a new message? Could you test from the Windows 7 search box ''(copy the line and paste in the search box and press Enter):'' (Default client) mailto:user@example.com?subject=subject&body=message%20body (Windows Live Mail) wlmail.exe /mailurl:mailto:user@example.com?subject=subject&body=message%20body Any difference? I think the behavior of the mail program is determined by some information in the Windows registry. To update that information, you might make a switch in the Default Programs control panel. Not sure what you can switch to, but the idea is to change from Windows Live Mail to another email program, then change back, to refresh the registry settings.

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

You can also check the network.protocol-handler.external.mailto prefs on the about:config page.
If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value.

You can also check the network.protocol-handler.external.mailto prefs on the about:config page.<br /> If network.protocol-handler.external.mailto prefs are user set (bold) then right-click and Reset them to the default value. *http://kb.mozillazine.org/about:config
jbgarman50 0 solutions 1 answers

i'm using FF 24 on Win7. My defaul email is Att.net or Yahoo.mail.

i'm using FF 24 on Win7. My defaul email is Att.net or Yahoo.mail.
Dyvik Chenna
  • Locale Leader
6 solutions 96 answers
http://kb.mozillazine.org/about:config try this out!!
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi jbgarman50, I think you're new to this thread.

Check out the following article and try choosing Yahoo Mail: Change the program used to open email links.

Does that work for your account?

Hi jbgarman50, I think you're new to this thread. Check out the following article and try choosing Yahoo Mail: [[Change the program used to open email links]]. Does that work for your account?
when 0 solutions 9 answers

How Can I change the default email acoount in mailto ? I wont add some new.

How Can I change the default email acoount in mailto ? I wont add some new.
cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

What email service do you want to use?

Did you look in "Tools > Options > Applications: Mailto" to see if your email client is supported?

What email service do you want to use? Did you look in "Tools > Options > Applications: Mailto" to see if your email client is supported? *http://kb.mozillazine.org/File_types_and_download_actions *https://support.mozilla.org/kb/change-firefox-behavior-when-open-file
when 0 solutions 9 answers

https://email.t-online.de/ Yes I look that link. Maybe that link are helpful but not in my case.My email is not supported. I try change configutarion in about:config. Many things but none rosolve my problem.

https://email.t-online.de/ Yes I look that link. Maybe that link are helpful but not in my case.My email is not supported. I try change configutarion in about:config. Many things but none rosolve my problem.
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi when, the site is configured to offer you the option to add it on your first visit, but then it sets a cookie so it doesn't bother you about it again. Try removing the cookie and reloading the page to see whether you get the button again.

While viewing a page on the site, open the page info dialog using either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"
  • click the padlock in the address bar > More Information > "View Cookies"

Then remove just the "ngMailtoReg" cookie. Close the dialogs and reload the page. Do you get the button?

If that doesn't work, the steps to create the setting manually are a bit involved...

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste gec and pause while the list is filtered.

(3) Double-click gecko.handlerService.allowRegisterFromDifferentHost to toggle its value from false to true. The line should turn bold.

(4) In another tab, containing a normal web page, open the Web Console using one of these methods:

  • Ctrl+Shift+k
  • orange Firefox button > Web Developer > Web Console
  • classic Tools menu > Web Developer > Web Console

A small area should open below the current page.

(5) Copy the following line of script and paste it next to the caret (">") at the bottom of the Web Console (it all goes on one long line):

navigator.registerProtocolHandler('mailto','https://email.t-online.de/?service=writemail&uri=%s','T-online');

Then press the Enter key to execute it. An infobar should open at the top of the page. Click "Add Application". You now can close the Web Console using any of the same methods you used for opening it.

If instead of an infobar the Web Console displays "Not allowed to register a protocol handler for mailto" then switch to your about:config tab, search for mailto. If the line is bold and set to false, double-click network.protocol-handler.external.mailto to toggle its value back to true. Then try this step 5 again.

(6) Open the Application preferences dialog using:

(WIN) orange Firefox button (or Tools menu) > Options > Applications
(MAC) Firefox > Preferences > Applications
(LINUX) Edit > Preferences > Applications

In the search box on that tab, type or paste mailto and pause while the list is filtered. If you click the drop-down list on the right side, should should now find T-online.

(7) Return to the tab with about:config, if you changed the search change it back to gec, and double-click gecko.handlerService.allowRegisterFromDifferentHost to return its value to false. You can close about:config.

Hi when, the site is configured to offer you the option to add it on your first visit, but then it sets a cookie so it doesn't bother you about it again. Try removing the cookie and reloading the page to see whether you get the button again. While viewing a page on the site, open the page info dialog using either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" * click the padlock in the address bar > More Information > "View Cookies" Then remove just the "ngMailtoReg" cookie. Close the dialogs and reload the page. Do you get the button? If that doesn't work, the steps to create the setting manually are a bit involved... (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''gec''' and pause while the list is filtered. (3) Double-click '''gecko.handlerService.allowRegisterFromDifferentHost''' to toggle its value from false to true. The line should turn bold. (4) In another tab, containing a normal web page, open the Web Console using one of these methods: * Ctrl+Shift+k * orange Firefox button > Web Developer > Web Console * classic Tools menu > Web Developer > Web Console A small area should open below the current page. (5) Copy the following line of script and paste it next to the caret (">") at the bottom of the Web Console (it all goes on one long line): navigator.registerProtocolHandler('mailto','https://email.t-online.de/?service=writemail&amp;uri=%s','T-online'); Then press the Enter key to execute it. An infobar should open at the top of the page. Click "Add Application". You now can close the Web Console using any of the same methods you used for opening it. ''If instead of an infobar the Web Console displays "Not allowed to register a protocol handler for mailto" then switch to your about:config tab, search for mailto. If the line is bold and set to false, double-click '''network.protocol-handler.external.mailto''' to toggle its value back to true. Then try this step 5 again.'' (6) Open the Application preferences dialog using: (WIN) orange Firefox button (or Tools menu) > Options > Applications<br> (MAC) Firefox > Preferences > Applications<br> (LINUX) Edit > Preferences > Applications In the search box on that tab, type or paste '''mailto''' and pause while the list is filtered. If you click the drop-down list on the right side, should should now find T-online. (7) Return to the tab with about:config, if you changed the search change it back to gec, and double-click '''gecko.handlerService.allowRegisterFromDifferentHost''' to return its value to false. You can close about:config.

Modified by jscher2000

when 0 solutions 9 answers

It's not working. I don't now why ?<:P Maybe I'm doing something wrong. Take a look... I have question where you find what I need paste in the web console ...:https://email.t-online.de/?service=writemail&uri=%s','T-online');?

It's not working. I don't now why ?<:P Maybe I'm doing something wrong. Take a look... I have question where you find what I need paste in the web console ...:https://email.t-online.de/?service=writemail&uri=%s','T-online');?
jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi when, are you in a private browsing session? Firefox doesn't show cookies in a private session. If you are in a regular session and that dialog is blank, then you shouldn't need to clear any cookies.

Although the console doesn't recognize that line of script, Firefox still should open the bar along the top of the page to allow you to add t-online. Make sure you are viewing a real webpage and not a special internal page like the 9-thumbnail new tab page.

Hi when, are you in a private browsing session? Firefox doesn't show cookies in a private session. If you are in a regular session and that dialog is blank, then you shouldn't need to clear any cookies. Although the console doesn't recognize that line of script, Firefox still should open the bar along the top of the page to allow you to add t-online. Make sure you are viewing a real webpage and not a special internal page like the 9-thumbnail new tab page.
when 0 solutions 9 answers

Hi I'm in normal session. I show you haw looks like my cookies page. Yes I'm understand that. I dont need delete cookie when I don't haw any cookies... I have ad block ad to my firefox. Maybe this is the problem. I try off ad block and repeat all steps. Still not working...

Hi I'm in normal session. I show you haw looks like my cookies page. Yes I'm understand that. I dont need delete cookie when I don't haw any cookies... I have ad block ad to my firefox. Maybe this is the problem. I try off ad block and repeat all steps. Still not working...

Modified by when

jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi when, I wonder whether it would work better to try to add it when you are on the t-online site itself?

If that doesn't help, could you try it in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Will Firefox let you add the new mailto handler?

Hi when, I wonder whether it would work better to try to add it when you are on the t-online site itself? If that doesn't help, could you try it in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Will Firefox let you add the new mailto handler?

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
17582 solutions 159077 answers

Did you check the Mailto choices in Tools > Options > Applications?

Once you have clicked the Add to Firefox button then you should see an extra choice appearing.


Did the running the code in the third screenshot bring up a bar at the top of the page?
Note that you can open the Web Console on the https://email.t-online.de/ page, so no need to open a new tab.

The last screenshot shows an error because of the leading prompt character ">".

Did you check the Mailto choices in Tools > Options > Applications? Once you have clicked the Add to Firefox button then you should see an extra choice appearing. ---- Did the running the code in the third screenshot bring up a bar at the top of the page?<br /> Note that you can open the Web Console on the https://email.t-online.de/ page, so no need to open a new tab. The last screenshot shows an error because of the leading prompt character ">".
when 0 solutions 9 answers

Hi I do what you wont but it's still not working. Take a look... And still i don't have cookies. Safe mode is number 2 and 3. I try start Firefox in Admin privilages but result is the same. Unfortunately

Hi I do what you wont but it's still not working. Take a look... And still i don't have cookies. Safe mode is number 2 and 3. I try start Firefox in Admin privilages but result is the same. Unfortunately

Modified by when

jscher2000
  • Top 10 Contributor
8797 solutions 71955 answers

Hi when, could you check on whether you have any non-default settings for "mailto"-related preferences?

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste mailto and pause while the list is filtered

Is anything bolded, indicating a customized setting?


The fact that the console shows "undefined" is not the issue. That's actually normal. The problem is that the "infobar" with the Add Application button is not sliding down on your Firefox for some reason. Testing in Safe Mode should have ruled out an add-on or toolbar customization as the culprit.


I wonder whether it could be due to some kind of corruption in the file that stores these handler entries, mimeTypes.rdf. It's an XML file with a difficult-to-understand structure that volunteers typically recommend that you rename and allow Firefox to rebuild with default settings. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Keeping that window open, switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox. Hopefully now this feature will behave more normally.

Hi when, could you check on whether you have any non-default settings for "mailto"-related preferences? (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''mailto''' and pause while the list is filtered Is anything bolded, indicating a customized setting? ---- The fact that the console shows "undefined" is not the issue. That's actually normal. The problem is that the "infobar" with the Add Application button is not sliding down on your Firefox for some reason. Testing in Safe Mode should have ruled out an add-on or toolbar customization as the culprit. ---- I wonder whether it could be due to some kind of corruption in the file that stores these handler entries, mimeTypes.rdf. It's an XML file with a difficult-to-understand structure that volunteers typically recommend that you rename and allow Firefox to rebuild with default settings. Here's how: Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show Folder" button Keeping that window open, switch back to Firefox and Exit Pause while Firefox finishes its cleanup, then rename '''mimeTypes.rdf''' to something like mimeTypes.old Restart Firefox. Hopefully now this feature will behave more normally.

Modified by jscher2000