X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

'do this automatically for files like this from now on' box greyed out

Posted

Whenever I go to download a file, the 'do this automatically for files like this from now on' box is greyed out. I have scoured the internet looking for a solution and just about every one of them is either severely outdated or does not fix my problem. I have reset my Firefox more than I can count and yet it does not seem to fix my problem. It used to work just fine, but it no longer does and it is very annoying and frustrating. I have even tried to completely uninstall it and reinstall it to my computer and that doesn't fix anything.

Is there any sort of way to fix this problem? Firefox is my browser of choice and I'd prefer not to have to start using another one. I know it may seem trivial because it's just one extra step, but when you're doing it a bunch of times in a row like I do, it can get quite bothersome.

Thank you.

Chosen solution

jenz1205 wrote:

Content-Type: application/octet-stream 

As you can see from the response headers you pasted, the server in question is sending the generic application/octet-stream file type. "Do this automatically..." will either be grayed out, or it might be available but checking it will have no effect.

jenz1205 wrote:

I still get the greyed out 'Do this automatically…" box and it seems that none of the add-ons or plugins I've downloaded have helped me change/fix this.

What rules did you set up in the Force Content-Type add-on? The following should suit your needs:

  • URL: (.torrent)$ Old Content-Type: application/octet-stream New Content-Type: application/x-bittorrent

Alternatively, instead of downloading torrent files, use the magnet links, if the site in question offers them.

jenz1205 wrote:

Is there a default mimeTypes file that I can download or something?

If you delete the mimeTypes.rdf file from the profile folder while Firefox is closed, it will be replaced with the factory default when Firefox is next started (meaning all your added and customized download actions will be discarded).

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Imgur Uploader 1.0.6 (giorgio@gilestro.tk)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • XKit 7.2.1 (xkit@studioxenix.com)
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Adobe Contribute Toolbar 6.1 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9800 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0614
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-21-2013
  • driverDate2:
  • driverVersion: 9.18.13.2049
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9800 GT )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: google.com
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 53669
  • plugin.importedState: True
  • plugin.state.npauthz: 0
  • plugin.state.npitunes: 0
  • plugin.state.npspwrap: 0
  • plugin.state.npystate: 0
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
Gingerbread Man
  • Top 25 Contributor
220 solutions 898 answers

There are two possible causes. You can use the Web Console tool to inspect the server's response headers to find out which one you're dealing with, or you can simply post an example link here and someone will analyze it for you.

1. The server is sending the Content-Disposition: attachment header. Install the following add-on.

2. The server is the Content-Type: application/octet-stream header. Install the following add-on and configure it accordingly; you can find some examples towards the end of post at the second link.

Question owner

I am not entirely sure what you are talking about with these links. The very first one you provided shows how to check for the response headers you mentioned with a Mac, and I run on a Windows PC, so the steps it gives cannot be performed by me, or at least I am not sure of the Windows PC steps to do what it is talking about.

Every time I have seen this problem posted online, the solutions are to either change the about:config of two specific entries, one of which does not exist on my computer, to replace the mimeType file (which I've done and it didn't work), or delete the pref.js file (also which has not worked). As I said in my first post, I have reset Firefox many times and it has not yet fixed my problem.

And, frankly, I don't understand why I need to install a plugin/add on to make this work correctly. I never had to before and it used to work just fine. There has to be a way to fix this without needing to install anything additional to my browser or computer.

And what sort of example are you talking about for me to post for someone to analyze? I am not sure I fully understand that. This isn't the first time someone has had this problem and has needed it to be fixed. But, as I said in my first post, most of those problems are old and the solutions are outdated, as in they were for Firefox 2, 3, 4, etc.

Gingerbread Man
  • Top 25 Contributor
220 solutions 898 answers

jenz1205 wrote:

I am not sure of the Windows PC steps to do what it is talking about.

The directions in the aforementioned article are for all operating systems. To open the Web Console on Windows, press Ctrl+Shift+K.
On Windows Vista and later, you can click the Firefox button in the top left corner of the window, then choose Web Developer, then Web Console.
On Windows XP, you can open the Tools menu and choose Web Developer, then Web Console.

jenz1205 wrote:

I don't understand why I need to install a plugin/add on to make this work correctly.

Firefox is behaving the way the server instructs it to. To change something that is working as intended, you need add-ons.

jenz1205 wrote:

And what sort of example are you talking about for me to post for someone to analyze?

A link to a download where the "Do this automatically..." option is grayed out. Chances are it's going to be a case of the Content-Disposition: attachment header, so you could save some time by just installing the InlineDisposition add-on and see if it solves the problem.

Question owner

Ok, so I went into the Web Console, but am still unsure of what it is that I am supposed to be looking for, or fixing.

As far as the two plugins/add ons you suggested, I've installed both and neither has seemed to help me with my problem. I have had them both running at the same time and then did one at a time to make sure they didn't cancel each other out. Still, nothing is helping or solving this problem.

Most of the files I am trying to download are torrent files. So you can literally pick any torrent site and click a link, they all do the same thing.

As far as the "Do this automatically..." option being greyed out, it is still like that and nothing I try seems to be fixing this. Is there anything else I can try to fix this? It really is becoming quite a nuisance.

I keep seeing stuff online about mimeTypes.rdf and I have tried to fix that by deleting it or even saving a basic one in place of the one I have, yet it keeps reverting back to the cluttered one. This is what my file currently looks like, and I feel like it shouldn't.

<RDF:RDF xmlns:NC="http://home.netscape.com/NC-rdf#"

        xmlns:RDF="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
 <RDF:Description RDF:about="urn:handler:web:http://30boxes.com/external/widget?refer=ff&url=%s"
                  NC:prettyName="30 Boxes"
                  NC:uriTemplate="http://30boxes.com/external/widget?refer=ff&url=%s" />
 <RDF:Description RDF:about="urn:handler:web:https://mail.google.com/mail/?extsrc=mailto&url=%s"
                  NC:prettyName="Gmail"
                  NC:uriTemplate="https://mail.google.com/mail/?extsrc=mailto&url=%s" />
 <RDF:Description RDF:about="urn:scheme:handler:mailto"
                  NC:useSystemDefault="true"
                  NC:alwaysAsk="false">
   <NC:possibleApplication RDF:resource="urn:handler:web:https://compose.mail.yahoo.com/?To=%s"/>
   <NC:possibleApplication RDF:resource="urn:handler:web:https://mail.google.com/mail/?extsrc=mailto&url=%s"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:scheme:ircs"
                  NC:value="ircs">
   <NC:handlerProp RDF:resource="urn:scheme:handler:ircs"/>
 </RDF:Description>
 <RDF:Seq RDF:about="urn:schemes:root">
   <RDF:li RDF:resource="urn:scheme:webcal"/>
   <RDF:li RDF:resource="urn:scheme:ircs"/>
   <RDF:li RDF:resource="urn:scheme:mailto"/>
   <RDF:li RDF:resource="urn:scheme:irc"/>
 </RDF:Seq>
 <RDF:Description RDF:about="urn:handler:web:https://compose.mail.yahoo.com/?To=%s"
                  NC:prettyName="Yahoo! Mail"
                  NC:uriTemplate="https://compose.mail.yahoo.com/?To=%s" />
 <RDF:Description RDF:about="urn:scheme:handler:ircs"
                  NC:alwaysAsk="true">
   <NC:possibleApplication RDF:resource="urn:handler:web:https://www.mibbit.com/?url=%s"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:schemes">
   <NC:Protocol-Schemes RDF:resource="urn:schemes:root"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:scheme:mailto"
                  NC:value="mailto">
   <NC:handlerProp RDF:resource="urn:scheme:handler:mailto"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:scheme:webcal"
                  NC:value="webcal">
   <NC:handlerProp RDF:resource="urn:scheme:handler:webcal"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:scheme:handler:webcal"
                  NC:useSystemDefault="true"
                  NC:alwaysAsk="true">
   <NC:possibleApplication RDF:resource="urn:handler:web:http://30boxes.com/external/widget?refer=ff&url=%s"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:scheme:handler:irc"
                  NC:alwaysAsk="true">
   <NC:possibleApplication RDF:resource="urn:handler:web:https://www.mibbit.com/?url=%s"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:root"
                  NC:en-US_defaultHandlersVersion="3" />
 <RDF:Description RDF:about="urn:scheme:irc"
                  NC:value="irc">
   <NC:handlerProp RDF:resource="urn:scheme:handler:irc"/>
 </RDF:Description>
 <RDF:Description RDF:about="urn:handler:web:https://www.mibbit.com/?url=%s"
                  NC:prettyName="Mibbit"
                  NC:uriTemplate="https://www.mibbit.com/?url=%s" />

</RDF:RDF>

Is there a default mimeTypes file that I can download or something? I really feel like this issue shouldn't be an issue, or that it shouldn't be resolved quickly. No amount of resets or fresh installs of Firefox have helped.

Modified by jenz1205

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can use the Live Http Headers to check with which content header (MIME type) the file is send by the server.

This usually happens if the server sends the file with a generic content type.

jscher2000
  • Top 10 Contributor
2347 solutions 20801 answers

Looking in the web console is to diagnose why Firefox is treating the download the way it is. When you click the URL in the web console, a small window pops up showing the Request and Response Headers (and some cookies). The critical information is In the Response Headers. In particular, Content-Type and Content-Disposition.

  • When the content type specifies the generic binary file type (application/octet-stream), Firefox may allow you to check the box to do this every time, but it doesn't actually work.
  • When the content disposition specifies attachment, then the site is forcing a download.

The extensions linked above are designed to help you work around these different instructions from the server.

I don't use torrents, so I don't know whether there could be some other factor here.

Question owner

Ok, so I am apparently still having issues. I checked the headers and such like said and I have copy and pasted below what the response headers have said. I still get the greyed out 'Do this automatically…" box and it seems that none of the add-ons or plugins I've downloaded have helped me change/fix this. As I said in my very first post, I didn't always have this problem and it just started one day and I cannot fix it. It has become quite annoying, even with the help I am getting from you guys, which I do appreciate.


Response Headers Δ172ms

Server: nginx/1.3.11

Last-Modified: Tue, 01 Oct 2013 08:45:05 GMT

Etag: "524a8b91-5100"

Date: Tue, 01 Oct 2013 11:43:53 GMT

Content-Type: application/octet-stream

Content-Length: 20736

Content-Encoding: gzip

Connection: keep-alive

Accept-Ranges: bytes

Modified by jenz1205

Gingerbread Man
  • Top 25 Contributor
220 solutions 898 answers

Chosen Solution

jenz1205 wrote:

Content-Type: application/octet-stream 

As you can see from the response headers you pasted, the server in question is sending the generic application/octet-stream file type. "Do this automatically..." will either be grayed out, or it might be available but checking it will have no effect.

jenz1205 wrote:

I still get the greyed out 'Do this automatically…" box and it seems that none of the add-ons or plugins I've downloaded have helped me change/fix this.

What rules did you set up in the Force Content-Type add-on? The following should suit your needs:

  • URL: (.torrent)$ Old Content-Type: application/octet-stream New Content-Type: application/x-bittorrent

Alternatively, instead of downloading torrent files, use the magnet links, if the site in question offers them.

jenz1205 wrote:

Is there a default mimeTypes file that I can download or something?

If you delete the mimeTypes.rdf file from the profile folder while Firefox is closed, it will be replaced with the factory default when Firefox is next started (meaning all your added and customized download actions will be discarded).

Question owner

neither the Old Content-Type: application/octet-stream or New Content-Type: application/x-bittorrent are options in the dropdown menu. am i to just write them in manually?

and i have tried deleting the mimeTypes.rdl many times over (i've found that as a possible solution in other places i have looked up this problem) and it has never worked.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Deleting mimeTypes.rdf only helps if you are able to find a server that sends the file with the correct MIME type to set the automatic action. It won't help if you still try to do this with a generic MIME type or other MIME type that doesn't work.

BranchMorgan 0 solutions 2 answers

I've had this problem a couple times and then it goes away. I've noticed twice that it seems to start up when I delete my history and then it stays until I get the option not greyed out. So, for example, it was greyed out on all the video sites I go to, but when I downloaded a .exe file (instal file for a driver I think) it gave me an un-greyed box, which I checked and then saved the file. Then after that all the downloads on the video sites would do it automatically too.

Helpful Reply

i was finally able to get it working, by using the solution gingerbread man gave me with the Forced Content addon. Neither of the options I had been given previously were available on the drop down menu, so it took me a while to realize I could manually type them in, which I finally did.

URL: (.torrent)$ Old Content-Type: application/octet-stream New Content-Type: application/x-bittorrent

Thank you very much!

crackd 0 solutions 4 answers

magnetlinks is the only solution that worked and is fine by me ty

Yaron 1 solutions 108 answers

I've set Firefox to open various file types (txt, png, pdf) with their default application; the "Do this automatically for files like this" option is checked. For some reason, FF keeps asking whether to save or open the file.

The Content-Type is: application/pdf.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

You can check the mimeTypes.rdf file to see which MIME type is connected to each of those actions.

Yaron 1 solutions 108 answers

Thank you.

FF ignores the settings for any file type.

In IE8, the "Always ask before opening this type of file" check-box is missing. It might be a Windows issue.

Any idea?

jscher2000
  • Top 10 Contributor
2347 solutions 20801 answers

Hi Yaron, did you try removing the mimeTypes.rdf file to reset download handling to defaults? This helps when the file contains conflicting entries or has become corrupted somehow.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show Folder" button

Leaving that window open, switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename mimeTypes.rdf to something like mimeTypes.old

Restart Firefox and update your PDF setting to your preference. Any improvement?

Yaron 1 solutions 108 answers

Hi jscher2000,

Thank you.

I've tried it. This issue is really annoying. I'd appreciate more possible solutions.

jscher2000
  • Top 10 Contributor
2347 solutions 20801 answers

Hi Yaron, does Firefox behave the same in its Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Yaron 1 solutions 108 answers

Thank you jscher2000. I appreciate it.

Safe mode or a new profile doesn't solve it. I have the problem with IE as well. It might be a Windows issue.