X
Tap here to go to the mobile version of the site.

Support Forum

'do this automatically for files like this from now on' box greyed out

Posted

Whenever I go to download a file, the 'do this automatically for files like this from now on' box is greyed out. I have scoured the internet looking for a solution and just about every one of them is either severely outdated or does not fix my problem. I have reset my Firefox more than I can count and yet it does not seem to fix my problem. It used to work just fine, but it no longer does and it is very annoying and frustrating. I have even tried to completely uninstall it and reinstall it to my computer and that doesn't fix anything.

Is there any sort of way to fix this problem? Firefox is my browser of choice and I'd prefer not to have to start using another one. I know it may seem trivial because it's just one extra step, but when you're doing it a bunch of times in a row like I do, it can get quite bothersome.

Thank you.

Whenever I go to download a file, the 'do this automatically for files like this from now on' box is greyed out. I have scoured the internet looking for a solution and just about every one of them is either severely outdated or does not fix my problem. I have reset my Firefox more than I can count and yet it does not seem to fix my problem. It used to work just fine, but it no longer does and it is very annoying and frustrating. I have even tried to completely uninstall it and reinstall it to my computer and that doesn't fix anything. Is there any sort of way to fix this problem? Firefox is my browser of choice and I'd prefer not to have to start using another one. I know it may seem trivial because it's just one extra step, but when you're doing it a bunch of times in a row like I do, it can get quite bothersome. Thank you.

Chosen solution

jenz1205 wrote:

Content-Type: application/octet-stream 

As you can see from the response headers you pasted, the server in question is sending the generic application/octet-stream file type. "Do this automatically..." will either be grayed out, or it might be available but checking it will have no effect.

jenz1205 wrote:

I still get the greyed out 'Do this automatically…" box and it seems that none of the add-ons or plugins I've downloaded have helped me change/fix this.

What rules did you set up in the Force Content-Type add-on? The following should suit your needs:

  • URL: (.torrent)$ Old Content-Type: application/octet-stream New Content-Type: application/x-bittorrent

Alternatively, instead of downloading torrent files, use the magnet links, if the site in question offers them.

jenz1205 wrote:

Is there a default mimeTypes file that I can download or something?

If you delete the mimeTypes.rdf file from the profile folder while Firefox is closed, it will be replaced with the factory default when Firefox is next started (meaning all your added and customized download actions will be discarded).

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Imgur Uploader 1.0.6 (giorgio@gilestro.tk)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • XKit 7.2.1 (xkit@studioxenix.com)
  • Adobe Acrobat - Create PDF 1.0 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Adobe Contribute Toolbar 6.1 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 9800 GT
  • adapterDescription2:
  • adapterDeviceID: 0x0614
  • adapterDeviceID2:
  • adapterDrivers: nvd3dum nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 6-21-2013
  • driverDate2:
  • driverVersion: 9.18.13.2049
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 9800 GT )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: google.com
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 1
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 53669
  • plugin.importedState: True
  • plugin.state.npauthz: 0
  • plugin.state.npitunes: 0
  • plugin.state.npspwrap: 0
  • plugin.state.npystate: 0
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
3389 solutions 30764 answers

Hi Yaron, if multiple browsers are affected, perhaps some download-related feature of your security software is coming into play?

Hi Yaron, if multiple browsers are affected, perhaps some download-related feature of your security software is coming into play?
Yaron 2 solutions 142 answers

Hi jscher2000,

That's probably correct. I'm trying to figure out the cause.

Thank you.

Hi jscher2000, That's probably correct. I'm trying to figure out the cause. Thank you.