X
Tap here to go to the mobile version of the site.

Support Forum

How can I access Advanced Javascript Settings?

Posted

I'm aware that, in recent versions of Firefox, the ability to disable Javascript has been removed. I don't intend to re-open discussion of that particular decision. But removing that option has also removed access to the Advanced Javascript Settings menu, which was far more useful than simply disabling Javascript itself. For example, although I rarely disabled Javascript entirely (other than when debugging my own site), I routinely disabled the ability of websites to disable context menus or to move and resize pop-up windows.

Unlike disabling Javascript entirely, these are settings which provide a positive benefit for "ordinary" (non-developer) users. If, say, I want to open a link in a new tab, then the correct way to do that is to right-click on it. Sites which disable right-click degrade the user experience, and allowing a way to override that is a good thing. Whatever the justification for removing the ability to disable Javascript entirely (and I do understand it, even if I don't agree with it), I can't see any justification for removing access to these advanced settings.

So my question is, how can I re-enable access to the Advaned javascript Settings? I can't see any obvious setting for it in about:config, and simply disabling javascript entirely via that method isn't what I want to do.

I'm aware that, in recent versions of Firefox, the ability to disable Javascript has been removed. I don't intend to re-open discussion of that particular decision. But removing that option has also removed access to the Advanced Javascript Settings menu, which was far more useful than simply disabling Javascript itself. For example, although I rarely disabled Javascript entirely (other than when debugging my own site), I routinely disabled the ability of websites to disable context menus or to move and resize pop-up windows. Unlike disabling Javascript entirely, these are settings which provide a positive benefit for "ordinary" (non-developer) users. If, say, I want to open a link in a new tab, then the correct way to do that is to right-click on it. Sites which disable right-click degrade the user experience, and allowing a way to override that is a good thing. Whatever the justification for removing the ability to disable Javascript entirely (and I do understand it, even if I don't agree with it), I can't see any justification for removing access to these advanced settings. So my question is, how can I re-enable access to the Advaned javascript Settings? I can't see any obvious setting for it in about:config, and simply disabling javascript entirely via that method isn't what I want to do.

Chosen solution

I have a post listing the three corresponding about:config preferences here: https://support.mozilla.org/en-US/questions/967108#answer-464407

Read this answer in context 14

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/29.0.1547.57 Safari/537.36

More Information

jscher2000
  • Top 10 Contributor
3377 solutions 30698 answers

Chosen Solution

I have a post listing the three corresponding about:config preferences here: https://support.mozilla.org/en-US/questions/967108#answer-464407

I have a post listing the three corresponding about:config preferences here: https://support.mozilla.org/en-US/questions/967108#answer-464407
cor-el
  • Top 10 Contributor
  • Moderator
12489 solutions 115242 answers
See also: *Controle de Scripts: https://addons.mozilla.org/firefox/addon/controle-de-scripts/
TheOldFox 86 solutions 620 answers

Not as easy as check boxes, but....still available. Options can be changed thru about:config. Appear to all be working in my Firefox 23.0.1 version.

Below is an article with all of the JavaScript settings in about:config that can be set

Not as easy as check boxes, but....still available. Options can be changed thru '''''about:config'''''. Appear to all be working in my Firefox 23.0.1 version. Below is an article with all of the JavaScript settings in '''''about:config''''' that can be set *http://kb.mozillazine.org/Prevent_websites_from_disabling_new_window_features *Also see - http://kb.mozillazine.org/About:config

Modified by TheOldFox

Waka_Flocka_Flame 441 solutions 5048 answers

Hello,

In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window.

However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on.

about:config

  1. In the address bar, type "about:config" (with no quotes), and press Enter.
  2. Click "I'll be careful, I promise"
  3. In the search bar, search for "javascript.enabled" (with no quotes).
  4. Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled.

To Re-enable JavaScript, repeat these steps.

Add-ons

You can alternatively install an add-on that lets you disable JavaScript, such as

  • No-Script (to disable JavaScript on a per page basis, as required)
  • QuickJava (to easily disable and enable JavaScript, automatic loading of images, and other content)
  • SettingSanity (adds back JavaScript options, including Advanced JavaScript Settings, as well as options for loading images and showing the Tab Bar)

Thank you and I hope this helps!

Hello, In Firefox 23, as part of an effort to simplify the Firefox options set and protect users from unintentially damaging their Firefox, the option to disable JavaScript was removed from the Firefox Options window. However, the option to disable JavaScript was not removed from Firefox entirely. You can still access it from about:config or by installing an add-on. '''about:config''' # In the address bar, type "about:config" (with no quotes), and press Enter. # Click "I'll be careful, I promise" # In the search bar, search for "javascript.enabled" (with no quotes). # Right click the result named "javascript.enabled" and click "Toggle". JavaScript is now disabled. To Re-enable JavaScript, repeat these steps. '''Add-ons''' You can alternatively install an add-on that lets you disable JavaScript, such as *[https://addons.mozilla.org/firefox/addon/noscript/ No-Script] (to disable JavaScript on a per page basis, as required) *[https://addons.mozilla.org/firefox/addon/quickjava/ QuickJava] (to easily disable and enable JavaScript, automatic loading of images, and other content) *[https://addons.mozilla.org/firefox/addon/settingsanity/ SettingSanity] (adds back JavaScript options, including Advanced JavaScript Settings, as well as options for loading images and showing the Tab Bar) Thank you and I hope this helps!
Sirus 1 solutions 7 answers

Helpful Reply

I am a Firefox web developer and I need those JavaScript options on a daily basis. Bring back the JavaScript settings.

If you want a dumb system, fine: just make a simple/advanced settings menu toggle for the normal users and let power users have an easy access to ALL the settings. Stop removing stuff damn it. I Don't have time to waste to tweak the about:config settings.

For now, I'll use SettingSanity.Thank you RealityRipple.

Also, if Mozilla keeps going like this, I won't hesitate to stop recommending Firefox.

Sirus

I am a Firefox web developer and I need those JavaScript options on a daily basis. Bring back the JavaScript settings. If you want a dumb system, fine: just make a simple/advanced settings menu toggle for the normal users and let power users have an easy access to ALL the settings. Stop removing stuff damn it. I Don't have time to waste to tweak the about:config settings. For now, I'll use [https://addons.mozilla.org/en-US/firefox/addon/settingsanity/ SettingSanity].Thank you RealityRipple. Also, if Mozilla keeps going like this, I won't hesitate to stop recommending Firefox. '''Sirus'''
Glyn406 0 solutions 8 answers

Hi

As I'm not at all technical, most of this discussion is over my head; however, I believe it may point to the answer to a problem that's plagued me recently.

I visited the UK site of Bosch (www.bosch-home.co.uk/store/product/Grid/00488320) to buy a spare part for a vacuum cleaner. However, when I tried to click the button "add to shopping basket", all that happened was that an error message "javascript:void(0)" appeared in the lower left corner of my monitor screen. I then telephoned the firm to place the order, and after doing so complained about the malfunction of the online ordering procedure. The person taking my call said that she had used the same screen in order to process my order, without any difficulty at all. She also said that clicking the button when successful would have opened briefly a pop-up window indicating that the item with been added to the basket, and suggested that I might have pop-ups disabled and should speak to my Internet provider about this.

I knew that pop-up disabling was a function of the user's settings and not of the ISP, and rather tetchily argued this point. Even so, I subsequently disabled the pop-up blocker in Firefox and tried again; still no joy.

I then did a web search on the error message and found this site (www.techsupportforum.com/forums/f56/javascript-void-0-error-message-126756.html) where 'ahmorrow' gave as three other possible causes:

An improperly written JavaScript ::::: Webmaster must rewrite the JavaScript

JavaScript is not enabled ::::: Enable JavaScript

Web browser implementation of JavaScript is broken ::::: Switch web browsers or upgrade your web browser

After reading this I tried the Bosch site again, using IE; the "add to basket" button functioned perfectly. Downloaded Opera, and tried with that; again, opened perfectly. Tried on my wife's iPad, using Safari; again, perfect.

This all suggests that it's Firefox that is at fault. Not good news. So what does a non-techie like me do to cope with this?

Hi As I'm not at all technical, most of this discussion is over my head; however, I believe it may point to the answer to a problem that's plagued me recently. I visited the UK site of Bosch (www.bosch-home.co.uk/store/product/Grid/00488320) to buy a spare part for a vacuum cleaner. However, when I tried to click the button "add to shopping basket", all that happened was that an error message "javascript:void(0)" appeared in the lower left corner of my monitor screen. I then telephoned the firm to place the order, and after doing so complained about the malfunction of the online ordering procedure. The person taking my call said that she had used the same screen in order to process my order, without any difficulty at all. She also said that clicking the button when successful would have opened briefly a pop-up window indicating that the item with been added to the basket, and suggested that I might have pop-ups disabled and should speak to my Internet provider about this. I knew that pop-up disabling was a function of the user's settings and not of the ISP, and rather tetchily argued this point. Even so, I subsequently disabled the pop-up blocker in Firefox and tried again; still no joy. I then did a web search on the error message and found this site (www.techsupportforum.com/forums/f56/javascript-void-0-error-message-126756.html) where 'ahmorrow' gave as three other possible causes: An improperly written JavaScript ::::: Webmaster must rewrite the JavaScript JavaScript is not enabled ::::: Enable JavaScript Web browser implementation of JavaScript is broken ::::: Switch web browsers or upgrade your web browser After reading this I tried the Bosch site again, using IE; the "add to basket" button functioned perfectly. Downloaded Opera, and tried with that; again, opened perfectly. Tried on my wife's iPad, using Safari; again, perfect. This all suggests that it's Firefox that is at fault. Not good news. So what does a non-techie like me do to cope with this?
cor-el
  • Top 10 Contributor
  • Moderator
12489 solutions 115242 answers

Helpful Reply

The href value javascript:void(0) is a placeholder to be shown when you hover a link, so you can see that this is not a normal link.
The actual action is done via an onclick handler that is tied to the button (link), so if this isn't working then this can be caused by a script that didn't run properly to add this onclick action to the button or that JavaScript is blocked on that website possibly by an extension.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Note that there is also security software that can block pop-ups and JavaScript, so check that as well.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

The href value javascript:void(0) is a placeholder to be shown when you hover a link, so you can see that this is not a normal link.<br /> The actual action is done via an onclick handler that is tied to the button (link), so if this isn't working then this can be caused by a script that didn't run properly to add this onclick action to the button or that JavaScript is blocked on that website possibly by an extension. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes Note that there is also security software that can block pop-ups and JavaScript, so check that as well. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.
jscher2000
  • Top 10 Contributor
3377 solutions 30698 answers

Hi Glyn406, Firefox's built-in JavaScript setting is just an on/off setting that enables scripts to run on all sites or no sites. To see whether JavaScript is running, you can try this test page:

http://dev.jeffersonscher.com/jstest.asp

If JavaScript is turned off, you'll see "JavaScript is not executing on your browser for this page." in the two lower sections. If instead you see a bunch of lines of information about your browser, then JavaScript is turned on and you can investigate other issues as described in cor-el's post.

Hi Glyn406, Firefox's built-in JavaScript setting is just an on/off setting that enables scripts to run on all sites or no sites. To see whether JavaScript is running, you can try this test page: http://dev.jeffersonscher.com/jstest.asp If JavaScript is turned off, you'll see "JavaScript is not executing on your browser for this page." in the two lower sections. If instead you see a bunch of lines of information about your browser, then JavaScript is turned on and you can investigate other issues as described in cor-el's post.