Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

website's internal scrolling windows not visible

  • 20 replies
  • 2 have this problem
  • 680 views
  • Last reply by WickedGirl

more options

The following restaurant web address has a menu that is not visible in FireFox but is visible and fully functional in Internet Explorer. The menu is a scrollable window contained within the web page.

http://fifersseafood.com/menu.html

Chosen solution

You can transfer some files to the new profile, make sure you are not moving corrupt files though.

Read this answer in context 👍 0

All Replies (20)

more options

That menu is an embedded PDF document. I am not having a problem seeing the scrollbar using the built-in Firefox PDF reader with Firefox 23.0.1.

If you click the angled-arrow button at the upper-right corner of that menu (labeled as Open in new window in the tooltip on cursor hover), does the scrollbar appear in the new window or new tab?

more options
more options

Also make sure that the Firefox window is wide enough to prevent the scroll bar from falling off at the right side.

more options

All I have is a big white rectangle where the menu should be. No arrows and no scroll bars.

I have attached a screenshot.

more options

Current Firefox versions have enabled a built-in PDF Viewer that doesn't have all features that other PDF readers like the Adobe Reader have or may not function properly otherwise.

You can change the action for Portable Document Format (PDF) from Preview in Firefox to use another application like the Adobe Reader or set to Always Ask in "Firefox > Options/Preferences > Applications".

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

more options

Cor-el...

I tried all of your suggestions. No changes. I even restarted Firefox in "safe mode" and that didn't help either.

What else can I try?

more options
more options

Can you display PDF files otherwise?

more options

Yes. I have Adobe Reader installed on my PC and it works. Downloading PDF files isn't a problem either. I also tried installing another PDF reader add-on. Still no change.

I'm not at my PC right now but I'll try the profile thing as soon as I can.

more options

You can set the pdfjs.disabled pref to true on the about:config page to disable the build-in PDF viewer.

You can check the value of the plugin.disable_full_page_plugin_for_types pref on the about:config page and remove the application/pdf part if present or reset the pref to the default via the right-click context menu.

See also:

more options

Cor-el...

Yes. I tried that yesterday and unfortunately, it didn't help.

more options

Cor-el...

Ok. I didn't fully understand your question about about viewing PDFs normally until I got back to my PC. I followed the link and used the embedded PDF tools. Most of them worked with Firefox. The only exceptions were a couple that had "file directory not found" error messages.

more options

Waka_Flocka_Flame...

That's it! The profile is the problem. I created a new one and the embedded PDF works on that restaurant site.

Now. Is there a way to target the problem on the default profile or should I just delete it and start from scratch? I'm reluctant to start over because I'm not sure what I'd be losing if I did.

more options

It is possible that you have disabled the built-in PDF player and also still have the pref set to disable the Adobe Reader plugin in Firefox (plugin.disable_full_page_plugin_for_types = application/pdf).
If this is the case then you won't see PDF files in Firefox.

more options

Now that we know that the default profile is the problem, is there a way to target the problem on the default profile?

I'm reluctant to delete the default profile and start over because I'm not sure what I'd be losing if I did.

more options

Chosen Solution

You can transfer some files to the new profile, make sure you are not moving corrupt files though.

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can also move or rename the prefs.js file out of the profile folder.


Note that your System Details List shows that you have a user.js file in the profile folder to initialize some prefs on each start of Firefox.

The user.js file is only present if you or other software has created it, so normally it wouldn't be there. You may want to check its content with a plain text editor if you didn't create this file yourself.

The user.js file is read each time you start Firefox and initializes preferences to the value specified in this file, so involved preferences can only be changed temporarily for the current session.

more options

OK... We're done. I fixed it.

I used the "Recovering important data from an old profile" link to determine what files to save or delete. I made a backup of the original profile and saved it elsewhere.

I then went in to the original profile folder and deleted the user.js and cookies files. Everything is working now in the old profile.

Thanks to all for your help. I really appreciate your prompt attention.

more options

An added perk... Firefox starts faster now also. It took nearly 10 seconds to load before. Now it's around 1 second.

Thanks Again!

more options

Hi folks, did anyone think of going to the Firefox options, the applications tab, and just changing what program is used to open the PDF files? This may avoid changing profiles, etc.