X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

unable to open this internet shortcut. the protocol "FirefoxURL" does not have a registered program.

Posted

I recently ran into this problem after cleaning up my Windows 7 notification icons, which, required the deletion of 2 Registry Keys: IconStreams and PastIconsStream. This did a great job of clearing out the old icons, however, I ended up with this side effect!

I found this article: https://support.mozilla.org/en-US/questions/943001, which, gave me several remedies, including: create a new Boolean preference name: 'browser.shell.shortcutFavicons and set the value to false. None of the remedies worked.

  1. My solution was a simple one, I backed up my Firefox Profile, uninstalled Firefox, then, reinstalled Firefox, transferred my original profile back back and the problem was solved!

To make the re-installation easier, it's a good idea to download a new copy of the Firefox Installer, that, way you don't start another browser and searching for it, you can just simply run the installer. Also, don't forget to make a copy of your current Firefox Profile.

I hope, that, this helps and I hope, that, I haven't put this in the wrong place!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • 5.1.20513.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Try to redo the default browser and temporarily set another browser as the default browser.

Question owner

Sorry, the re-install was to no avail - problem reoccurred.

I was on the Beta Update Channel, had Firefox v24.0 Beta, I began to think, that, maybe this was the problem (this wouldn't be the first time a Firefox Update had a problem)!

Decided to re-install an older version. Used Revo to totally remove all traces of Firefox, then used CCleaner, ran cleaner and Registry Cleaner, then, did a restart.

Re-installed Firefox v23.0 (had this installer saved), turned off all automatic updating, I don't want to update, just want to see how v23.0 does, I don't recall having a problem with it.

Have been running all day and no problems with the pinned sites, I would have had a problem by now.

If you decide to do the re-installation of a previous version, remember to backup your Firefox Profile BEFORE uninstalling !

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

I'm not sure what is altering your registry entry for FirefoxURL. However, if it happens again, you might try cor-el's suggestion of making IE the default browser temporarily, then making Firefox the default browser again. This should cause Firefox to refresh the registry.

Helpful Reply

Thanks for your reply.

As I stated, I re-installed v23.0 and I have NO problems since.

ps I just reinstalled Windows Pro 64-bit, system is fine. I have Firefox v22.0 on two computers and now have v23.0 on the computer, that, I was having the problem with the pinned urls.

Considering, that, I have been using the v23.0 Firefox all day with no problems, I can only conclude, that, there must be a problem with v24.0.

If the problem returns, I will re-post.

Again, thanks for your response.

kstjohn 0 solutions 4 answers

Helpful Reply

The Cause and Solution:

Changing the default browser will not work. This seems to be a bug in 24 wherein there is a missing Firefox URL entry in HKEY_CLASSES_ROOT made by the install. Until FF team gets cracking with a revision the only solution is to put the entry in the registry yourself or revert back to 23 if you're not comfortable with regedit - if you are it's a simple fix:

  1. Open HKEY_CLASSES_ROOT with regedit
  2. Scroll down to FirefoxURL
  3. Right click on FirefoxURL and select New then String Value
  4. Change the name of the new string "New Value #1" just added in the right panel to "URL Protocol" (no quotes)
  5. That's it - it's fixed - just exit regedit and enjoy!

Modified by kstjohn

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

It's strange that this only affects pinned sites. Desktop shortcuts, links in other programs, and even Frequent sites on the jump list work normally. ??

Anyway, this problem was caused a well-intended but apparently under-tested registry clean-up in Firefox 24. A bug report has been filed to fix it in a future release: 911158 – Remove "URL Protocol" from FirefoxURL key by FireFox 24 Windows Installer cause jumplist pinned shortcut unuseable.

About the bug tracking system: It's generally not helpful to add comments to bugs (unless there is a call for test cases), but you can register on the Bugzilla site and "vote" for them to be fixed. See:

kstjohn 0 solutions 4 answers

Yes - very strange indeed but true. Desktop shortcuts work just fine. Dragging one to FF in task bar to pin will not function and throws error message no registered program for protocol. Windows7 Ultimate x64 .

jscher2000
  • Top 10 Contributor
2365 solutions 20923 answers

Here are some screen shots for people who aren't very familiar with RegEdit for the steps in kstjohn's post.

rkpdm3 0 solutions 3 answers

Thanks kstjohn. It worked like charm.

kstjohn 0 solutions 4 answers

You are welcome!