Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webpage URL shortcuts dragged to desktop no longer show the Firefox icon or any icon. How do I fix this?

  • 15 replies
  • 13 have this problem
  • 3866 views
  • Last reply by jigasquid

more options

Recently when I dragged webpage URL shortcuts to my desktop, they no longer showed the Firefox icon. The icon that appears is the standard white icon with the little square and three colored dots that Windows uses for unknown programs although when I double-click on the URL, Firefox does boot up.

I would like to fix this problem so that the Firefox icon will again appear in the URL shortcut. How do I correct this problem?

Windows XP Pro SP3 Firefox 17.0

All Replies (15)

more options

Is Firefox set as your default browser?

more options

There has been a change to the icons that an internet shortcut gets.

  • bug 110894 - Use favicons on webpage shortcuts in Windows
more options

[mushaf] "Is Firefox set as your default browser?"

Yes, it is.


[cor-el] "There has been a change to the icons that an internet shortcut gets." "bug 110894 - Use favicons on webpage shortcuts in Windows"

I checked out the bug report and this may be my problem. This only started happening recently. The icon that shows up in all my desktop webpage shortcuts are all the same, regardless of the webpage. The icon that appears in these shortcut is a Windows icon that is used when Windows doesn't recognize the file type (described in my original post).

Thank you for your replies.

Dave

more options

Thanks for posting this issue. I have the exact same issue for dragging URLs to any window.

>> I checked out the bug report and this may be my problem.

No, I don't think it is your problem.

I reported it as a new bug since I didn't see anything that directly addressed this issue.

Drag URL To A Window As A Shortcut = No Icon For That Shortcut

https://bugzilla.mozilla.org/show_bug.cgi?id=834314

more options

[ggg3] No, I don't think it is your problem.

You are correct. I misread cor-el's post. The link works but there is no icon whatsoever shown in the shortcut.

I appreciate you posting a bug report.

more options

I had just upgraded NIS and the Firefox icon in the quick launch bar changed to a standard windows icon. I corrected this by making sure Firefox was set to my default browser. Try this. Using Windows 7.

Click the Start button--control panel--programs--default programs--set your default programs

When installed programs are listed ion the left side click once on Firefox.

At the bottom of the page click "set this program as default".

You should see the windows icon change to the Firefox icon.

This worked for me.

Good luck

more options

FF > Tools > Options > Advance > General > System Defaults > Says "FF is my default browser. Plus my "File Types" were already set correct.

XP has no "control panel--programs--default programs" Option. XP equivalent is XP Window Menu > Tools > Folder Option > File Types. Assign the following protocols and file types to the browser you wish to set as default:

   URL:HyperText Transfer Protocol (HTTP protocol)
   URL:HyperText Transfer Protocol with Privacy (HTTPS protocol)
   URL:File Transfer Protocol {FTP protocol)
   HTML File
   HTM File (optional) 

In Windows XP and earlier, you can find the URL protocols listed above in File Types, under extension "N/A" or "(NONE)".

more options

I'm using XP Pro. My Firefox URL file type is set to use the Firefox icon. Also my HTTP, HTTPS, and HTML file types are also set to use the Firefox icon. Internet shortcuts dragged to the desktop still do not show the correct icon.

more options

Further to cor-el's post I just signed up to say a hearty thanks to the fine folk in Bugzilla who are beavering away to enable us mere mortals to be able to choose between the new (and imho unfathomable) idea of having a pure white icon with a miniscule favicon in the middle of it that requires bionic vision to see what it is... and the nice friendly and immediately identifiable Firefox logo that we've all grown to know and love.

May the Force be with you all :)

more options

The only way I know to get the Firefox symbol is by bookmarking the page in IE, then dragging the bookmark to your desktop. If Firefox is set as your default browser, the symbol will show.

more options

Try to create a new Boolean pref browser.shell.shortcutFavicons and set the value to false.

Modified by cor-el

more options

Nice fix cor-el Tried with several shortcuts that were dragged and had no icon, and new drags of same do have icons. Thanks

>> paste "about:config" in address bar >> right click in blank area >> New > Boolean

Modified by ggg3

more options

I'd like to second ^^^that^^^ emotion

Thanks cor-el :o)

Presuming we've simply pre-empted v22 so when that arrives it will remain as it is now. Sweet!

more options

I do appreciate the suggestion, unfortunately this didn't work for me. Perhaps this issue is a conflict with an addon. When I get the time, I'll try removing them to see if one of them is causing this issue.

more options

Thank you guys for caring - the new browser.shell.shortcutFavicons worked a treat. Much appreciate you hanging in there!