X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox 10 crashes when a custom plugin for audio recording is used

Posted

Firefox 10 crashes when a custom audio plugin is used to record audio.

Crash Report:

Signature pr_FindSymbolInLib More Reports Search UUID d8407ae9-692c-48d0-8124-aa2572130808 Date Processed 2013-08-08 17:15:04.213447 Uptime 0 Install Age 80926 since version was first installed. Install Time 2013-08-07 18:46:11 Product Firefox Version 10.0.12esr Build ID 20130103094221 Release Channel esr OS Windows NT OS Version 6.1.7601 Service Pack 1 Build Architecture x86 Build Architecture Info GenuineIntel family 6 model 37 stepping 2 | 4 Crash Reason EXCEPTION_ACCESS_VIOLATION_READ Crash Address 0xc

RAW DUMP: OS|Windows NT|6.1.7601 Service Pack 1 CPU|x86|GenuineIntel family 6 model 37 stepping 2|4 Crash|EXCEPTION_ACCESS_VIOLATION_READ|0xc|0 Module|plugin-container.exe|10.0.12.4751|plugin-container.pdb|363DC590C2B046D1928E26EF9740CA6E2|0x00810000|0x00815fff|1 Module|comctl32.dll|6.10.7601.17514|comctl32.pdb|B4CE90AAB95E4B89A22A7711DFD7E6EF2|0x6f890000|0x6fa2dfff|0 Module|xul.dll|10.0.12.4751|xul.pdb|0713661C29384117B68A3B841E04A99A2|0x71500000|0x7249ffff|0 Module|mozjs.dll||mozjs.pdb|3DA317EAAF2F4D3199E1A2D1EF991F152|0x724a0000|0x72671fff|0 Module|smime3.dll|3.13.5.0|smime3.pdb|58F7D72634C54977B13C4A9ABECE79C51|0x72680000|0x72697fff|0 Module|ssl3.dll|3.13.5.0|ssl3.pdb|E98A36351A104C93AEDCE11791A9D3F01|0x726a0000|0x726c4fff|0 Module|nss3.dll|3.13.5.0|nss3.pdb|D77D83396DC745BDBD110434E9223CF51|0x726d0000|0x7276cfff|0 Module|nssutil3.dll|3.13.5.0|nssutil3.pdb|9CE86535436D4668A7F5AEAF3F1CA8E41|0x727a0000|0x727b7fff|0 Module|mozsqlite3.dll|3.7.7.1|mozsqlite3.pdb|A88D83A112CA49ECB77591DFDC83F3D82|0x727c0000|0x72886fff|0 Module|mozalloc.dll|10.0.12.4751|mozalloc.pdb|3D520E32A37D4FFF879289AA795BE58C2|0x72890000|0x72895fff|0 Module|nspr4.dll|4.9.0.0|nspr4.pdb|8F5CB8C77F184A99A339287357C113072|0x728b0000|0x728dcfff|0 Module|plds4.dll|4.9.0.0|plds4.pdb|C07A2CAA4448492F883A8E82BE9689FD2|0x728e0000|0x728e6fff|0 Module|plc4.dll|4.9.0.0|plc4.pdb|58EA5B8832984680AF7BF2D9CC5361A42|0x728f0000|0x728f6fff|0 Module|mozutils.dll|10.0.12.4751|mozutils.pdb|CEB347916D294B25AFB7027EE0A836F32|0x72900000|0x7290cfff|0 Module|dwmapi.dll|6.1.7600.16385|dwmapi.pdb|D8D91B3F339A4FDC960FC7121D146DF42|0x739d0000|0x739e2fff|0 Module|uxtheme.dll|6.1.7600.16385|wuxtheme.pdb|20C669C0018E406295BFA56B7C93850F2|0x739f0000|0x73a6ffff|0 Module|winspool.drv|6.1.7601.17514|winspool.pdb|B165BBE7CD8C4F39BE373C0D9DFCD77B2|0x73b90000|0x73be0fff|0 Module|msvcr80.dll|8.0.50727.6195|msvcr80.i386.pdb|54C9E2F351544D1CB39517DC4B299EA81|0x74030000|0x740cafff|0 Module|msvcp80.dll|8.0.50727.6195|msvcp80.i386.pdb|E8A9423E890A4ADDB38F8F756268437C1|0x740d0000|0x74156fff|0 Module|winmm.dll|6.1.7601.17514|winmm.pdb|7AFD98FCAAD34F6B8B31A4667C4E2BFC2|0x74180000|0x741b1fff|0 Module|msimg32.dll|6.1.7600.16385|msimg32.pdb|13C89B70614E4E7FB1C677D443D15D182|0x74420000|0x74424fff|0 Module|wsock32.dll|6.1.7600.16385|wsock32.pdb|0AAE6683A7F540DFB265DCD12B7BD0FB2|0x750a0000|0x750a6fff|0 Module|version.dll|6.1.7600.16385|version.pdb|52234E5C7EC44646B62D56357B2C94872|0x757f0000|0x757f8fff|0 Module|PGPmapih.dll|10.2.0.2401|PGPmapih.pdb|5CAD47CF04F3473E8741DCC49382C9121|0x75800000|0x7580dfff|0 Module|CRYPTBASE.dll|6.1.7600.16385|cryptbase.pdb|E62FEAE559EE4CD995614215B01AC2102|0x758d0000|0x758dbfff|0 Module|sspicli.dll|6.1.7601.17856|wsspicli.pdb|3098DDD636D246ABBB226C68C351E6451|0x758e0000|0x7593ffff|0 Module|user32.dll|6.1.7601.17514|wuser32.pdb|0FCE9CC301ED4567A819705B2718E1D62|0x75940000|0x75a3ffff|0 Module|advapi32.dll|6.1.7601.17514|advapi32.pdb|3F32049F550C42B09CF114A1FB8A97E92|0x75ad0000|0x75b6ffff|0 Module|ws2_32.dll|6.1.7601.17514|ws2_32.pdb|18C960B958404C4F80F686EE978A33D42|0x75b70000|0x75ba4fff|0 Module|imm32.dll|6.1.7601.17514|wimm32.pdb|35DD4069EB2A43BF869D6E311FAD09452|0x75bb0000|0x75c0ffff|0 Module|kernel32.dll|6.1.7601.17965|wkernel32.pdb|D08F1E131D1F4D97B4AB2F64E00CFC8B2|0x75c10000|0x75d1ffff|0 Module|psapi.dll|6.1.7600.16385|psapi.pdb|A895A052F325481B9E2DA00A29E8D5DF2|0x75d20000|0x75d24fff|0 Module|msvcrt.dll|7.0.7601.17744|msvcrt.pdb|F1D253F9555C46DF8076400A52B3A9292|0x75d30000|0x75ddbfff|0 Module|shell32.dll|6.1.7601.17859|shell32.pdb|1489BCD8E80C441E91308A093631DE5E2|0x75de0000|0x76a29fff|0 Module|KERNELBASE.dll|6.1.7601.17965|wkernelbase.pdb|E1609DE3233B4EDF8211CF7E83211B401|0x76a30000|0x76a76fff|0 Module|oleaut32.dll|6.1.7601.17676|oleaut32.pdb|68047829A4754E789AC1C8035BA168CD2|0x76ab0000|0x76b3efff|0 Module|ole32.dll|6.1.7601.17514|ole32.pdb|5061F11A9A57433595EA5EA75A156F4B2|0x77010000|0x7716bfff|0 Module|shlwapi.dll|6.1.7601.17514|shlwapi.pdb|E128B1CEE2EB438C8646E6967118F33E2|0x77170000|0x771c6fff|0 Module|lpk.dll|6.1.7600.16385|wlpk.pdb|C39166A53CCE43F0ADF876B9C637A1EA1|0x771d0000|0x771d9fff|0 Module|nsi.dll|6.1.7600.16385|nsi.pdb|D15A81679FAE4A7392344B6FD26867942|0x77270000|0x77275fff|0 Module|sechost.dll|6.1.7600.16385|sechost.pdb|7AF14D02D41E4CD6942745FE0E6372B11|0x77280000|0x77298fff|0 Module|gdi32.dll|6.1.7601.17514|wgdi32.pdb|08A541B5942242BDB4AEABD8C87E4CFF2|0x772a0000|0x7732ffff|0 Module|comdlg32.dll|6.1.7601.17514|comdlg32.pdb|96BC483CDFF04D1AAFE462F093B954EC2|0x77550000|0x775cafff|0 Module|rpcrt4.dll|6.1.7601.17514|wrpcrt4.pdb|FAC24015130D4D7FAAA77EA36ED5AF1C2|0x775d0000|0x776bffff|0 Module|msctf.dll|6.1.7600.16385|msctf.pdb|173DAEF86B2548DBA6134EB74C4D2F232|0x77810000|0x778dbfff|0 Module|usp10.dll|1.626.7601.17514|usp10.pdb|F49786E2C7C54EA99E7C37120CDAEB9C1|0x778e0000|0x7797cfff|0 Module|ntdll.dll|6.1.7601.17725|wntdll.pdb|D74F79EB1F8D4A45ABCD2F476CCABACC2|0x77d80000|0x77efffff|0 0|0|nspr4.dll|pr_FindSymbolInLib|hg:hg.mozilla.org/releases/mozilla-esr10:nsprpub/pr/src/linking/prlink.c:9e1102e58ac8|1100|0x0 0|1|nspr4.dll||||0x3cd0 0|2|xul.dll|mozilla::plugins::PluginModuleChild::Init(std::basic_string<char,std::char_traits&lt;char&gt;,std::allocator&lt;char&gt; &,void="" &gt;="" *)|hg:hg.mozilla.org="" *,base::messagepumpwin::dispatcher="" *,ipc::channel="" *,messageloop="" 0|3|xul.dll|mozilla::plugins::pluginprocesschild::init()|hg:hg.mozilla.org="" 0|4|xul.dll|xre_initchildprocess|hg:hg.mozilla.org="" 0|5|plugin-container.exe|wmain|hg:hg.mozilla.org="" 0|6|plugin-container.exe|__tmaincrtstartup|f:="" 0|7|kernel32.dll|basethreadinitthunk|||0x12="" 0|8|ntdll.dll|__rtluserthreadstart|||0x27="" 0|9|ntdll.dll|_rtluserthreadstart|||0x1b="" 1|0|ntdll.dll|ntremoveiocompletion|||0x15="" 1|10|xul.dll|base::thread::threadmain()|hg:hg.mozilla.org="" 1|11|xul.dll|`anonymous="" 1|12|kernel32.dll|basethreadinitthunk|||0x12="" 1|13|ntdll.dll|__rtluserthreadstart|||0x27="" 1|14|ntdll.dll|_rtluserthreadstart|||0x1b="" 1|1|kernelbase.dll|getqueuedcompletionstatus|||0x29="" 1|2|xul.dll|base::messagepumpforio::getioitem(unsigned="" 1|3|xul.dll|base::messagepumpforio::waitforiocompletion(unsigned="" 1|4|xul.dll|base::messagepumpforio::waitforwork()|hg:hg.mozilla.org="" 1|5|xul.dll|base::messagepumpforio::dorunloop()|hg:hg.mozilla.org="" 1|6|xul.dll|base::messagepumpwin::runwithdispatcher(base::messagepump::delegate="" 1|7|xul.dll|base::messagepumpwin::run(base::messagepump::delegate="" 1|8|xul.dll|messageloop::runhandler()|hg:hg.mozilla.org="" 1|9|xul.dll|messageloop::run()|hg:hg.mozilla.org="" <="" base="" chromium="" const="" crt="" crt_bld="" crtexe.c|594|0x17="" ipc="" long,base::messagepumpforio::iohandler="" long,base::messagepumpforio::ioitem="" message_loop.cc:9e1102e58ac8|175|0x7="" message_loop.cc:9e1102e58ac8|201|0x9="" message_pump_win.cc:9e1102e58ac8|485|0x6="" message_pump_win.cc:9e1102e58ac8|500|0xc="" message_pump_win.cc:9e1102e58ac8|507|0xd="" message_pump_win.cc:9e1102e58ac8|536|0x25="" message_pump_win.cc:9e1102e58ac8|53|0x7="" message_pump_win.h:9e1102e58ac8|78|0xc="" mozilla-esr10:dom="" mozilla-esr10:ipc="" mozilla-esr10:toolkit="" namespace'::threadfunc(void="" nsembedfunctions.cpp:9e1102e58ac8|518|0xb="" nswindowswmain.cpp:9e1102e58ac8|107|0x4e="" p="" platform_thread_win.cc:9e1102e58ac8|26|0x9="" pluginmodulechild.cpp:9e1102e58ac8|251|0x1d="" pluginprocesschild.cpp:9e1102e58ac8|164|0x1f="" plugins="" releases="" self_x86="" sp="" src="" thread.cc:9e1102e58ac8|156|0x9="" vctools="" xre=""></char,std::char_traits&lt;char&gt;,std::allocator&lt;char&gt;>

The plugin works like a charm though on another machine. Note: The plug in needs to go only with the version 10 and upgrading version is not a viable solution.

Chosen solution

Version 10 is not supported and hasn't been for sometime. You should update to either to latest ESR (17) or latest release, (23)

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • Google Update
  • AIR Audio Firefox plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.1 r102
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.2"

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0.12) Gecko/20100101 Firefox/10.0.12

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Chosen Solution

Version 10 is not supported and hasn't been for sometime. You should update to either to latest ESR (17) or latest release, (23)

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

If Firefox still crashes after updating from here, reset firefox.

If after a reset it still crashes, follow the directions below.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

More information and further troubleshooting steps can be found in the Firefox crashes - Troubleshoot, prevent and get help fixing crashes article.

Helpful Reply

I gotta use the Firefox 10 and other versions are not a viable solution. Firefox 10 is being used in multiple machines to test the product and i don't have an option of upgrading this.

I have tried resetting and restarting the firefox in safe mode but none helps

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

See the directions in my last post about posting crash ID's.

Question owner

Sorry for not reading whole of the post in such a hurry...but here are the

5 most recent crash ids:

dd0d7289-0e04-46f8-8654-b6ea001b166e 8/8/20132:49PM 9373eb9e-1faf-4f55-86c8-a35f2fdb74ca 8/8/20132:47 PM 1caf75e4-4cf1-45bb-a6ac-c7c8f18becff 8/8/20132:42 PM bp-7b115285-7979-4b42-b0e5-9b4542130808 8/8/20132:20 PM 49a6ff66-7079-474f-a24f-32042a8afdcf 8/8/20132:12 PM 99b551bb-ba90-4fa1-b5d5-cc823bed3ea8 8/8/20132:10 PM 905f0abe-6770-4bb5-8ea0-ecb0b8cca838 8/8/20132:10 PM

Modified by spuchala

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Thanks for the info, sorry to tell you this but your crasher seems to be fixed in Firefox 15, refer to

So yeah you will have to update firefox to prevent this crash

EDIT: Also another similar crash ID was fixed around Firefox 13 to 14.

Modified by Waka_Flocka_Flame

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

As I thought, you've run into the issue of designing software for specific, ancient versions of Firefox.

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

also see the tracking flags

  • Tracking Flags:

status-firefox11: affected status-firefox12: affected tracking-firefox15: + status-firefox15: fixed tracking-firefox16: + status-firefox16: fixed status-firefox17: fixed blocking-fennec1.0: - tracking-fennec: +

Question owner

Well i know that Firefox doesn't crash from 15 on wards for this issue cause i have tested this with higher versions but installing any version above 10 is not a viable solution for us.

And as i have mentioned in my first post Firefox 10 works like a charm on HP EliteBook with audio drivers 'AMD High Definition Audio Device and IDT High Definition Audio CODEC'

and the same Firefox 10 crashes on HP ProBook 644Ob with drivers 'IDT High Definition Audio CODEC' and 'High Definition Audio Device'

Any input is so so helpful and lemme know if you need additional info

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

So you can ONLY use firefox 10? The problem crashing your FIrefox was fixed last year in FIrefox 15, the only real fixes are trying to create a new profile, disable hardware accel, or update firefox.

Question owner

Hi Waka,

Thanks for getting back so soon and yeah

I have tried steps 1 and 2 i.e. creating new profiles and hardware acceleration and others before and no luck...

and step 3 is not a solution at least for us.

The thing i dont understand though is why would it work on the specefic machine i have listed above and not in the other with the same version of firefox.

Lemme know if this is being caused cause of the audio drivers on each of the machine.

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

did you read this bug?

it likely has all the information you need

Question owner

Hi Waka,

Not sure if that bug is closer to mine. But this is additional report from the crash pop up if this may throw some light to the issue:

AdapterDeviceID: 0046 AdapterVendorID: 8086 Add-ons: firebug@software.joehewitt.com:1.7.3,{972ce4c6-7e08-4474-a285-3208198ce6fd}:10.0.12 AvailableVirtualMemory: 3877761024 BuildID: 20130103094221 CrashTime: 1375981569 EMCheckCompatibility: true FramePoisonBase: 00000000f0de0000 FramePoisonSize: 65536 InstallTime: 1375901171 Notes: Cisco VPN AdapterVendorID: 8086, AdapterDeviceID: 0046, AdapterSubsysID: 1722103c, AdapterDriverVersion: 8.15.10.2622 Has dual GPUs. GPU #2: AdapterVendorID2: 000a, AdapterDeviceID2: 000a, AdapterSubsysID2: 0000000a, AdapterDriverVersion2: 11.0.0.0D2D? D2D+ DWrite? DWrite+ D3D10 Layers? D3D10 Layers+

ProductName: Firefox ReleaseChannel: esr StartupTime: 1375981540 SystemMemoryUsePercentage: 36 Theme: classic/1.0 Throttleable: 1 TotalVirtualMemory: 4294836224 URL:

deleted the url for security reasons

Vendor: Mozilla Version: 10.0.12 Winsock_LSP: PGPlsp over [MSAFD Tcpip [TCP/IP]] : 2 : 1 : C:\Windows\system32\PGPlsp.dll

MSAFD Tcpip [TCP/IP] : 2 : 1 :  
MSAFD Tcpip [UDP/IP] : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [RAW/IP] : 2 : 3 :  
MSAFD Tcpip [TCP/IPv6] : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
MSAFD Tcpip [UDP/IPv6] : 2 : 2 :  
MSAFD Tcpip [RAW/IPv6] : 2 : 3 : %SystemRoot%\system32\mswsock.dll 
RSVP TCPv6 Service Provider : 2 : 1 :  
RSVP TCP Service Provider : 2 : 1 : %SystemRoot%\system32\mswsock.dll 
RSVP UDPv6 Service Provider : 2 : 2 :  
RSVP UDP Service Provider : 2 : 2 : %SystemRoot%\system32\mswsock.dll 
MSAFD RfComm [Bluetooth] : 2 : 1 :  
PGPlsp : 2 : 0 : C:\Windows\system32\PGPlsp.dll

This report also contains technical information about the state of the application when it crashed.

Modified by spuchala

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

The windows crash reports are basically useless for diagnosing Firefox issues. We already told you, you are having a crash that is due to using an ancient version of Firefox. I can't tell you why it crashes on one computer and not on another, there are too many variables and since it's unstable software who knows. Either update Firefox or use another browser.

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

What is PGPlsp.dll, delete that and try again.

Question owner

Thanks Tylor for the suggestion and am very sorry for being so persistent with this thing cause the product is supposed to be used on firefox 10. U guys have been so helpful and instantaneous. Thanks for throwing in so much light into this issue.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Who designs the product? Contact them to insistent on an update. Forcing you to use ancient versions of Firefox leaves you at risk for serious security issues on top of the stability issues you've experienced.

Question owner

Tried deleting PGPlsp.dll but no luck...

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Your only option is to request for a upgraded version of the plugin or see if the plugin works with firefox 23.