X
Tap here to go to the mobile version of the site.

Support Forum

How to prevent physical memory filling up and crashing Firefox (22.0) when watching Flash-based videos?

Posted

This happens maybe 30-50% of the time when I watch a video online, whether it be on YouTube or other streaming site. This usually happens when the video is at least 20 minutes long, and about 8-9 minutes in.

Looking at the Task Manager, my memory fills up to nearly its max (3.8-3.9 GB out of 4 GB) for a while before Firefox crashes. How can a video that is not very high definition take up that much physical memory space? After Firefox crashes, the RAM used immediately drops back below 1 GB.

Is this a Flash bug or a Firefox bug/leak? Or maybe my browser customization is at fault? It does not happen on Chrome.

This happens maybe 30-50% of the time when I watch a video online, whether it be on YouTube or other streaming site. This usually happens when the video is at least 20 minutes long, and about 8-9 minutes in. Looking at the Task Manager, my memory fills up to nearly its max (3.8-3.9 GB out of 4 GB) for a while before Firefox crashes. How can a video that is not very high definition take up that much physical memory space? After Firefox crashes, the RAM used immediately drops back below 1 GB. Is this a Flash bug or a Firefox bug/leak? Or maybe my browser customization is at fault? It does not happen on Chrome.

Additional System Details

Installed Plug-ins

  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.1.3.13728
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Google Update
  • 5.1.20125.0
  • The plugin allows you to have a better experience with Microsoft Lync
  • Unity Player 4.0.1f2
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • ActiveTouch General Plugin Container Version 105

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • AutoPager 0.8.0.8 (autopager@mozilla.org)
  • CacheViewer Continued 0.9.4.1 ({30E08C68-889E-11E0-95EF-DA7E4824019B})
  • Exif Viewer 2.00 (exif_viewer@mozilla.doslash.org)
  • FlashGot 1.5.5.5 ({19503e42-ca3c-4c27-b1e2-9cdb2170ee34})
  • flashresizer 3.0 (flashresizer@sean.hale)
  • FOXlinks 2.8 ({3ba8ae12-85ee-4cd9-9c00-9bec81ee0c1c})
  • Greasemonkey 1.9 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • IE Tab 2 (FF 3.6+) 4.12.22.2 ({1BC9BA34-1EED-42ca-A505-6D2F1A935BBB})
  • Image Toolbar 0.6.12 ({A4732521-77D9-447E-A557-B279AC923F06})
  • InvisibleHand 3.8.28 (canitbecheaper@trafficbroker.co.uk)
  • LeechBlock 0.6.4 ({a95d8332-e4b4-6e7f-98ac-20b733364387})
  • Linkification 1.3.8 ({35106bca-6c78-48c7-ac28-56df30b51d2a})
  • MEGA EXTENSION 1.0.3 (firefox@mega.co.nz)
  • NetVideoHunter 1.9.5 (netvideohunter@netvideohunter.com)
  • Social Fixer 7.601 (socialfixer@mattkruse.com)
  • Status-4-Evar 2013.02.16.23 (status4evar@caligonstudios.com)
  • Tab Mix Plus 0.4.1.0 ({dc572301-7619-498c-a57d-39143191b318})
  • Text-to-Image 1.4.4 ({f701c26a-479a-4724-b4f1-870db12f063c})
  • The Camelizer - Amazon Price Tracker 2.2.1 (izer@camelcamelcamel.com)
  • TinEye Reverse Image Search 1.1 (tineye@ideeinc.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Unfriend Finder 42.210 (firefox@unfriendfinder.com)
  • UnMHT 6.3.3 ({f759ca51-3a91-4dd1-ae78-9db5eee9ebf0})
  • Update Scanner 3.1.12 ({c07d1a49-9894-49ff-a594-38960ede8fb9})
  • UploadScreenshot.com Capture 1.9.1 (uss-button@uploadscreenshot.com)
  • Print pages to PDF 0.1.9.0 (printPages2Pdf@reinhold.ripper) (Inactive)
  • SkipScreen 0.7.0 (SkipScreen@SkipScreen) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 5800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6898
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] DISPLAY5 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 100 ]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 5800 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 102400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.history_expire_days.mirror: 180
  • browser.places.importBookmarksHTML: False
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.search.useDBForOrder: True
  • browser.sessionstore.max_tabs_undo: 50
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.resume_from_crash: False
  • browser.sessionstore.resume_session_once: True
  • browser.startup.homepage: about:blank
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.closeWindowWithLastTab: False
  • browser.tabs.insertRelatedAfterCurrent: False
  • browser.tabs.selectOwnerOnClose: False
  • browser.tabs.tabMinWidth: 50
  • browser.tabs.warnOnClose: False
  • browser.urlbar.autoFill: False
  • browser.urlbar.trimURLs: False
  • browser.zoom.full: False
  • dom.ipc.plugins.enabled.npietab2.dll: True
  • dom.max_script_run_time: 1800
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.checkCompatibility: False
  • extensions.checkCompatibility.10.0: False
  • extensions.checkCompatibility.10.0a: False
  • extensions.checkCompatibility.11.0: False
  • extensions.checkCompatibility.11.0a: False
  • extensions.checkCompatibility.12.0: False
  • extensions.checkCompatibility.12.0a: False
  • extensions.checkCompatibility.13.0: False
  • extensions.checkCompatibility.13.0a: False
  • extensions.checkCompatibility.14.0: False
  • extensions.checkCompatibility.14.0a: False
  • extensions.checkCompatibility.15.0: False
  • extensions.checkCompatibility.15.0a: False
  • extensions.checkCompatibility.3.6: False
  • extensions.checkCompatibility.3.6b: False
  • extensions.checkCompatibility.3.6p: False
  • extensions.checkCompatibility.3.6pre: False
  • extensions.checkCompatibility.3.7a: False
  • extensions.checkCompatibility.4.0: False
  • extensions.checkCompatibility.4.0b: False
  • extensions.checkCompatibility.4.0p: False
  • extensions.checkCompatibility.4.0pre: False
  • extensions.checkCompatibility.4.2: False
  • extensions.checkCompatibility.4.2a: False
  • extensions.checkCompatibility.4.2a1: False
  • extensions.checkCompatibility.4.2a1pre: False
  • extensions.checkCompatibility.4.2b: False
  • extensions.checkCompatibility.5.0: False
  • extensions.checkCompatibility.5.0a: False
  • extensions.checkCompatibility.5.0b: False
  • extensions.checkCompatibility.6.0: False
  • extensions.checkCompatibility.6.0a: False
  • extensions.checkCompatibility.6.0b: False
  • extensions.checkCompatibility.7.0: False
  • extensions.checkCompatibility.7.0a: False
  • extensions.checkCompatibility.7.0b: False
  • extensions.checkCompatibility.8.0: False
  • extensions.checkCompatibility.8.0a: False
  • extensions.checkCompatibility.9.0: False
  • extensions.checkCompatibility.9.0a: False
  • extensions.checkCompatibility.nightly: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: False
  • general.useragent.extra.brc:
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • network.http.max-persistent-connections-per-server: 4
  • places.database.lastMaintenance: 1373236210
  • places.history.expiration.transient_current_max_pages: 104858
  • places.history.expiration.transient_optimal_database_size: 167772160
  • places.last_vacuum: 1301627083
  • plugin.disable_full_page_plugin_for_types: ,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,application/pdf
  • plugin.importedState: True
  • privacy.clearOnShutdown.extensions-tabmix: False
  • privacy.cpd.cookies: False
  • privacy.cpd.downloads: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1371161710

Misc

  • User JS: Yes
  • Accessibility: Yes
Waka_Flocka_Flame 441 solutions 5048 answers

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash update and/or a malfunctioning browser plugin such as Real Player.

In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles:

Other, more technical information about these issues can be found under these Links:


Please tell us if this helped!

Recent crashes of certain multimedia contents (this includes Youtube videos, certain flash games and other applications) in conjunction with Firefox are most probably caused by a recent Flash update and/or a malfunctioning browser plugin such as Real Player. In order to remedy the problem, please perform the steps mentioned in these Knowledge Base articles: * [[Flash Plugin - Keep it up to date and troubleshoot problems]] * [[Flash 11.3 crashes]] * [[Flash 11.3 doesn't load video in Firefox]] Other, more technical information about these issues can be found under these Links: * http://forums.adobe.com/thread/1018071?tstart=0 * http://blogs.adobe.com/asset/2012/06/inside-flash-player-protected-mode-for-firefox.html Please tell us if this helped!
Waka_Flocka_Flame 441 solutions 5048 answers

You should also try disabling FIrefox hardware acceleration and Flash hardware acceleration.

You should also try disabling FIrefox hardware acceleration and Flash hardware acceleration. * http://forums.adobe.com/thread/891337 * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]
jscher2000
  • Top 10 Contributor
3407 solutions 30919 answers

Thank you for uploading your settings. It seems you've reduced the amount of disk cache that Firefox can use. Could you try increasing that and see whether it has any effect on this problem?

orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Cached Web Content" section


I wonder whether the video recorder/downloader extensions could be holding the stream in memory longer than usual. You could disable one or all of them, or test in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Thank you for uploading your settings. It seems you've reduced the amount of disk cache that Firefox can use. Could you try increasing that and see whether it has any effect on this problem? orange Firefox button (or Tools menu) > Options > Advanced > Network mini-tab > "Cached Web Content" section ---- I wonder whether the video recorder/downloader extensions could be holding the stream in memory longer than usual. You could disable one or all of them, or test in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
cor-el
  • Top 10 Contributor
  • Moderator
12530 solutions 115512 answers

I think that Firefox is more likely to use the memory cache for such streamed media files.

What does it say about the caches on the about:cache page if you pause the playing after a few minutes?

Maybe you should consider to reset all prefs to cleanup and remove the obsolete prefs from older Firefox versions and possibly check the content of the user.js file as well.

I think that Firefox is more likely to use the memory cache for such streamed media files. What does it say about the caches on the about:cache page if you pause the playing after a few minutes? Maybe you should consider to reset all prefs to cleanup and remove the obsolete prefs from older Firefox versions and possibly check the content of the user.js file as well.

Question owner

Hello everyone, I have not forgotten about you. Over time, I've tried all the relevant suggestions here, but I still have crashes. Here is a screenshot of what happened on the most recent crash. As you can see, memory crept up and stayed near max, and then Firefox crashed.

Currently, I have set my cache to 1 GB. My initial settings were not a limitation; rather, it was Firefox's smart cache management that automatically capped it around 350 MB. Hardware acceleration has been disabled both on my browser and for Flash. I've tried disabling the video download extensions, but it still crashed (I've re-enabled them since).

I haven't been able to test extensively with Safe Mode because these crashes seem to happen randomly and after a while of usage. But I suspect SM is safe from these crashes (especially since the other suggestions haven't helped). Assuming SM is the solution, how can I fix this problem during normal usage?

Thanks all.

Hello everyone, I have not forgotten about you. Over time, I've tried all the relevant suggestions here, but I still have crashes. Here is a screenshot of what happened on the most recent crash. As you can see, memory crept up and stayed near max, and then Firefox crashed. Currently, I have set my cache to 1 GB. My initial settings were not a limitation; rather, it was Firefox's smart cache management that automatically capped it around 350 MB. Hardware acceleration has been disabled both on my browser and for Flash. I've tried disabling the video download extensions, but it still crashed (I've re-enabled them since). I haven't been able to test extensively with Safe Mode because these crashes seem to happen randomly and after a while of usage. But I suspect SM is safe from these crashes (especially since the other suggestions haven't helped). Assuming SM is the solution, how can I fix this problem during normal usage? Thanks all.
Waka_Flocka_Flame 441 solutions 5048 answers

There must be a addon interfering, or you need to disable hardware acceleration.

There must be a addon interfering, or you need to disable hardware acceleration. * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]
jscher2000
  • Top 10 Contributor
3407 solutions 30919 answers

Safe Mode also disables Firefox's use of hardware acceleration for graphics. This is helpful when Firefox is not fully compatible with your graphic card drivers. You can manually turn that off for normal mode.

You generally need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

orange Firefox button (or Tools menu) > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the issue resolved (or at least improved)?

Safe Mode also disables Firefox's use of hardware acceleration for graphics. This is helpful when Firefox is not fully compatible with your graphic card drivers. You can manually turn that off for normal mode. You generally need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). orange Firefox button (or Tools menu) > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available" If you restart Firefox, is the issue resolved (or at least improved)?

Question owner

As mentioned, I have already tried disabling hardware acceleration for both Firefox and Flash (which did not work).

Barring any known solutions, it seems my only option is to test my extensions. It is a daunting task since the issue seemingly arises randomly, and I value the usage of my extensions. Hopefully I can get back to everyone eventually. Will report back on any solutions.

As mentioned, I have already tried disabling hardware acceleration for both Firefox and Flash (which did not work). Barring any known solutions, it seems my only option is to test my extensions. It is a daunting task since the issue seemingly arises randomly, and I value the usage of my extensions. Hopefully I can get back to everyone eventually. Will report back on any solutions.
doomsdaze 0 solutions 1 answers

To remedy the situation Firefox needs to fix their shit - full-stop.

This was never a problem - maybe it was once in a while, but now, nearly every time I watch a video it starts lagging, I restart theFox; no-problem... for a little while.

I can literally watch the flash plugin sapping my ram. With so many bitching about this, it is not a problem that computer users need to sort out, it's FF's problem, ffs.

I really, really don't want to use Chrome. (was on a forum the other day and was gobsmacked how many people admitted to tossing FF to the side and adopting Chrome BECAUSE of this issue.)

I've even been subjected to watching some vids on IE!! my word, what is the world coming to?

To remedy the situation Firefox needs to fix their shit - full-stop. This was never a problem - maybe it was once in a while, but now, nearly every time I watch a video it starts lagging, I restart theFox; no-problem... for a little while. I can literally watch the flash plugin sapping my ram. With so many bitching about this, it is not a problem that computer users need to sort out, it's FF's problem, ffs. I really, really don't want to use Chrome. (was on a forum the other day and was gobsmacked how many people admitted to tossing FF to the side and adopting Chrome BECAUSE of this issue.) I've even been subjected to watching some vids on IE!! my word, what is the world coming to?
Waka_Flocka_Flame 441 solutions 5048 answers

Doomsdaze, may you please ask a new question (top of the page "Ask Question" button), and ask a new question with troubleshooting information.

Thanks in advance.

Doomsdaze, may you please ask a new question (top of the page "Ask Question" button), and ask a new question with troubleshooting information. Thanks in advance.

Modified by Waka_Flocka_Flame

Helpful Reply

Well, doomsdaze's rant didn't help solve my problem, but it actually makes me feel better about switching to Chrome.

Yes, I switched browsers, set up all-new extensions and settings, and accepted other inconveniences because I couldn't watch videos in peace on Firefox.

I had no idea there were so many others with this problem!

Well, doomsdaze's rant didn't help solve my problem, but it actually makes me feel better about switching to Chrome. Yes, I switched browsers, set up all-new extensions and settings, and accepted other inconveniences because I couldn't watch videos in peace on Firefox. I had no idea there were so many others with this problem!