X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Passwords cannot be saved in version 22. worked fine before the upgrade. I am NOT in the "Private Viewing" setting. It just will NOT save passwords.

Posted

The "dropdown for "Save passwords is NOT grayed out. Clicking the "save password box does NOTHING. I am running Windows XP SP3. The previous version (21) worked fine. Version 223 does not allow for passwords to be saved. I am NOT in the Private viewing mode. The ""Remember Passwords for sites" box under Tools/ Options/ Security is checked. "remember History" shows on Tools/ Options/ Privacy. As I said: Save passwords is no longer working with version 22. It worked on version 21. No settings were made with this upgrade. I am on another computer that does NOT have version 22 on it. I refuse to upgrade this computer.

Chosen solution

Here is what did work:

1. Backup/ Export "Bookmarks" as HTML

      ( I actually imported them into Internet Explorer)

2. Go into Control Panel/

3. Click "Add or Remove Programs or Windows Components"

4, Remove Mozilla Firefox and any other programs related to it.

    It will take some time to find anything related to 
    Firefox  and remove it.  Do this part for sure.

5. Download a new version of Mozilla Firefox.

6. Install and run this clean new installation.

7. Import the html backup of your bookmarks.

Removing all traces of the program and any old components seems to fix this. Whenever a "new" version comes out I will do this and save myself the grief.......Now to attempt this on one of the other computers in the office......

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • GEPlugin
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

smo 45 solutions 498 answers

Hello,

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Thank you.

Question owner

This is the THIRD Time I have done the "Reset Firefox". This Does NOT Work. There is an inherent problem with Firefox 22.

AGAIN: There IS an Inherent problem with Firefox 22 and Windows XP. It will NOT allow passwords to be saved. How do I get Firefox 21 that does work?

Now I must enter all the websites AGAIN..... I will NOT do a Reset on Firefox again...does NOT Help....

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello k6ohh, maybe the problem is the key3.db and signons.sqlite files that store the passwords in Firefox.

Try to rename the key3.db and signons.sqlite files in Firefox profile folder.

You can rename these files to key3.db.old and signons.sqlite.old, or you can move them to another location(folder, desktop) to make it possible to undo the action if the above does not solve the issue.

Also you need to make a new Master Password after the renaming or deleting these files and all your currently saved passwords are lost.

If the above works then you can remove the renamed files that are no longer needed, if does not work move it again in the profile folder and rename it to the previous name (key3.db and signons.sqlite).

see also : Password Manager - Troubleshooting

Your important data and their files


thank you

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Try to disable hardware acceleration in Firefox.

It is possible that there is a problem with the key3.db and signons.sqlite files that store the encrypted names and passwords in Firefox. Rename the key3.db and signons.sqlite files in the Firefox profile folder. You can add .old to the file names (key3.db.old and signons.sqlite.old) or move them to another folder to make it possible to undo the action. You need to set a new Master Password after renaming or deleting key3.db and all currently saved passwords are lost. If that has worked then you can remove the renamed files that are no longer needed.

See:

Helpful Reply

This does NOT work either. If you are not running Windows XP SP# and Firefox 22 please do not make these suggestions. These two "suggestions" do NOT work either. The problem is inherent with Firefox release 22. It will NOT allow the saving of passwords. Again: if you are not running Windows XP SP3 and Firefox 22 please do not offer these "suggestions"....

ideato
  • Top 25 Contributor
617 solutions 4263 answers

We are trying to help, i'm in xp and 22 also and i don't have the problem.

thanks again

Question owner

Here is what did work:

1. Backup/ Export "Bookmarks" as HTML

       ( I actually imported them into Internet Explorer)

2. Go into Control Panel/

3. Click "Add or Remove Programs or Windows Components"

4, Remove Mozilla Firefox and any other programs related to it.

     It will take some time to find anything related to 
     Firefox  and remove it.  Do this part for sure.

5. Download a new version of Mozilla Firefox.

6. Install and run this clean new installation.

7. Import the html backup of your bookmarks.

Removing all traces of the program and any old components seems to fix this. Whenever a "new" version comes out I will do this and save myself the grief.......Now to attempt this on one of the other computers in the office......

Modified by k6ohh

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hi, check also if the signon.autofillForms in about:config it is TRUE(the default), if it is not, make it TRUE(double-click on it).

http://kb.mozillazine.org/Signon.autofillForms


also check it in safe mode


thanks again

Chosen Solution

Here is what did work:

1. Backup/ Export "Bookmarks" as HTML

      ( I actually imported them into Internet Explorer)

2. Go into Control Panel/

3. Click "Add or Remove Programs or Windows Components"

4, Remove Mozilla Firefox and any other programs related to it.

    It will take some time to find anything related to 
    Firefox  and remove it.  Do this part for sure.

5. Download a new version of Mozilla Firefox.

6. Install and run this clean new installation.

7. Import the html backup of your bookmarks.

Removing all traces of the program and any old components seems to fix this. Whenever a "new" version comes out I will do this and save myself the grief.......Now to attempt this on one of the other computers in the office......

Jer 0 solutions 5 answers

I have same problem, but only with a new yahoo user. My old yahoo user ids work fine in, but one Yahoo user I added will not prompt to save password. Other sites will prompt to save password, the Mozilla site did fine. I have run in safe mode and the results were the same. Autofillforms is True. I am on version 22 of Firefox. I did just update to Ver 22, So the problem, with me, is just new Yahoo users and also when I change a Yahoo user password, it doesn't prompt me anymore if I want to update. I guess you could say it is a Yahoo problem, but then again i didn't have the problem prior to Ver 22. This all started because I like to change passwords every 30 - 60 days.

I should add, password changes made to Gmail and Facebook did get prompted to update new password. So I guess we know where the problem is?

Modified by Jer

Japie33 0 solutions 3 answers

Have same problem as mentioned above. Back from holiday two updates arrived at the same time, Firefox 22 and new Java software 10,25.2.17. I first thought Java was the culprit. The problem: all passwords are in Mozilla but are not presented when entering a site. Please provide easy solution. Also had the HD-screen problem of Firefox 22 which is solved. Firefox 22 should not have been distributed with those defects. (Windows XP SP3 with all updates installed)