Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address bar search with single word does not work

  • 26 replies
  • 38 have this problem
  • 4514 views
  • Last reply by bookraiders

more options

When I perform a single word search in the firefox address bar, such as 'asdf', 'google' 'test', i get rediredted to sitecrafting.com At first a web logo for sitecrafting shows up but my single word search is still in the address bar. Then after a second or two the sitecrafting.com address appears in the address bar and the screen refreshes to the sitecrafting.com website.

However, if i do a multiple word serch in the address bar, then i get a google search as expected. For instance 'asdf asdf' give me a google search results page for that two worded phrase.

I have done the keyword.url reset. I have uninstalled firefox and removed all profile/preference and then reinstalled. I have tested in safe mode with all addons disabled. None of these have fixed the problem.

Please oh please help me!!!!

All Replies (6)

more options

Thank you for the clarification. I do indeed have Tab Utilities (1.6pre5) installed.

more options

I'm not sure that the proper answer to the question of "why can't firefox do a search on a single word entered in the address bar" is to blame your DNS-lookup provider. Yes, I use OpenDNS, and yes, they return stupid advertising pages when my browser attempts to go to a non-existent URL. HOWEVER: both old (v. 12 and below) and new Opera, as well as Chrome, are smart enough to figure out that when I enter a single word into the omnibar, I WANT TO SEARCH IT. Obviously, there's some sort of rules-based parsing going on here. Why would that be too difficult for Firefox to implement? It seems rather Pollyanna-ish to just say "Gosh! I have no idea if that's a valid domain or a search keyword! Here, let me try a DNS-lookup on it!", especially when you consider that the majority of DNS providers "do the wrong thing". Seems more like a failure of design on Firefox's part, to me.

Modified by bookraiders

more options

You can set the keyword.enabled pref to false to disable the search and use a one letter keyword search if you want to do a search via the location bar. This will still not work properly in case your ISP or DNS service does an automatic redirect, but allows to do single word searches more reliably.

more options

See above: "Yes, I use OpenDNS, and yes, they return stupid advertising pages when my browser attempts to go to a non-existent URL."

more options

Hi bookraiders, you can file a request for enhancement bug at the following site:

https://bugzilla.mozilla.org/

Is the proposed change as simple as "if there is no period, skip the DNS lookup"?

In that case, there would be a change for local addresses (e.g., http://intranet/): users would need to type the protocol to bypass search. This might be acceptable to business users because after the first access, the autocomplete drop-down and autofill features would make future accesses easier.

more options

That does seem like a good solution, especially if "localhost" were to be included among the keywords that wouldn't trigger a search.

Modified by bookraiders

  1. 1
  2. 2