X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Error messages with Javascript

Posted

I continually get this error message after Firefox updated. I am running FF 22.0. I updated Java, no joy in getting rid of the error messages, " evalInSandbox:Error: Permission denied for <https://facebook.com> to create wrapper for object of class UnnamedClass" & "Error: Permission denied for <https://facebook.com> to create wrapper for object of class UnnamedClass". It's something with the Javascript application. Any idea as to why these messages keep popping up & how do I fix this?


moderator corrected the title for this thread

Modified by the-edmeister

Chosen solution

hello, update your social fixer addon - this should address the issue: http://socialfixer.com/blog/category/releasenotes/

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Yahoo Application State Plugin version 1.0.0.7
  • DivX Plus Web Player version 2.2.0.52
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • DivX VOD Helper Plug-in

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Forecastfox 2.2.2 ({0538E3E3-7E9B-4d49-8831-A227C80A7AD3})
  • Social Fixer 7.501 (socialfixer@mattkruse.com)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • avast! Online Security 8.0.1489 (wrc@avast.com) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 520
  • adapterDescription2:
  • adapterDeviceID: 0x1040
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7600.16385
  • driverDate: 2-29-2012
  • driverDate2:
  • driverVersion: 8.17.12.9610
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 520 )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.google.com/
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • dom.max_chrome_script_run_time: 0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372359887
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.blocklisted.npviewpoint: True
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.java: 2
  • plugin.state.npdeployjava: 2
  • privacy.sanitize.migrateFx3Prefs: True
  • security.csp.enable: False
  • security.default_personal_cert: Select Automatically
  • security.disable_button.openDeviceManager: False
  • security.OCSP.enabled: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1372009539

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2044 solutions 8899 answers

Chosen Solution

hello, update your social fixer addon - this should address the issue: http://socialfixer.com/blog/category/releasenotes/

Question owner

Thanks, Philipp. That appears to have solved the problem. I knew it had to have been one of the add ons, but I tried disabling them one by one and still got the error message. I may have missed that Social Fixer one, I don't recall.