X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I download Firefox 21???

Posted

Hi folks,

I've got the feeling that I've been here before!! I logged on this morning, and my Roboform toolbar was missing (again)!

Eventually, I discovered that Firefox had updated from V21 to V22 overnight. A quick Google search has led me to discover that V22 does not work with Roboform. Therefore I need to get back to V21. I cannot find anywhere how to get back to V21.

I have found in my downloads folder the V20 link, so I now have V20 reinstalled (= Roboform is working again), but I would rather have V21.

Anyone got any ideas about how to to this???

Thanks

Chosen solution

Update Roboform to 7.9.0, and Firefox to 22 and everything will be running smooth again

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • Google Update
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • GEPlugin
  • 5.1.20125.0
  • Facebook Video Calling Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Open Bookmarks in New Tab 0.1.2012122901 (openbookmarkintab@piro.sakura.ne.jp)
  • Open Link in New Tab 0.1.2012122901 (openlinkintab@piro.sakura.ne.jp)
  • RoboForm Toolbar for Firefox 7.8.9.5 ({22119944-ED35-4ab1-910B-E619EA06A115})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • HDvid Codec 2.0 (hdvc@hdvc.com) (Inactive)
  • Skype Click to Call 6.9.0.12585 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)
  • SweetPacks Toolbar for Firefox 1.13.0.0 ({EEE6C361-6118-11DC-9C72-001320C79847}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Mobility Radeon HD 4330
  • adapterDescription2:
  • adapterDeviceID: 0x9552
  • adapterDeviceID2:
  • adapterDrivers: atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 7-29-2009
  • driverDate2:
  • driverVersion: 8.634.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Mobility Radeon HD 4330)
  • windowLayerManagerType: Direct3D 9

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow.restriction: 0
  • browser.link.open_newwindow.restriction.backup: 2
  • browser.places.smartBookmarksVersion: 4
  • browser.search.openintab: True
  • browser.sessionstore.max_resumed_crashes: 100
  • browser.startup.homepage: https://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.internaluseonly.changed: False
  • keyword.URL: http://search.sweetim.com/search.asp?src=6&barid={DF889AB9-B19A-11E2-A6C4-A4BADBA51B56}&crg=3.1010000.10011&st=23&q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372319817
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, roboform has a new toolbar version 7.9.0.0 available on its website which will work with the current firefox release.

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6629 answers

Chosen Solution

Update Roboform to 7.9.0, and Firefox to 22 and everything will be running smooth again

mickatron 0 solutions 7 answers

Helpful Reply

If you do need version 21 EN-US.

For others looking you can download version 21 EN-US from; https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/21.0/win32/en-US/Firefox%20Setup%2021.0.exe

The article which I got the link from was; https://support.mozilla.org/en-US/kb/install-older-version-of-firefox

Windwalker1 0 solutions 2 answers

It seems I have the same issue here yet my skills are yet be developed to "update Roboform to 7.9.0". I got to the download version 21 EN-US part ,but the rest is stumping me. Could some here assist me?

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, downgrading firefox is the wrong way of tackling this issue - simply download and install the current roboform for windows setup file from http://www.roboform.com/download and you should be good.

Windwalker1 0 solutions 2 answers

Thanks fro responding Philipp. I just talked with a Kasperski rep who let me know that their and firefox 'extentions' compatibility with the firefox 23 version are yet to be ironed out. So for the mean time I am recommended to use firefox 21. I am new to the roboform (as in never used it before) and I type my passwords out each time EXCEPT last night when firefox would not even trust google.com ( i got a crazy pop up saying Untrusted site/unverified certificate -- essentially 'danger'). I went to Chrome for a minute and yahoo too for a minute and everything 'went through' fine.

Today I'm trying to find out what's going on. So what, really, is a download of roboform going to help me with -- I think is the question.

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

Helpful Reply

roboform is a separate program which integrates into firefox - if you want to download firefox 21 for another reason then what was said about it doesn't apply to your situation...

the firefox extensions that kaspersky offers are mere gimmicks and aren't necessary for the anti-virus engine to protect you. on the other hand downgrading firefox two versions will leave you vulnerable to multiple known vulnerabilities, so from a security standpoint it's far better to keep your browser up to date.

in case you want to install firefox 21 nevertheless, fully download it from the link posted above (if there is a part file it indicates that the download is not yet finished), and double-click the file in order to launch the installation.