X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The new version I installed today (6/25/13) keeps resizing the desktop size of the browser to some gawd awfully large size. how can I make it stop???

Posted

this is not an issue of running at full screen or minimizing/maximizing.. I resize it down and launch later and it comes back as a large sized desktop.

Chosen solution

Hi Griffvan, Firefox now adjusts the page zoom level according to your Windows settings, to better support high DPI displays. For example, if Windows is set to 125% font size (120dpi), the content area will be zoomed by 25% compared with Firefox 21 and earlier.

The straightest line back toward the earlier style of display is the following two step approach:

Step 1: Install the Theme Font & Size Changer extension. Why? Because turning off the scaling affects the chrome area (menus, toolbars, and tabs) as well as the content.

After restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This should take effect immediately without another restart.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • iTunes Detector Plug-in
  • GEPlugin
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • PDFlite Browser Plugin
  • NPWLPG
  • The Hulu Desktop Plugin allows Hulu.com to integrate with the Hulu Desktop application.
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Regarding Firefox menus, toolbars, and pages:

Firefox now tries to adjust the zoom level according to your Windows settings, as well as better supporting high DPI displays.

You can try adjusting the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) If layout.css.devPixelsPerPx has been customized from its default value of -1.0, right-click it and choose Reset to assess whether the default value works for you.

If not...

(4) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for smaller fonts, or a larger ratio for larger fonts. For example, 1.25 corresponds to 125% font size in Windows display settings. You may need to switch back and forth to other windows/tabs to see how it's affecting them.

Can you find a good size?

More info in this thread: How do I set the default font size to a lower value?

Regarding the Windows desktop or other applications:

Setting a low resolution on the Compatibility tab of the Firefox program shortcut can cause all of Windows to resize when you run Firefox. Right-click your shortcut > Properties > Compatibility, I suggest clearing all settings here so Firefox runs using its default settings.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

see here - https://support.mozilla.org/en-US/questions/962990

Question owner

I was a bit quick to hit "solved." The aforementioned will resize the browser and the content within the tab, but the only thing that sticks is the brower's font size (i.e. the links, menus, etc) and not that actually content in the window. If i resize using the native windows option with the touch pad it will stay so long as the browser is open. Close and open the browser again and the 1.0 value stays for the browser but the content is blown up again.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

How about Restarting firefox? Does that work?

Modified by Waka_Flocka_Flame

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Site-specific zoom levels should be retained between sessions. However, that might not apply to "private" windows. Are you in private browsing mode?

Do you use any Zoom-related extensions such as NoSquint or Default FullZoom Level? If so, you may need to update them and check their settings to see how they work with Firefox 22.

If you do not use either of those but you want to try using one to adjust your default page zoom level, here are the links:

After setting your Global zoom level, you can still fine-tune the zoom on individual sites using Firefox's standard zoom feature (keyboard shortcut or mouse wheel).

Griffvan 0 solutions 2 answers

I have the same issue - the browser is larger than 100% and is causing problems on some sites I use. I need an explanation in plain english for dummies on how to fix this. Happened after an update, nothing I caused. Please help, this is driving me nuts.

Modified by Griffvan

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Chosen Solution

Hi Griffvan, Firefox now adjusts the page zoom level according to your Windows settings, to better support high DPI displays. For example, if Windows is set to 125% font size (120dpi), the content area will be zoomed by 25% compared with Firefox 21 and earlier.

The straightest line back toward the earlier style of display is the following two step approach:

Step 1: Install the Theme Font & Size Changer extension. Why? Because turning off the scaling affects the chrome area (menus, toolbars, and tabs) as well as the content.

After restarting Firefox, click the new "A" icon at the right end of the navigation toolbar and change the font size from Normal to 15.

Step 2: Change your global scaling in the about:config preferences editor.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for Firefox 21-sized fonts in the content area.

This should take effect immediately without another restart.

Griffvan 0 solutions 2 answers

Thank you for your help - I just went and changed the Windows back to 100% (I have no idea how it got on 125% in the first place) and that did the trick.