X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox screen blown up after update

Posted

After updating, the design, layout and text of firefox has 'blown up'; it's too large.

The only advice I consistently got after searching was to try View > Zoom etc.,

That only changed the screen I was in and reverted after changing to a new page, opening a new tab or restarting firefox.

I need a permanent solution where the firefox screen is where it was before.

Chosen solution

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

EDIT by AliceWyman: To summarize:

  1. In the Firefox address bar, type about:config and press the Enter key.
    If the "This might void your warranty!" warning appears, click I'll be careful, I promise! to continue.
  2. Search for the layout.css.devPixelsPerPx preference
  3. Double-click the entry and change its value from -1.0 to 1.0
    (you can adjust this up or down if needed, e.g, to 1.1 or 0.9).

Note that changes take effect immediately. To set it back to it's default value, right-click the preference and select Reset.


If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.20125.0
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

http://www.mozilla.org/en-US/firefox/22.0/releasenotes/

2nd one

To fix:

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page. Type "layout.css.devPixelsPerPx" double click it and type 1.0, hit enter.

Modified by Waka_Flocka_Flame

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Firefox now tries to adjust the zoom level according to your Windows settings, as well as better supporting high DPI displays.

You can try adjusting the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste pix and pause while the list is filtered

(3) If layout.css.devPixelsPerPx has been customized from its default value of -1.0, right-click it and choose Reset to assess whether the default value works for you.

If not...

(4) Double-click layout.css.devPixelsPerPx and change its value to 1.0 for smaller fonts, or a larger ratio for larger fonts. For example, 1.25 corresponds to 125% font size in Windows display settings. You may need to switch back and forth to other windows/tabs to see how it's affecting them.

Can you find a good size?

More info in this thread: How do I set the default font size to a lower value?


Workarounds

If you cannot adjust both the "chrome" area and the "content" area to your liking simultaneously, you might need an extension to correct one or the other:

Modified by jscher2000

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

huh we have the same resolution

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi Waka_Flocka_Flame, you were much faster than me in posting. :-)

Question owner

Thank you both - I'm sure you get this question a lot, to say the least.

Looks good so far.

(Might try 1.25)

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Likely no 1 question that will be asked next couple of days as FF 22 spreads as this is a new feature.

hordon 0 solutions 7 answers

I can't return my old convinient scale with adjusting layout.css.devPixelsPerPx parameter.

Are there other ways to fix this annoying scale thing? Otherwise I'll have to downgrade to v.21 :(

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

did you try the layout.css.devPixelsPerPx tweaks we provided, you should change it to 1.0 instead of -1.0.

hordon 0 solutions 7 answers

Yes, I did. I tried different decimals also. This solution doesn't work for me.

Running FF in a Safe mode didn't show any changes as well.

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi hordon, the change to Firefox affects both the menu/toolbar/tab area and the pages. Are you getting the same size everywhere, or one is right and the other is wrong?

The following extensions are known to tweak sizes or zoom levels. If you have any of these, please update your extensions and check to see whether they have any changes related to Firefox 22, or adjust their defaults.

To check for extension updates:

orange Firefox button (or Tools menu) > Add-ons > "gear" icon > "Check for Updates"

Any luck?

hordon 0 solutions 7 answers

Hi jscher.

Setting layout.css.devPixelsPerPx to 1.0 combined with Theme Font & Size Changer works. Thank you!

Though I'm not very happy with keeping an additional extension for just to deal with this issue. I hope there will be a better in-build fix soon.

Modified by hordon

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Windows Vista, 7, and 8 have a feature called DPI virtualization which might enlarge the display in some applications. This shouldn't happen with Firefox, but to rule this out, DPI virtualization can be disabled globally (in the Display control panel) or just for Firefox (on the Compatibility tab of the Firefox shortcut properties). If anyone experiments with this, please report on your results.

Probably not relevant. Never mind.

Modified by jscher2000

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96831 answers

Chosen Solution

Code changes regarding HiDPI support for high resolution displays have landed in Firefox 22 and later (bug #844604).

You can modify the layout.css.devPixelsPerPx and increase or decrease the value in 0.1 or 0.05 steps to adjust the size of fonts and other elements in Firefox.

  • The layout.css.devPixelsPerPx pref is a String value parsed to a float and allows to fine tune the dimensions of all elements (user interface and web pages) more precisely (resolution 0.1 or 0.05).
  • Change the default value -1 to 1 to make it work like in previous Firefox versions (100%)

Start with a value of 1 and adjust this value with 0.1 steps or 0.05 for finer adjustments.

  • Use values between 1.0 and about 0.5 to reduce elements in size (do NOT go all the way to 0.05!)
  • Use values greater than 1.0 to magnify and make elements larger (percentage divided by DPI, % / DPI).
  • http://kb.mozillazine.org/about:config

EDIT by AliceWyman: To summarize:

  1. In the Firefox address bar, type about:config and press the Enter key.
    If the "This might void your warranty!" warning appears, click I'll be careful, I promise! to continue.
  2. Search for the layout.css.devPixelsPerPx preference
  3. Double-click the entry and change its value from -1.0 to 1.0
    (you can adjust this up or down if needed, e.g, to 1.1 or 0.9).

Note that changes take effect immediately. To set it back to it's default value, right-click the preference and select Reset.


If web pages needs to be adjusted after changing this pref then you can look at the Default FullZoom Level or NoSquint extension.

Use this extension to adjust the font size for the user interface:

Modified by AliceWyman

Question owner

Thanks hordon for bringing that up. I'll try jscher's recommendations too if they worked for you.

Modified by rayznack

Guymax 0 solutions 12 answers

Helpful Reply

Why do we have to change anything?

I don't get this, everything was PERFECT with 21 and now 22 F'ed up everything.

I shouldn't be having to download any type of "adjusting add on" or hacking the settings in the software.

PUT MY FF THE WAY IT WAS (back to normal). This HiDPI crap is not for Firefox to touch...that's why we adjusted the DPI in Windows in the first place to get things larger and now Firefox is making them even MORE larger...WTF?

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi Guymax, so that we can get a better understanding of how Firefox 22 is working on different Windows setups, could you reply with:

  • Windows OS version (e.g., XP, Vista, 7, 8)
  • Windows DPI setting (e.g., 125% text size, or 120ppi)
  • Firefox layout.css.devPixelsPerPx setting (e.g., default of -1.0 or another setting)

My understanding is that the chrome area (menu, toolbar, tabs) should look like other applications at the default setting (-1.0), while the content area should be zoomed exactly as set in your Windows DPI setting. However, if you do not get that, it would be really helpful to get more detail on where it doesn't work that way.

I suspect zooming the content area to 125% (if that is your Windows setting) is more than you're used to. (110% or 120% would be more typical using Firefox's zoom feature.)

Guymax 0 solutions 12 answers

Vista SP2 Home Premium DPI 115% layout.css.devPixelsPerPx 1.0 Zoom 100% (added feature, NOT part of Firefox original set up)

jscher2000
  • Top 10 Contributor
2365 solutions 20925 answers

Hi Guymax, setting layout.css.devPixelsPerPx to 1.0 should have restored the content area to look like Firefox 21. If you prefer that setting and the chrome area (menu, toolbars, tabs) is too small at that setting, as a workaround you can use the Theme Font & Size Changer extension to upsize the chrome area.

Guymax 0 solutions 12 answers

Helpful Reply

Yep I know I had to use the Theme Font & Size Changer because otherwise the "chrome area" is too small.

The question is WHY? Why is it touching the "chrome" area. Setting the PPPx to 1.0 is NOT returning the menus to version 21 status.

The only thing Firefox should be allowed to make bigger or smaller is the content IN it's own window not the window it self.

My Firefox window actually GREW larger after restart of receiving the 22 update.

We shouldn't have to do all this work just to have a (any) browser do it's job correctly.

Once again it (the browser) shouldn't be touching what Windows DPI is already doing.

Modified by Guymax