Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Can't copy and paste from Firefox 22.0 anymore other than ctrl c & v

  • 92 replies
  • 115 have this problem
  • 262 views
  • Last reply by GP49

more options

Normally I would select/wrap text in Firefox and right click and choose copy from the top of menu, click and go to Word,Notepad etc. and go to paste but nothing there paste item in menu greyed out.

It works ok ctrl v and c but is frustrating because the built-in function is so much cleaner

  • UPDATE - Downloaded Firefox 23.0 Beta1 - problem is gone - works again - Thanks all!!

Modified by jimmy-d

Chosen solution

The developers have created a fix for this problem for future versions of Firefox (Firefox 23+). Unfortunately, there's no immediate solution for Firefox 22.

The current beta of Firefox 23 does not yet contain the fix. It is included in beta 6, but that is not yet available through the "all beta" page.

Update: The main beta page now offers beta "8" which has the fix. The file you download should have 23.0b8 in the file name.

Note: Firefox 23 is scheduled for release on August 6th, but it isn't pushed out to everyone all at once. You might need to visit the main install page to get it if your Firefox doesn't detect the new version on the 6th or 7th.

Read this answer in context 👍 3

All Replies (12)

more options

Same problem here. I am also using a Windows 8 Sony Vaio touchscreen laptop (but using the Win7 desktop) which I have not had for very long and I thought it was the machine that the problem until I tried a different browser. Even Ctrl+C, Ctrl+V does not work for me except on very rare occasions.

As we trade on ebay and Amazon it is a real pain since I am copying and pasting customer addresses to our labelprinter program hundreds of times a day. I have reverted back to v21 for now but a fix cannot come quickly enough because the tabs are far too small for touch in v21.

I am also using Zonealarm but disabling it made no difference.

Scrolling using the touchscreen seems to be an issue too, sometimes it works, sometimes it doesn't, even from tab to tab. Example one site will scroll, go to the next tab, try to scroll using the touchscreen and nothing happens (you have to use the scrollbar)

Modified by coolcity

more options

The problem did not exist before Firefox 22. Nothing else changed.

Ergo: it is a Firefox problem. No reason we should have to backdate our Firefox installation to "fix" the problem, either; or wait (for how long) until Firefox V.23 is issued.

more options

Amen!

more options

Agreed, but I can never be too harsh on what is, after all, a free resource and at least the temporary solution does the job.

more options

Hi coolcity, Firefox 23 is scheduled to release on August 6th.

This morning, the main beta page pushes me the installer for beta 8 (you will see b8 in the file name), which should contain the fix. Although "beta" versions are for testing and are expected to have a few more bugs than the final release, the beta should be close to the final code by this time.

If you choose to try it, it's never a bad idea to back up your settings when switching between the regular releases and the beta releases, and vice versa. This article has some tips on that: Back up and restore information in Firefox profiles.

more options

Hi,

Thanks for the informative reply. I am too busy to be playing around with it at the moment to be honest, I will just wait for v.23, another week or so isn't going to hurt and it is still the best browser on the planet bar none.

The android version seems a bit slow though (compared to Chrome) but then you can't have everything.

more options

FYI disabling the Flag Fox add on in v22 fixed this for me on win xp.

Jimmy

Modified by Jimmy

more options

The Flag Fox addon does not exist on my Firefox 22, and never has on ANY version of Firefox here. So it can't be the cause of this problem on my Firefox, though there may be some code in it that is the same as in some other program, causing the trouble.

ALSO: today I had at least two instances of CTRL-C not working, just like the Copy feature in the right-click mouse dropdown menu and the Edit-Copy feature didn't work, either. I had to un-highlight the text, re-highlight it and then do CTRL-C to copy properly.

more options

Yes I have the same issue, whether selecting and copying either Via right click, the Copy button or by usingCtrl+C, it just doesn't work most of the time.

Hint: You can quickly tell if Copy has worked our not by adding the Paste button to the bar and selecting a text field. If you have copied successfully the Paste button will light up and not be grayed out.

I don't have Flag Fox and disabled all other add-ons; no joy.

Not a big deal though since v23 is released in a few days.

Modified by coolcity

more options

WORK AROUND FOR ZA 11?

Just got it working in FF v22.0 after toggling OS Firewall setting in ZA (Free) 11. Running Avast Free 8, Windows Defender is turned off, all Live Essentials components removed (use Thunderbird 17.08), and the Windows Firewall service is disabled. This is a new Windows 8 x64 laptop, so all of this was downloaded in the last few weeks, so are fairly current versions. Windows updates are current with all important updates up through 8/20/13, as well as some optional components like .Net and such.

All I did was go into ZA and View Details on the firewall panel, then hit settings under Application Control, then Advanced Settings in lower right corner. Clicked the tab for OS Firewall and turned it off. Hit OK/backed out of ZA and was able to copy/paste from web pages to clipboard again as normal.

Now, here's the really odd thing. I went back into ZA and turned it on again, and it is still working.

PS: Not loading much in FF--just the Deskcut extension to simplify getting shortcuts to desktop. For some reason, since I started using Classic Shell to get a decent start button going, FF doesn't minimize when I drag the favicon to start bar like it used to. Otherwise it's just Avast's security, Flash, etc--the usual stuff that gets into most browsers.

Modified by RAIST5150

more options

I just (on 23 August 2013) downloaded the latest version and it still does not work.

more options

For me, the update to FF 23.0 fixed the "Can't copy and paste" problem totally.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5