Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

Enabling copy and paste

  • 9 replies
  • 34 have this problem
  • Last reply by Johnathome

more options

We recently received the FireFox ESR 24 that now prevents us from being able to copy/paste within a web-based application using Ctrl+C / Ctrl+V or right-click copy/paste menus. Is there a fix for this? We have tried installing RightToClick, but this does not work either.

All Replies (9)

more options

There's nothing in Firefox that prevents you from copying and pasting things with the context menu or keyboard shortcuts.

If you're having problems with a online editor website, make sure dom.event.clipboardevents.enabled is set to true in about:config.

RightToClick is only useful if you've encountered a website that prevents the context menu from showing, or replaces it with a custom menu that isn't useful. Even without that add-on, you can always hold down the Shift key when you right-click to show Firefox's context menu instead of the website's.

If the problems persist, first check if the issue goes away when starting Firefox with Add-ons Disabled. If that doesn't help, post an example link that's giving you trouble.

more options

We have checked the setting referenced in your reply (dom.event.clipboardevents.enabled) to no avail. We get the following message when trying to copy/paste within this particular web-based application (Oracle's RPAS tool); however have verified the recommended setting and it still does not work. That message was: You need set signed.applets.codebase_principal_support=true in about:config.

I'm starting to think it's a compatibility issue between Oracle's copy/paste functionality and FireFox.

more options

Use keyboard shortcuts if the buttons on the web page or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command + V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command + X)

See also:

more options

Already tried short cut method works. Even created a user.js file to attempt to modify settings to no avail. Perhaps it's more of a compatibility issue with the new version of Oracle's software and not so much FireFox.

more options

I can't say what's going on the page without a link to it, but I'd guess the site is requesting privileges that are no longer being granted. You can probably get more information if you press Ctrl+Shift+K to open the web console, click the Clear button, then attempt to perform the actions that fail to work.

  • [WONTFIX] Bug 789327 - Copy to clipboard failed - about:config preference signed.applets.codebase_principal_support also failed.
  • Bug 546848, comment 57 - Remove support for enablePrivilege
more options

Websites no longer can enable this privilege, but doing this manually by setting prefs via the user.js files should still work.

more options

So now we are able to copy/paste if we're copying data from within the browser into the browser...but if I wanted to copy values from an excel datasheet and then paste them into the browser, this appears to still be prevented. Our application does provide a "Paste from External" option; however it is more cumbersome than simply doing a Ctrl+V. I think we may have to live with it though.

more options

Glad to hear that it's working!

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently. .

more options

I had the same problem. Ctrl-C did not work in my Firefox because I had the add-on Translator installed, the one with the large red T. In the options box of T-translator I had a mark in the "Hotkey for the action chosen above" part in the box left of "Ctrl". I disabled that mark and after restart I was able to use Ctrl-C again within Firefox.