X
Tap here to go to the mobile version of the site.

Support Forum

This thread was closed and archived. Please ask a new question if you need help.

Enabling copy and paste

Posted

We recently received the FireFox ESR 24 that now prevents us from being able to copy/paste within a web-based application using Ctrl+C / Ctrl+V or right-click copy/paste menus. Is there a fix for this? We have tried installing RightToClick, but this does not work either.

We recently received the FireFox ESR 24 that now prevents us from being able to copy/paste within a web-based application using Ctrl+C / Ctrl+V or right-click copy/paste menus. Is there a fix for this? We have tried installing RightToClick, but this does not work either.

Additional System Details

Installed Plug-ins

  • Google Update
  • 5.1.30214.0
  • Citrix Online App Detector Plugin
  • Microsoft Lync 2010 Meeting Join Plug-in
  • Next Generation Java Plug-in 10.45.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Shockwave Flash 11.7 r700
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.1"
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.8.612
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Store Netscape Plugin
  • Npdsplay dll
  • DRM Netscape Network Object
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0.12) Gecko/20100101 Firefox/10.0.12

More Information

Gingerbread Man 403 solutions 1537 answers

There's nothing in Firefox that prevents you from copying and pasting things with the context menu or keyboard shortcuts.

If you're having problems with a online editor website, make sure dom.event.clipboardevents.enabled is set to true in about:config.

RightToClick is only useful if you've encountered a website that prevents the context menu from showing, or replaces it with a custom menu that isn't useful. Even without that add-on, you can always hold down the Shift key when you right-click to show Firefox's context menu instead of the website's.

If the problems persist, first check if the issue goes away when starting Firefox with Add-ons Disabled. If that doesn't help, post an example link that's giving you trouble.

There's nothing in Firefox that prevents you from copying and pasting things with the context menu or keyboard shortcuts. If you're having problems with a online editor website, make sure ''dom.event.clipboardevents.enabled'' is set to '''true''' in [http://kb.mozillazine.org/About:config about:config]. RightToClick is only useful if you've encountered a website that prevents the context menu from showing, or replaces it with a custom menu that isn't useful. Even without that add-on, you can always hold down the Shift key when you right-click to show Firefox's context menu instead of the website's. If the problems persist, first check if the issue goes away when starting Firefox with Add-ons Disabled. If that doesn't help, post an example link that's giving you trouble. * [[Troubleshoot Firefox issues using Safe Mode]]

Question owner

We have checked the setting referenced in your reply (dom.event.clipboardevents.enabled) to no avail. We get the following message when trying to copy/paste within this particular web-based application (Oracle's RPAS tool); however have verified the recommended setting and it still does not work. That message was: You need set signed.applets.codebase_principal_support=true in about:config.

I'm starting to think it's a compatibility issue between Oracle's copy/paste functionality and FireFox.

We have checked the setting referenced in your reply (dom.event.clipboardevents.enabled) to no avail. We get the following message when trying to copy/paste within this particular web-based application (Oracle's RPAS tool); however have verified the recommended setting and it still does not work. That message was: You need set signed.applets.codebase_principal_support=true in about:config. I'm starting to think it's a compatibility issue between Oracle's copy/paste functionality and FireFox.
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Use keyboard shortcuts if the buttons on the web page or other methods aren't working.

  • Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C)
  • Paste: Ctrl+V or Shift+Insert (Mac: Command + V)
  • Cut: Ctrl+X or Shift+Delete (Mac: Command + X)

See also:

Use keyboard shortcuts if the buttons on the web page or other methods aren't working. *Copy: Ctrl+C or Ctrl+Insert (Mac: Command + C) *Paste: Ctrl+V or Shift+Insert (Mac: Command + V) *Cut: Ctrl+X or Shift+Delete (Mac: Command + X) See also: *http://kb.mozillazine.org/Clipboard_not_working

Question owner

Already tried short cut keys...no method works. Even created a user.js file to attempt to modify settings to no avail. Perhaps it's more of a compatibility issue with the new version of Oracle's software and not so much FireFox.

Already tried short cut keys...no method works. Even created a user.js file to attempt to modify settings to no avail. Perhaps it's more of a compatibility issue with the new version of Oracle's software and not so much FireFox.
Gingerbread Man 403 solutions 1537 answers

Helpful Reply

I can't say what's going on the page without a link to it, but I'd guess the site is requesting privileges that are no longer being granted. You can probably get more information if you press Ctrl+Shift+K to open the web console, click the Clear button, then attempt to perform the actions that fail to work.

  • [WONTFIX] Bug 789327 - Copy to clipboard failed - about:config preference signed.applets.codebase_principal_support also failed.
  • Bug 546848, comment 57 - Remove support for enablePrivilege
I can't say what's going on the page without a link to it, but I'd guess the site is requesting privileges that are no longer being granted. You can probably get more information if you press Ctrl+Shift+K to open the web console, click the Clear button, then attempt to perform the actions that fail to work. * [WONTFIX] [https://bugzilla.mozilla.org/show_bug.cgi?id=789327 Bug 789327] - Copy to clipboard failed - about:config preference signed.applets.codebase_principal_support also failed. * [https://bugzilla.mozilla.org/show_bug.cgi?id=546848#c57 Bug 546848, comment 57] - Remove support for enablePrivilege
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Websites no longer can enable this privilege, but doing this manually by setting prefs via the user.js files should still work.

Websites no longer can enable this privilege, but doing this manually by setting prefs via the user.js files should still work. *[[/questions/936323]]#answer-393468 * http://kb.mozillazine.org/Granting_JavaScript_access_to_the_clipboard

Question owner

So now we are able to copy/paste if we're copying data from within the browser into the browser...but if I wanted to copy values from an excel datasheet and then paste them into the browser, this appears to still be prevented. Our application does provide a "Paste from External" option; however it is more cumbersome than simply doing a Ctrl+V. I think we may have to live with it though.

So now we are able to copy/paste if we're copying data from within the browser into the browser...but if I wanted to copy values from an excel datasheet and then paste them into the browser, this appears to still be prevented. Our application does provide a "Paste from External" option; however it is more cumbersome than simply doing a Ctrl+V. I think we may have to live with it though.
Moses
  • Moderator
459 solutions 3607 answers

Glad to hear that it's working!

If you have not already, please mark this thread as solved by marking the solution.
This will help other users experiencing similar problems find help faster and more efficiently. .

Glad to hear that it's working! If you have not already, please mark this thread as solved by marking the solution.<br> This will help other users experiencing similar problems find help faster and more efficiently. .
Johnathome 0 solutions 1 answers

I had the same problem. Ctrl-C did not work in my Firefox because I had the add-on Translator installed, the one with the large red T. In the options box of T-translator I had a mark in the "Hotkey for the action chosen above" part in the box left of "Ctrl". I disabled that mark and after restart I was able to use Ctrl-C again within Firefox.

I had the same problem. Ctrl-C did not work in my Firefox because I had the add-on Translator installed, the one with the large red T. In the options box of T-translator I had a mark in the "Hotkey for the action chosen above" part in the box left of "Ctrl". I disabled that mark and after restart I was able to use Ctrl-C again within Firefox.