X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox unable to play youtube videos: "An error occurred, please try again later."

Posted

Tried deleting cookies, clearing history, reinstalling flash, firefox safe mode, all add ons turned off, made a different firefox profile, restarted firefox to its default settings. Nothing works, start playing any youtube video and at the 1 second mark the error appears. It doesn't matter if the video is embedded.

Curiously, youtube does work in chrome.

What do I do?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.4 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • FireShot 0.98.34 ({0b457cAA-602d-484a-8fe7-c1d894a011ba})
  • Readability 2.4 (readability@readability.com)
  • Reddit Enhancement Suite 4.2.0.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7480D
  • adapterDescription2:
  • adapterDeviceID: 0x9993
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7480D)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1370466878
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Clear the cache and the cookies from websites that cause problems.

"Clear the Cache":

  • Firefox/Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Firefox/Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Question owner

I've done those things already and they did not work. I am still unable to play any youtube videos past the 1 second mark. Same error message as before

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can check for problems with current Flash plugin versions and try these:

  • disable a possible RealPlayer Browser Record Plugin extension for Firefox and update the RealPlayer if installed
  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)
  • disable hardware acceleration in the Flash plugin

Question owner

Still no luck.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

danindub 0 solutions 4 answers

Same issue here. On hundreds (!) of machines in the office.

Mix of Firefox 22/23. Flash from 11.3 to 11.8. All experiencing the same issue. No such problems with Chrome.

Resetting/reinstalling firefox brings no improvement.

danindub 0 solutions 4 answers

Just to add:

We've tried enabled/disabled hardware acceleration, disabling protected mode in flash, clearing cookies and history, resetting firefox, reinstalling firefox from scratch, updating Flash plugin, disabling all the plugins in firefox, safe more...

So far no joy.

Kirck 0 solutions 4 answers

I've the same problem, I tried with a clean firefox's profile, disabling hardware acceleration from firefox and flash, disabling protect mode, installing an older flash's version, and nothing works.

I think that the problem is NOT firefox, because with the internet explorer I have the same probem, only videos in youtube, the rest portals like vimeo works correctly.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Make sure that your security software isn't blocking cookies.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

Kirck 0 solutions 4 answers

Hello cor-el, I tried your solution but I still have the same error

Keithf 0 solutions 1 answers

I found a solution for me................ Several weeks ago I added a SPRINT AirWave to my home network. They instruct you to install the AirWave (for efficiency) first off the cable modem, etc. and add your home network after the AirWave. I read on a YOUTUBE forum that putting the router first and moving the the AirWave to your router solves the problem. I did! It did! Thanks to Sprint for identifying the issue. You might not have an AirWave on your net but there might be something else in the path.

phantoms 0 solutions 7 answers

Helpful Reply

If your computer doesn't have any sound (no speakers hooked up, etc. then plug in a set of headphones and see if it works. I know it sounds funny, but I've been dealing with this problem for months on a work computer that has no speakers. Plugging in a set of headphones fixed the problem.

Youtube now requires a sound device present to work correctly.

Kirck 0 solutions 4 answers

Hello phantoms, I found the same solution yesterday. My coworker gave me a speakers and youtube worked fine.

Modified by Kirck

danindub 0 solutions 4 answers

That worked a charm! THanks so much!

CbrMrk 0 solutions 2 answers

Helpful Reply

I had same problem. I found a workaround is turning off Dynamic Adaptive Streaming (DASH) with Youtube Center (https://addons.mozilla.org/en-us/firefox/addon/youtube-center/)