Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

In Firefox, I keep getting "Server not found" error - CONSTANTLY!

  • 10 replies
  • 64 have this problem
  • 14514 views
  • Last reply by cor-el

more options

Two days ago I started getting the "server not found" error, off and on, daily. It is happening on both my desktop iMac 10.7, and my Windows 7 laptop. I keep having to hit the "Try Again" butting, and sometimes, several times, before a web site will finally launch. The only two extensions I have on both, are the Adblock Plus and the Last Tab Close Button, both of which, have been installed on said computers for months and months and months.

I went in and changed a setting to the "auto detect proxy setting", hoping that would work, and it did not.

I have Firefox version 21 on both computers, and it seems the problem started shortly after this latest Firefox update, and at the SAME TIME on both computers.

I do not have virus protection on my iMac, nor on my Windows 7 laptop, at the moment, but I have run online software to check for anything, and no issues, so I believe, it is not that which is the issue.

The firewalls on both computers are working fine and no issues there either, I have not changed any firewall settings, on either computer. It couldn't be the firewall, in my opinion, because this annoying error message started happening on BOTH of my computers, at the same time; I work on my iMac in the morning, then switch to my laptop in the afternoon, and same issue continues on both, and started at the same time, on both.

Is there something broken in Firefox from this last update of the browser?

Does anyone have any suggestions as to why both computers are having this issue, at the same time?

I have not tried using I.E. yet on my laptop, I rarely have ever needed to use that browser, and I hate it, so I don't use it.

Any help or suggestions, would be appreciated.

All Replies (10)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

To Enable SafeMode

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.
  • Once you get the pop-up, just select "'Start in Safe Mode"

If it works in Safe Mode and in normal mode with all extensions (Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: "Firefox > Quit Firefox"; Linux: "Firefox/File > Quit")

more options

I followed those steps, but clearly some steps are missing. How do you "enable each extension one at a time"? The only choices I see in Safe Mode are "disable" and "remove."

And why is it that every other update to Firefox breaks Firefox? I've had to install add-ons just to be able to use it in Windows 8 with a touchpad.

Now that I think of it, it doesn't even matter any more. After years of Firefox loyalty (even after Firefox users have dropped to 28%), I'm off to download Google Chrome (up to 52%). I'll miss Firefox, but not the on-again, off-again performance.

Modified by kaetheb

more options

What you first do is starting Firefox in Safe mode.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

If you still have the problem in Safe Mode then the cause can be security software and you can try to boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

Still doesn't answer the question. HOW DO YOU ENABLE EACH EXTENSION ONE AT A TIME? I don't see any feature/button/checkbox for that.

more options
more options

You can enable and disable individual extension on the Firefox/Tools > Add-ons > Extensions page.

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

more options

I'm having this problem too. Running Ff 23.0.1 on OS X 10.8.4. Safe mode doesn't make any difference.

more options

You can try to reset (power off/on) the router.

You can try to disable IPv6.

more options

I'm still getting the same problem - though it appears to be happening cross-browser and -device.

more options

Try to set a different DNS server to see if that helps in case the currently set DNS server responds too slowly.