X
Tap here to go to the mobile version of the site.

Support Forum

About:home won't search google

Posted

My problem lies with the about:home page.

when I click home, it goes to the firefox start page. I can't search anything there.

When I type something in, and press "Search" (the blue button), it doesn't do anything. If I use the address bar or the search beside it, it works, but it won't work on the about:home.

Any suggestions? I've added the troubleshooting information as well using the plugin

My problem lies with the about:home page. when I click home, it goes to the firefox start page. I can't search anything there. When I type something in, and press "Search" (the blue button), it doesn't do anything. If I use the address bar or the search beside it, it works, but it won't work on the about:home. Any suggestions? I've added the troubleshooting information as well using the plugin

Chosen solution

None of those helped, as I've tried them all.

To fix the problem, I downloaded a program "ADWCleaner" which can be found here: http://download.cnet.com/AdwCleaner/3000-7786_4-75851221.html

To use it: Click the Search button and it will find all the toolbars etc and remove them, and all the unwanted registry entries.

The PC will reboot.

Then you can use the searchreset as said above, and reset everything back to normal!

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Unity Player 4.1.2f1
  • Google Talk Plugin Video Accelerator version:0.1.44.24
  • Version 3.17.0.12440
  • Conduit Plugin
  • np-mswmp
  • 2.1.3
  • Google Update
  • 5.1.20125.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • Pando Web Plugin
  • Facebook Video Calling Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Winamp Application Detector
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.4.1 for Mozilla browsers
  • ConnecTV AFP Plugin 0.4.0.3
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • QUAKE LIVE
  • DivX Plus Web Player version 2.2.0.52
  • 0.70.4
  • LiveVDO plug-in
  • Octoshape embedded video plugin
  • DivX VOD Helper Plug-in
  • Detector for the Onlive Game Client
  • wpidetector
  • 1.7
  • Nexon Game Controller
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Version 0.9.18, Copyright 2006-2009 Veetle Inchttp://www.veetle.com/
  • Version 0.9.18, copyright 2006-2010 Veetle Inchttp://www.veetle.com/
  • Contribute Firefox IBE Plugin DLL
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Amazon Browser Bar 3.0.20121002 (abb@amazon.com)
  • Better Battlelog (BBLog) 3.5.1 (jid1-qQSMEVsYTOjgYA@jetpack)
  • Better JTV 1.2.5 ({1fc895a6-2042-46ec-a61b-233165b4c218})
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • RuneScape 10.15.0.562 ({a8864317-e18b-4292-99d9-e6e65ab905d3})
  • selectivecookiedelete 4.1 (selectivecookiedelete@siju.mathew)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Web Developer 1.2.2 ({c45c406e-ab73-11d8-be73-000a95be3b12})
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Adobe Contribute Toolbar 6.0 ({01A8CA0A-4C96-465b-A49B-65C46FAD54F9}) (Inactive)
  • avast! WebRep 8.0.1483 (wrc@avast.com) (Inactive)
  • DivX Plus Web Player HTML5 <video> 2.1.2.145 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b}) (Inactive)
  • Skype Click to Call 6.4.0.11328 ({82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6739
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6800 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 1048576
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.sessionstore.enabled: True
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • browser.tabs.loadOnNewTab: 1
  • browser.urlbar.autocomplete.enabled: False
  • browser.urlbar.clickSelectsAll: False
  • browser.urlbar.maxRichResults: 1
  • dom.max_chrome_script_run_time: 0
  • dom.max_script_run_time: 0
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.internaluseonly.changed: False
  • font.size.variable.x-western: 18
  • gfx.direct3d.prefer_10_1: True
  • keyword.enabled: False
  • keyword.URL:
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1366230539
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf,video/flc
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.enable_ssl2: True
  • security.enable_tls: False
  • security.warn_viewing_mixed: False

Misc

  • User JS: Yes
  • Accessibility: No
ideato 893 solutions 6250 answers

Hello, go to about:config find/type (or copied -paste from here) the browser.startup.homepage_override.mstone , right-click on it and select reset, exit firefox and restart it.


otherwise,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Hello, go to [http://kb.mozillazine.org/about:config about:config] find/type (or copied -paste from here) the '''browser.startup.homepage_override.mstone''' , right-click on it and select reset, exit firefox and restart it. otherwise, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.

Question owner

In safemode, the same problem persists.

Both of them won't allow me to search.


Any other ideas?

In safemode, the same problem persists. Both of them won't allow me to search. Any other ideas?

Question owner

Since I can't edit my post, I'll need to write another.


I managed to do it yesterday, and since then I've not installed any plugins etc.

Since I can't edit my post, I'll need to write another. I managed to do it yesterday, and since then I've not installed any plugins etc.
ideato 893 solutions 6250 answers

Try to delete the chromeappsstore.sqlite file in the Firefox Profile Folder and then reset the browser.startup.homepage_override.mstone one more time.

thank you

Try to delete the '''chromeappsstore.sqlite''' file in the [http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox Profile Folder] and then reset the '''browser.startup.homepage_override.mstone''' one more time. thank you

Question owner

I don't have that file for some reason, but what I done was just went to help > troubleshoot information > and then just reset firefox and it works

I don't have that file for some reason, but what I done was just went to help > troubleshoot information > and then just reset firefox and it works
ideato 893 solutions 6250 answers
Ok, that is good news, see if you like : [http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Transferring data to a new profile - Firefox] [https://support.mozilla.org/en-US/kb/Recovering%20important%20data%20from%20an%20old%20profile#os=win7&browser=fx20 Recovering important data from an old profile] thanks

Question owner

After resetting firefox, the search worked.

But after installed an add-on, it removes the search thing again.

I installed both adblockplus, and Webdeveloper addon's (seperately) and both times it wouldn't let me use the search.

Any suggestions?

After resetting firefox, the search worked. But after installed an add-on, it removes the search thing again. I installed both adblockplus, and Webdeveloper addon's (seperately) and both times it wouldn't let me use the search. Any suggestions?

Question owner

Can anyone else help me here?

Can anyone else help me here?
cor-el
  • Top 10 Contributor
  • Moderator
17696 solutions 160119 answers

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart then see:

Try to use the SearchReset extension to reset some preferences to the default values. *https://addons.mozilla.org/firefox/addon/searchreset/ Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons). If you do not keep changes after a restart then see: *http://kb.mozillazine.org/Preferences_not_saved

Chosen Solution

None of those helped, as I've tried them all.

To fix the problem, I downloaded a program "ADWCleaner" which can be found here: http://download.cnet.com/AdwCleaner/3000-7786_4-75851221.html

To use it: Click the Search button and it will find all the toolbars etc and remove them, and all the unwanted registry entries.

The PC will reboot.

Then you can use the searchreset as said above, and reset everything back to normal!

None of those helped, as I've tried them all. To fix the problem, I downloaded a program "ADWCleaner" which can be found here: http://download.cnet.com/AdwCleaner/3000-7786_4-75851221.html To use it: Click the Search button and it will find all the toolbars etc and remove them, and all the unwanted registry entries. The PC will reboot. Then you can use the searchreset as said above, and reset everything back to normal!
luvmuzak 0 solutions 1 answers

I had this problem for a couple of days. I performed the suggested task by forbsie1888 and it worked.

       "help > troubleshoot information > and then just reset firefox and it works "

Thanks-a-bunch!!

I had this problem for a couple of days. I performed the suggested task by forbsie1888 and it worked. "help > troubleshoot information > and then just reset firefox and it works " Thanks-a-bunch!!
FirefoxGoogleFix 0 solutions 12 answers

Had this problem this morning and it is now fixed.

1. Open Firefox Browser

2. Type about:config in location bar and press ENTER A message will come up "This might void your warranty" Select, I'll be careful, I promise.

3. Search for configuration key, keyword.URL and select it

4. Right Click on the configuration key, keyword.URL and choose RESET from the shortcut menu.

Firefox automatically resets the value to:

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

5. If the RESET option is greyed out in the shortcut options, select NEW and type in the google search location

http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=

and press OK.

If you are not comfortable with having changed the default URL, you can now go back to the shortcut option and select RESET, which will do exactly the same thing.

Your Firefox Google Search function will now work again, and you are back in business.

.... Enjoy.

Cheryl

Had this problem this morning and it is now fixed. 1. Open Firefox Browser 2. Type about:config in location bar and press ENTER A message will come up "This might void your warranty" Select, I'll be careful, I promise. 3. Search for configuration key, keyword.URL and select it 4. Right Click on the configuration key, keyword.URL and choose RESET from the shortcut menu. Firefox automatically resets the value to: http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= 5. If the RESET option is greyed out in the shortcut options, select NEW and type in the google search location http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= and press OK. If you are not comfortable with having changed the default URL, you can now go back to the shortcut option and select RESET, which will do exactly the same thing. Your Firefox Google Search function will now work again, and you are back in business. .... Enjoy. Cheryl
FirefoxGoogleFix 0 solutions 12 answers

Hi,

Cheryl again.

The only thing is, this will reset to the default settings.

If you want Firefox not to remember your search history etc, you will need to go to the Firefox drop down menu, and select Options, Options, Privacy, and reselect the tracking / browsing history selections you require.

At least your Firefox Google Search is now working again, and it is a relatively easy fix.

Bye.

Hi, Cheryl again. The only thing is, this will reset to the default settings. If you want Firefox not to remember your search history etc, you will need to go to the Firefox drop down menu, and select Options, Options, Privacy, and reselect the tracking / browsing history selections you require. At least your Firefox Google Search is now working again, and it is a relatively easy fix. Bye.