X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Flash keeps crashing on Firefox.

Posted

Whenever I visit a page that contains even the smallest of Flash objects, Firefox stops responding briefly and then a dialogue pops up to say that Shockwave Flash has crashed. I have tried all of the fixes I have found on other questions: I have reset Firefox, run it in Safe Mode, disabled all extensions, reinstalled both Firefox and Flash, downgraded both Firefox and Flash and turned off Flash's "Protective Mode" etc. The problem only seems to have come about after I upgraded to Firefox 20 yesterday if that is of any help. Flash also crashes on IE and doesn't work properly on Chrome (YouTube does not play sound for example). I have run out of ideas and I was wondering if anyone has anything that I could try. Thanks in advance for any answers!

Chosen solution

Thanks for the reply, I'd already tried all of the methods on that page, in the end I just did a system restore, the problem is solved now

Read this answer in context 11

Additional System Details

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • npsitesafety
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Facebook Video Calling Plugin
  • NPWLPG

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-GB/

Extensions

  • Firebug 1.11.2 (firebug@software.joehewitt.com)
  • Rainbow 1.5.2 (rainbow@colors.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • AVG Security Toolbar 14.2.0.1 (avg@toolbar) (Inactive)
  • Java Console 6.0.35 ({CAFEEFAC-0016-0000-0035-ABCDEFFEDCBA}) (Inactive)
  • Java Console 6.0.37 ({CAFEEFAC-0016-0000-0037-ABCDEFFEDCBA}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6320 Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x9806
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 384
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 9-27-2012
  • driverDate2:
  • driverVersion: 9.2.0.0
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6320 Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://www.google.co.uk/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: True
  • extensions.lastAppVersion: 20.0.1
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: Yes

Chosen Solution

Thanks for the reply, I'd already tried all of the methods on that page, in the end I just did a system restore, the problem is solved now

Modified by supersheep97

maglev 0 solutions 1 answers

Hello I saw your post after getting numerous Warning: Unresponsive plugin refering to Shockwave Flash. This was an apple plugin so I scanned for updates and installed or updated my apple software on Windows 7, rebooted and fixed my problem

stsguy 0 solutions 1 answers

I have this all the time now too. I notice every time it crashes there are two instances of the Flash plugin running in Task manager. If I kill one, both stop. Then I restart Firefox (20.x on Win7) and once again it crashes.

nayzaw 0 solutions 3 answers

I have same problem while using Firefox. I am using Windows 8 and the problem was caused by Adobe Flash Player 11.7.700.202. Reinstalling of it didn't fix my problem but deleting of its folder did fix in my case. The location of its folder is C:\Windows\SysWOW64\Macromed\Flash. I did delete the whole Flash folder. You may need to have permission(ownership) to delete it. If you do and don't know how to get permission, you can study it from this link >>> http://www.addictivetips.com/windows-tips/take-ownership-of-files-folder-and-change-permissions-in-windows-8/ Don't forget to reboot the system after delete that folder. Good luck.

Modified by nayzaw

beewebmaster 0 solutions 1 answers

System restore is NOT a viable solution for this. My brother got the FBI virus and we REFORMATTED his system. On an OS just four hours old, we got this error June 1. New install of Win 7 SP1 with ALL Windows updates New install of FF21.0 New install of Shockwave plugin New install of Flash plugin. Absolutely NOTHING on this system could possibly have been more updated, and it happened repeatedly on YouTube and Pandora as soon as we visited them.

Modified by beewebmaster

PeterFarncombe 0 solutions 3 answers

I am at the point of abandoning Firefox, having wasted so much time and energy trying to resolve 'Flashpoint' issues with the solutions suggested by others (as above).

It all just seems to take forever leaving little energy, time, or will-power to accomplish anything constructive or creative. The nonsense goes on and on and on!

Grumble grumble grumble. Sorry - I seem to be using this forum to vent spleen more than anything! Don't let it bring you down too. Simply, I'd love it if Mozilla could simply hammer something out and provide a universal fix.

Cheers -

codyjohn 0 solutions 3 answers

same here, you should look at some of the other posts on the same subject and see what the moderators said. one even said that mozilla supports open source software so they werent going to attempt to fix the issue.. wonder how many more of these are out there. if they keep it up they will be forced to put out a update in a week because people will stop using their software alltogether.

nayzaw 0 solutions 3 answers

In my case of Windows 8, the procedure of deleting "Flash" folder under the location of "C:\Windows\SysWOW64\Macromed", then reboot and then reinstall "Adobe Flash Player" has really fixed the crushing problem.

Remark: : If you need permission to delete that "Flash" folder when you try to delete it, read this article to edit permission " http://www.addictivetips.com/windows-tips/take-ownership-of-files-folder-and-change-permissions-in-windows-8/ "

Modified by nayzaw

wolfeh1 0 solutions 1 answers

I am having the same issue when I go into my yahoo mail it crashes. I updated same my browser becomes unresponsive and then begins to pulse. I have to close yahoo mail. I haven't been able to see my mail from my computer now because of this. I just use my cell phone for it. But it also happens on other sites where they have flash the last few times firefox just crashed.