X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

My button to display add ons had disappeared from my nav bar. It was shapped like a puzzle piece. How can I get it back?

Posted

I am running Firefox 20.0.1 with Windows 7 on my laptop. The puzzle piece shaped button that displays my add ons has disappeared from my nav bar. How can I get it back? I've tried going through the "customize" button the on toolbar drop down menu but the icon isn't there. Also, some of the other add ons I've downloaded don't show up anywhere, even on my add-on bar.

Chosen solution

You can also right-click on the navigation toolbar and click "Add-on bar" from the context menu.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Shockwave Flash 11.6 r602
  • Facebook Desktop Plugin
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • 5.1.20125.0
  • Amazon MP3 Downloader Plugin 1.0.17
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 20.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
  • Support URL: http://support.mozilla.org/1/firefox/20.0.1/WINNT/en-US/

Extensions

  • Abduction! 3.0.18 ({b0e1b4a6-2c6f-4e99-94f2-8e625d7ae255})
  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • After the Deadline 1.51 (afterthedeadline@afterthedeadline.com)
  • Autofill Forms 0.9.9.0 (autofillForms@blueimp.net)
  • Boo.ly Shopping 3.001 (getbooly@boo.ly)
  • Bookmark Favicon Changer 1.74 (bookmarkfaviconchanger@sonthakit)
  • Customizable Shortcuts 0.5.11 (customizable-shortcuts@timtaubert.de)
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • Easy YouTube Video Downloader 6.8 ({c0c9a2c7-2e5c-4447-bc53-97718bc91e1b})
  • Ebay Button 1.4.0 (ebayHotStuff@wangtom.com)
  • Facebook Bookmarks 0.8 ({50fa8145-5954-4508-9124-e61bbc85c08b})
  • Facebook Messenger 1.8 ({249b4e45-4fb9-4f6b-9754-7c0c1e605d44})
  • FireGestures 1.6.22 (firegestures@xuldev.org)
  • Google Shortcuts 2.1.7.1 ({5C46D283-ABDE-4dce-B83C-08881401921C})
  • Multirow Bookmarks Toolbar Plus 1.2 ({4c7097f7-08f2-4ef2-9b9f-f95fa4cbb064})
  • Norton Toolbar 2013.3.4.3 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62})
  • Norton Vulnerability Protection 11.3.0.9 - 4 ({BBDA0591-3099-440a-AA10-41764D9DB4DB})
  • Puzzle 0.5.3 (puzzle@internauta1024a.pl)
  • Readability 2.4 ({6005d9b1-d115-485a-a92a-3f6453ca3fe2})
  • RSS Icon in url bar 1.3 (rssicon.vaka@gmail.com)
  • ScrapBook 1.5.6 ({53A03D43-5363-4669-8190-99061B2DEBA5})
  • Snap Links Plus 2.3.1 (snaplinks@snaplinks.mozdev.org)
  • Tab Scope 1.1.9 (tabscope@xuldev.org)
  • Thumbnail Zoom Plus 2.4 (thumbnailZoom@dadler.github.com)
  • Translate This! 2.0 (jid0-k75TfRGfOXPHfEZmJ9cKu5eCgLc@jetpack)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Yahoo! Mail Notifier 1.0.5 ({89f8dde0-010a-11da-8cd6-0800200c9a66})
  • YouTube Button 1.6 (youtubebutton@youtube.invalid)
  • Fastest Facebook 1.1 ({288479BE-1B9E-11E2-80EA-F3246188709B}) (Inactive)
  • Yahoo! Toolbar 2.4.8.20120412011105 ({635abd67-4fe9-1b23-4f01-e679fa7484c1}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.1.7601.17789
  • driverDate: 12-12-2012
  • driverDate2:
  • driverVersion: 9.17.10.2932
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: http://www.msn.com/
  • browser.startup.homepage_override.buildID: 20130409194949
  • browser.startup.homepage_override.mstone: 20.0.1
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0.1
  • font.name.serif.x-western: Corbel
  • font.size.variable.x-western: 18
  • general.autoScroll: False
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1364956120
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • social.enabled: False

Misc

  • User JS: No
  • Accessibility: No
finitarry 157 solutions 2175 answers

You were using MR Tech Toolkit, right? That extension provides an extensions button that looks like a green puzzle piece. Your extensions are not displayed properly?

Try this:
Exit Firefox and delete the following files from the profile:
extensions.ini
extensions.sqlite
compatibility.ini

Restart Firefox and see if the problem is fixed. If not, you might have to reinstall the problem extensions.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8005 answers

Key into the addressbar about:addons that will take you where you want.

Then bookmark it onto the bookmark toolbar by manually adding that address as a bookmark and ensure that the toolbar is displayed.

Question owner

I tried removing the files and it didn't work. I also went through the Help pages and did the safe restart as well as disabling all extensions without luck. Any other suggestions?

Question owner

It worked like a charm! I'm so happy to have my button back!!!

THANKS!

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8005 answers

Glad you sorted it out. Thanks for posting back.

walknet 0 solutions 1 answers

I also have Firefox 22 and cannot get my Add-on Toolbar to display and no longer have the puzzle icon. I tried the bookmark solution but only get a page that displays the add-ons. I am not using MR Tech Toolkit. I have downloaded and previously used DownloadHelper as a seperate add-on but now cannot find it after updating to Firefox 22.  ?????

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8005 answers

Bookmarking or using about:addons is merely a shortcut or alternative method of getting to the addons page.

The addons toolbar at the bottom edge of the page can be turned on and off from a menu or by keyboard shortcuts, but probably not many add-ons actually make use of it.

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8005 answers

I have just tried download helper. That shows up in my Tools menu. I have the menu toolbar displaying. If you need to display the menu toolbar temporarily try pressing the Alt key. Presumably the options also appear in the FirefoxButton in one of its menus.

finitarry 157 solutions 2175 answers

Chosen Solution

You can also right-click on the navigation toolbar and click "Add-on bar" from the context menu.

Question owner

There is an add-on called

about:add-ons Launcher 1.1

You will find it if you do search. Fixed me right up!

KJ