X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Opening New Windows and Shockwave Flash

Posted

Please see this thread: https://support.mozilla.org/en-US/questions/936004. The last two posts indicate that someone said that installing the latest version of SW Flash solved the problem and someone responded that it didn't work for them. Then the thread was closed.

I have had SW Flash disabled for a long time now because of the problem. So, I installed the latest version, enabled it, and the problem still exists (I also have FF v20).

I don't know what causes the problem. Mozilla has been completely mum on the issue, i.e., they don't appear to even acknowledge it is a bug (I don't care whether it's FF's problem or Adobe's or both - I experience it in FF).

For those of you who don't want to read the other thread, here's a summary of the problem. If you open a new window in FF, it sometimes (usually?) doesn't focus on the new window but opens it and switches the focus back to the first window. It happens on the right-click menu. It happens sometimes when you just click on a link. It even happens just by typing in a URL in the address window. The only thing that eliminates the problem is to disable SW Flash.

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • GEPlugin
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPWLPG
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

jscher2000
  • Top 10 Contributor
2388 solutions 21097 answers

Helpful Reply

Just for the record, threads are closed automatically after six months; it doesn't indicate any editorial judgment.

I have this same problem a couple times a day. With your reminder, I looked up the currently available information on it.

  • This issue affects Windows 7, but apparently not earlier versions
  • It is related to protected mode, which was introduced to the plugin for Firefox in Flash 11.3

Two workarounds are known:

  • Disable Flash's protected mode. I haven't done this because given the choice, I prefer the extra security. If you need to do it, see this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?
  • Keep some Flash content open in a tab somewhere at all times, because the problem only occurs when Flash is started up from a non-running state. For example, you might make Adobe's "About" page one of your home tabs. Another user reported keeping a YouTube window minimized.

Adobe is aware of this problem, but their bug page does not show it as having been fixed yet: Bug#3223393 - [Platform_Windows]Windows-7: Firefox Window loses focus every time Flash plugin processes are (re-)launched.

It is rather mysterious that a plugin could cause so many strange behaviors in Firefox. This could explain part of Mozilla's push toward moving away from binary plugins toward an HTML5/web app future. Nevertheless, Flash will be important for many years to come, so hopefully protected mode will get fully debugged.

Question owner

Thanks very much for your response. I was aware of the protection workaround, but not of your second bullet point. I've reenabled (and updated) Flash and have been keeping that Adobe page open, and it appears to work. Thus far, I haven't experienced the problem. I tend not to use tabs (multiple windows instead), so I think the easiest thing for me to do is make the Adobe page my home page (silly but practical), and then just open other Windows to do whatever I want, leaving it open until I shut down FF. (People are rather "frank" in that bug report, aren't they?)

jscher2000
  • Top 10 Contributor
2388 solutions 21097 answers

I hadn't noticed they closed the bug report without any plans to fix it. Depressing. No wonder the comments are less than complimentary.

Amiton 0 solutions 4 answers

I have a similar related problem. When using FF 20 in private browsing mode. When browsing any websites with flash content on it especially video's a separate flash window tab within Win 7 opens at the taskbar. So depending on the website I view, it can loads 20+ separate Flash window tabs!

I think I have narrowed the issue down to using FF within private browsing only. It never used to happen with previous versions of FF.

Modified by Amiton

jscher2000
  • Top 10 Contributor
2388 solutions 21097 answers

Hi Amiton, does it make any difference if you toggle this setting (on or off, whatever you don't currently have) or back again:

orange Firefox button (or Tools menu) > Options > Tabs > "Show tab previews in the Windows taskbar"

Firefox 21 is now available. In case this is a fixed bug, you might try updating. You can use:

Help > About Firefox > "Check for Updates" button

monalisa413 0 solutions 6 answers

I'm using FF 21 and that seems to be when the problem started for me (or at least I think it was). Of course, it also coincided with sending my laptop to the Dell repair depot, having the hard drive re-formatted/replaced and windows 7 reinstalled. Naturally, that didn't do a thing to fix my problem which was a weird screen occurrence I mentioned in another post. Then the in-home repair guy (which was a result of my squawking loud enough) replaced the motherboard and the screen. Problem is back again as of last night; repair tech was just here Mon. 5/20 :( My husband's 10 yr. old Dell laptop has never had a problem; mine lasted 6 months before trouble started. Hope FF can figure out a fix for this soon. Good luck to all! Lisa

jscher2000
  • Top 10 Contributor
2388 solutions 21097 answers

Hi monalisa413, it's possible that you were running Flash 10.3 before your reinstall instead of Flash 11.7. This issue started at some point in the 11 series.

Unfortunately, there is no obvious way for Firefox to solve this problem because plugins have permission to do a wide variety of things like, in this case, changing the active window. As far as I know, there's no way to block particular plugin capabilities.

monalisa413 0 solutions 6 answers

Except for disabling or enabling? Have never tried Chrome. Maybe this is a good time.

jscher2000
  • Top 10 Contributor
2388 solutions 21097 answers

Flash 10.3 is still available, but of the various versions, I'm not sure which is best for you: http://www.adobe.com/support/flashplayer/downloads.html#fp10.3

Amiton 0 solutions 4 answers

Hi,

No that setting didnt make any difference on or off Iam afraid. Iam using FF 21.0. But have tried a previous version of FF hence why I narrowed it down to enabling the private browsing feature.

I will also try it with Flash 10 now also.

cor-el
  • Top 10 Contributor
  • Moderator
10784 solutions 97065 answers

You can find the latest Flash player versions for Firefox on this page.