X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I turn off Private Browsing?

Posted

I turned on my notebook this morning to find Private Browsing on and Firefox reset to the default appearance. I can't find out how to turn this browsing feature off! Read the articles, looked at Community forum ... nada. Please help! I want my own Firefox back!

Chosen solution

Firefox 20 has made some major changes in this area. If you are automatically in private browsing mode, it could be related to your history setting.

purple Firefox button (or Tools menu) > Options > Privacy

If you have Firefox will "Never remember history" that could cause this problem. Change to "Use custom settings for history" and uncheck the box for "Always use private browsing mode".

Does that work? You might need to restart Firefox in order to escape, as I don't see a way to change a private window into a regular window.

Note that I'm just exploring this change right now, and there's a good chance more knowledgeable people will chime in!

Read this answer in context 19

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • Google Update
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • SiteAdvisor
  • McAfee MSC FF plugin DLL
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6635 answers

Click the Firefox button, then click stop private browsing How do I turn off Private Browsing?

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Chosen Solution

Firefox 20 has made some major changes in this area. If you are automatically in private browsing mode, it could be related to your history setting.

purple Firefox button (or Tools menu) > Options > Privacy

If you have Firefox will "Never remember history" that could cause this problem. Change to "Use custom settings for history" and uncheck the box for "Always use private browsing mode".

Does that work? You might need to restart Firefox in order to escape, as I don't see a way to change a private window into a regular window.

Note that I'm just exploring this change right now, and there's a good chance more knowledgeable people will chime in!

Modified by jscher2000

Question owner

Thanks jscher! Your answer was spot-on. I guess there was an automatic update and just as you said, it now defaults to private browsing if you have the "Never remember history" option turned on. When I unchecked the box and restarted Firefox, everything was back to normal. To test, I rechecked the "Never remember history box" and it went right back to Private Browsing mode and restarted itself. Good to know!

Question owner

Hi Tyler, I don't have that Firefox button so using Tools - Options was the only way to change the settings. Thanks - I appreciate your superfast response and attempt to help. :-)

seantheaussie 0 solutions 5 answers

Unfortunately I have tried turning remember history on and off with no success. Does anyone have any other ideas?

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Helpful Reply

Hi seantheaussie, are you saying that Firefox restarted in Private Browsing mode again, even with Custom settings and the box unchecked, or that Firefox failed to save your change, you looked in the dialog and it had switched back?

seantheaussie 0 solutions 5 answers

jscher2000 I have had custom history settings for as long as I can remember. After I updated to firefox 20 this morning things were different. It didn't show my home page, the back button doesn't work, it didn't automatically fill out my passwords, it didn't have addresses in the address bar, clicking on links in windows live mail doesn't properly open the page. I suspect that I am stuck in private browsing mode.

    Firefox restarts when I change between custom settings for history and never remember history but the look and functionality of firefox doesn't change.
jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi seantheaussie, you can tell if you're in private browsing mode by the menu: purple Firefox button, or a "mask" at the right end of the classic menu bar.

What do you get instead of your home page? Did you lose any bookmarks or your saved passwords?

If preference changes do not stick, there is a support article with some possible diagnoses for that: How to fix preferences that won't save. I wouldn't do a reset as the first step since I have the sense you have a little more patience for troubleshooting than the average person.

seantheaussie 0 solutions 5 answers

Thanks for your help jscher2000 I was wrong about the problem. I Tried disabling all my addons and the problem disappeared upon restart. So now I get to enjoy myself enabling them one by one to find the contrary bastard. Sean

seantheaussie 0 solutions 5 answers

Bugger! Tab mix plus is the problem. I LOVE that addon

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

You can ask advice at the Tab Mix Plus forum:

seantheaussie 0 solutions 5 answers

I am right in the middle of that thanks cor-el

Kpka 0 solutions 4 answers

Helpful Reply

I suggest until Firefox fixes this crap, people revert from Firefox 20 to Firefox 19. It worked for me.

Here's the link: https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/19.0.2/

It's really too bad they came out with a not-ready-for-prime-time version as a full release; but they did, so this seems like the only way out to me.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi Kpka, what is the problem you're having, and what are you hoping will change in a future version of Firefox? It's important to give us a complete description, or else nothing will go into the bug system for action.

Kpka 0 solutions 4 answers

When I opened Firefox and it auto-updated to version 20 (I've now turned auto-updates off), my CookieSwap, instead of displaying a profile name on the bottom toolbar, just said "CookieSwap."

When I clicked on it, it didn't allow me to use a profile: "Profiles are disabled when private browsing," it said. I hadn't had any of the private options enabled, outside of having a small number of sites from which I refused cookies.

I couldn't "turn off" the private browsing to the point that Cookie Swap would let me use the profiles...so I was stuck with the cookies from only one of the profiles on my computer, and had I not rolled back, would have lost a LOT of the long-term logins (and settings) that I had in my other profiles. I'm not even sure if the default ones would have worked, as I didn't try to browse without my profiles. It may have had me involuntarily in private browsing mode.

I hope that future versions will have a very easily found check-off that says "disable private browsing" to make sure this never happens, and it's tested with the CookieSwap add-on to make sure that the add-on knows it isn't private browsing and will let us access all our cookies. If we change our minds and want to use private browsing, then the "disable private browsing" check-off can always be unchecked.

Kpka 0 solutions 4 answers

Addendum: The fact that the changes broke Cookie Swap are documented by the add-on's creator here: http://cookieswap.tinefamily.com/ .

He says he'll have an update within a week, but I can't live without my profiles for a week. It seems to have broken a number of other add-ons as well, from posts I've seen about it.

I guess you could reasonably say that you'd never be able to update FF if you have to worry about never breaking an add-on...but I just wish new features that are likely to break some stuff could be disabled if the add-on is more important.

Also, the help page shouldn't try to talk people out of reverting to older versions, as often that will solve the problem.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi Kpka, thanks for the follow up.

The changes that allow users to use both regular windows and private browsing in the same session must be pretty major. Cookie Swap probably is not the only add-on affected; I wish all add-ons could be tested with the betas before release, but there are just so many... Anyway, the add-ons will have to change because there's no going back to the old style private browsing.

Also, the help page shouldn't try to talk people out of reverting to older versions, as often that will solve the problem.

Actually, I think this is a rare case. Most Firefox problems relate to personal settings. And after each release Mozilla publicly discloses all the fixed security vulnerabilities, which makes it dangerous to stick with older versions too long.

Kpka 0 solutions 4 answers

Anyway, the add-ons will have to change because there's no going back to the old style private browsing.

Well, the one that affects me will change according to its creator, but as you admitted, there are many add-ons affected, and some won't be updated. Some likely are as essential to their users as Cookie Swap is to me. I could live without the swapping if I had to, but I couldn't live with the immediate loss of the cookies.

So, there should be a way to "turn off" the new private browsing system for those people. If not, those people should not be discouraged from reverting. I know that until I'm sure I can update without losing any cookies, I'm sticking with 19.

I think anyone else with an add-on that has similar consequences if they can't access it should stick with 19 until and unless it's updated.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Maybe you can get a beta version of the Cookie Swap extension.

A Private window has its own cookies that are apart from a not Private window, so you can have one second set if that is enough.
If you close all PB windows then those cookies are removed and opening a new private window will once again give you a fresh set. Multiple PB windows that are open at the same time share cookies.

You would need multiple Firefox instances with their own profile to have more independent sessions.

zakinbristol 0 solutions 1 answers

What is the point of settings that do not stick? I tried changing to custom settings but it reverts back to never remember history. I get sick of software developers deciding what we should want instead of what we actually want. It is not just Mozilla doing this but it makes us move to other products.