X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why do I not stay logged in to online newspaper ( Huffington Post)

Posted

When I sign in to the Huffington Post, an online newspaper via Google Chrome browser, I stay logged in for hours, until I exit the site. When using Firefox, my default browser, I remain signed in only until I click on a story and I then notice that I'm not signed in anymore.

I have tried turning off the Add-Ons, starting in Safe Mode but that does not help. This has not happened in any other site but because I have only visited the site for the first time recently, I can say that I have not made any changes to firefox just before or after that.

I have the option of using Google Chrome but I don't really like it - that's why FF is the default browser. I also post comments on Forums and newspaper stories and find Lazarus very useful if I am interrupted when writing a piece. Now Lazarus works brilliantly in Firefox but does not seem to work in GC. Yet another reason to sort out this 'remaining signed in' problem.

Chosen solution

Great work on tracking down the missing link!

Third party cookies are all the cookies set by servers other than the one listed in the address bar. They are necessary on some sites, as you have found, but also are the means by which advertising servers track you.

In my opinion, a good balance is to allow all cookies, but set them to expire at the end of the current session by changing your custom history options to:

Keep until: "I close Firefox"

Then if there are sites you do NOT want to be logged out of between sessions, add those as exceptions either using the Exceptions button on that same tab, or about:permissions (note the colon between about and permissions), or the Page Info dialog (Tools menu or right-click).

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 5.1.20125.0
  • Windows Activation Technologies Plugin for Mozilla
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Plug-in for detecting Nero Kwik Media.
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Starting in safe mode
Turning Add-ons off

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3015 answers

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

feer56 Thanks for a really clear reponse and instruction:

My permament selection in Clear Recent History was the seletion of the first 5 items including cache and cookies. I have now selected Cache and Cookies only and cleared everything.

I closed an reopened the website, signed in, clicked on an article to view, checked if I was still signed in and once again I am no longer signed in. I really want to coment on some of the articles - it's a very interesting time politically - and I want my views heard.

I have to try some suggestions by Co-rel - some I have tried already without success. Why am I only having problems with this Huffington Post site?

Modified by Figgerty

Question owner

cor-el - Thanks for you interest.

I never use Private Browsing mode and have started Firefox in Safe mode without Add-ons a few times and gone into the HP website, signed in, and as soon as I click an article, I am no longer signed in. This does not happen on any other site - is that significant. Does anybody else use this site with FF?


PS. (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). when I do this, all it shows is Default 19.0.2

Modified by Figgerty

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder
jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

There was a problem with Yahoo and AOL logging people out every few minutes that turned out to be related to the "Auto-detect" proxy setting. So in case this is the same situation, could you check the following:

orange Firefox button (or Tools menu) > Options > Advanced > Network

Click the "Settings" button and choose either "No Proxy" or "Use System Settings" option, and OK the change.

Notice any difference?

Question owner

core-el - thanks for continuing to search for the solution.

I deleted cookies.splite, after exiting Firefox, went back into the HP site, logged in checked a few notifications for me and once again, I'm no longer signed in. Deleting the cookies file has not worked BUT I now know how to find the profile, so thank you for that.

Modified by Figgerty

Question owner

jscher2000 - this seemed as if it could be the solution as AOL is all over the HP Cookies policy and the HP is the only site this is happening on.

http://www.huffingtonpost.co.uk/

The setting 'use system proxy settings' was clicked, I changed it to 'no proxy' then restarted Firefox, opened th HP website, signed in and once again was signed out as soon as I clicked an article. So proxy settings don't seem to be the solution.

I may have no option but to use GC for this site as this is the only one I have a problem with.

Thanks for your help.

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

And just in case you are blocking one of the sites from setting cookies, or taking other typical actions, could you check on this "page":

about:permissions

Because the list is not alphabetical, it's easiest to use the search box, e.g., aol, then huff, etc.

Question owner

jscher2000 The 'about Permissions' link does not work but I checked my cookies permissions and they allow cookies and third party cookies. I may have added the third part ones just now when I clicked on it. I also checked the current cookies and there is a Huffington Post cookie installed but not an AOL one. I will try again with Third Party cookies allowed and see if that works and I will report back later.

Thank you for staying with my problem.

Update: I left Third Part Cookies ticked and went into the Huff Post once again. I signed in, clicked on various stories, I was still signed in, I continued reading other stories and was still signed in. I again went to cookies settings, unclicked third party cookies allowed, went back to Huff Post, signed in, clicked some articles and I was back to square one - automatically logged out of Huff Post.

From my viewpoint, this problem is due to third party cookies not allowed. If I allow third party cookies, then I remain signed into the site. Is there likely to be other problems if I keep the setting as 'third party cookies allowed'. I realise that one problem may be solved but am I creating others with this setting.

Modified by Figgerty

jscher2000
  • Top 10 Contributor
2344 solutions 20793 answers

Chosen Solution

Great work on tracking down the missing link!

Third party cookies are all the cookies set by servers other than the one listed in the address bar. They are necessary on some sites, as you have found, but also are the means by which advertising servers track you.

In my opinion, a good balance is to allow all cookies, but set them to expire at the end of the current session by changing your custom history options to:

Keep until: "I close Firefox"

Then if there are sites you do NOT want to be logged out of between sessions, add those as exceptions either using the Exceptions button on that same tab, or about:permissions (note the colon between about and permissions), or the Page Info dialog (Tools menu or right-click).

Question owner

jscher2000 - thanks for your help in resolving this.

It was just luck, I'm afraid, I think your mention of AOL was the key to solving this. I'm glad I can continue with Firefox. I only use GC on the rare occasion when I have multiple tabs open in Firefox and need to keep them open with the titles visible. That's why I used it to access the Huff Post and checked out and commented on some articles. When I had finished with the multiple tabs on Firefox, that was when I logged into the Huff Post via Firefox and realised there was a problem.

I will now sort out my cookies policy.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Note that you can allow third-party cookies for the current session by setting the network.cookie.thirdparty.sessionOnly pref to true on the about:config page.

Question owner

Well, whilst allowing Third Party Cookies enables me to remain signed into the Huff Post site - and this was my original aim, I am now getting lots of video advertising during my session. Annoying ads for car parts, car repairs etc. which spoils my enjoyment of the site. I am reading a serious news story - about the Budget - and some idiot is trying to sell me a product whilst I'm doing so. I have Adblock-plus enabled and this has blocked all annoying ads until now. I shall have to consider if accessing this site is worth the hassle.