X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

On certain websites, controls don't seem to work. When I click "next" nothing happens.

Posted

On at least two different sites so far..when I encounter a control such as "Next" nothing happens when I click on that control. On one site, Newsday.com, which is a newspaper, they display some top stories and below the frame there are arrows, ">" and "<" to see the next story or previous. These do not work at all. I noticed that the default setting for my extensions and add-ons has come Java programs disabled. Could this be the problem?

Chosen solution

Thanks for the info. Actually, I think I've found my problem. Under the Content tab/Java, I hit the advanced button and there are three options. One of them is to disable content menus. I unchecked it and it seems to be working now. Thanks again for responding.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • npsitesafety
  • np-mswmp
  • Conduit Plugin
  • LogMeIn, Inc. Remote Access Components
  • Citrix Online App Detector Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • AVG Security Toolbar 14.2.0.1 (avg@toolbar)
  • Freemake Video Converter Plugin 1.0.0 (fmconverter@gmail.com)
  • LogMeIn, Inc. Remote Access Plugin 1.0.0.1007 (LogMeInClient@logmein.com)
  • Microsoft .NET Framework Assistant 0.0.0 ({20a82645-c095-46ed-80e3-08825760534b})
  • MixiDJ 10.14.65.43 ({c0c2693d-2ee8-47b4-9df7-b67a0ee31988})
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • EPUBReader 1.4.2.1 ({5384767E-00D9-40E9-B72F-9CC39D655D6F}) (Inactive)
  • Java Quick Starter 1.0 (jqs@sun.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDescription2:
  • adapterDeviceID: 0x0000
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x0000
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedGfxCard']
  • directWriteEnabled: False
  • directWriteVersion: 0.0.0.0
  • driverDate:
  • driverDate2:
  • driverVersion:
  • driverVersion2:
  • info: {u'AzureContentBackend': u'none', u'AzureCanvasBackend': u'cairo', u'AzureFallbackCanvasBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedGfxCard']
  • numTotalWindows: 1
  • webglRendererMessage: [u'blockedGfxCard']
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.blockautorefresh: True
  • browser.cache.disk.capacity: 1048576
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size_cached_value: 860160
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • extensions.lastAppVersion: 19.0.2
  • network.cookie.prefsMigrated: True
  • network.http.proxy.version: 1.0
  • places.database.lastMaintenance: 1363090502
  • places.history.expiration.transient_current_max_pages: 40210
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 2
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Although the names are similar, the Java add-ons are not used by Firefox to interpret and run JavaScript. Firefox handles JavaScript directly; you do not need Java for that. You just need to make sure JavaScript is enabled here:

orange Firefox button (or Tools menu) > Options > Content


When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

Then try reloading the page. Does that help?


It's possible that one of your other add-ons could be interfering, although I don't know why it would. To test that theory, you can disable all your nonessential, unrecognized, or unwanted add-ons on the following pages:

orange Firefox button (or Tools menu) > Add-ons > Plugins category
orange Firefox button (or Tools menu) > Add-ons > Extensions category

After restarting Firefox, do you notice any difference?

Chosen Solution

Thanks for the info. Actually, I think I've found my problem. Under the Content tab/Java, I hit the advanced button and there are three options. One of them is to disable content menus. I unchecked it and it seems to be working now. Thanks again for responding.