X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Bank website tries to connect but nothing. Works on Chrome & IE.

Posted

I am having difficulty accessing my bank's website, www.usbank.com. When I try to go to it, FF just sits there "Waiting for www.usbank.com...", but never gets to it. I've tried the following:

- Uninstalled/reinstalled FF. - A different user profile on the computer. - Cleared cache, history, etc. - Restored FF to default. - Scanned for malware, viruses, etc. - Run FF in Safe Mode.

The site pops up fine if I use Chrome or IE and works fine with FF on my laptop, so I know this is a computer specific thing.

At this point, I'm at a loss on how to fix this. Any suggestions?

Chosen solution

Every now and then you see a website behave in a bizarre and inexplicable manner. In the case of usbank.com, it serves pages normally when your browser identifies itself as Firefox 18, but if it identifies itself as Firefox 19, it won't load.

Fortunately, there is a hack for that.

(1) Select and copy the following preference name to the clipboard (it's not supposed to be a link, the forum software does that):

general.useragent.override.usbank.com

(2) In a new tab or window, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(3) In the filter box, type override and pause while the list is filtered

(4) Make sure general.useragent.site_specific_overrides is set to its default value of true (or right-click and choose Reset if it is not).

(5) Right-click anywhere in the preference list area and choose

New > String

then paste the preference name you copied. Click OK and enter TEMP or asdf or any text as a temporary placeholder. You should see the preference added in bold. Leave about:config open and switch back to this tab.

(6) Select and copy the following useragent string to the clipboard (it's all one line):

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

(That's Firefox 18 on Windows 7 64-bit)

(7) In about:config, double-click general.useragent.override.usbank.com and paste to replace the temporary text with the new useragent string. Click OK, you're done here.

Now try loading a page on US Bank. Working?

Read this answer in context 17

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.6 r602
  • npsitesafety
  • iTunes Detector Plug-in
  • 5.1.20125.0
  • Nitro PDF plugin for Firefox and Chrome
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • NPWLPG
  • Pando Web Plugin
  • Windows Activation Technologies Plugin for Mozilla

Application

  • Firefox 19.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0.2/WINNT/en-US/

Extensions

  • AVG SafeGuard toolbar 14.2.0.1 (avg@toolbar)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 6800 Series
  • adapterDescription2:
  • adapterDeviceID: 0x6739
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 12-19-2012
  • driverDate2:
  • driverVersion: 9.12.0.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 6800 Series)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage_override.buildID: 20130307023931
  • browser.startup.homepage_override.mstone: 19.0.2
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0.2
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Chosen Solution

Every now and then you see a website behave in a bizarre and inexplicable manner. In the case of usbank.com, it serves pages normally when your browser identifies itself as Firefox 18, but if it identifies itself as Firefox 19, it won't load.

Fortunately, there is a hack for that.

(1) Select and copy the following preference name to the clipboard (it's not supposed to be a link, the forum software does that):

general.useragent.override.usbank.com

(2) In a new tab or window, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(3) In the filter box, type override and pause while the list is filtered

(4) Make sure general.useragent.site_specific_overrides is set to its default value of true (or right-click and choose Reset if it is not).

(5) Right-click anywhere in the preference list area and choose

New > String

then paste the preference name you copied. Click OK and enter TEMP or asdf or any text as a temporary placeholder. You should see the preference added in bold. Leave about:config open and switch back to this tab.

(6) Select and copy the following useragent string to the clipboard (it's all one line):

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

(That's Firefox 18 on Windows 7 64-bit)

(7) In about:config, double-click general.useragent.override.usbank.com and paste to replace the temporary text with the new useragent string. Click OK, you're done here.

Now try loading a page on US Bank. Working?

Modified by jscher2000

miletwizestone 0 solutions 1 answers

Helpful Reply

WOW that was a lot of work but, worth it. I don't even want to know what was going on behind the scenes. Just glad it works.

Question owner

That worked! Weird it works fine on my laptop running the same version of FF but in the end, I just needed it fixed.

THANK YOU for your help.

wzdmb 0 solutions 7 answers

A website can't block a particular user agent string of a browser. Microsoft.com is experiencing the same issue with a combination of Windows 7 and FF 19.0.2. This is a browser issue, not a website issue. What is FF going to do about this user agent string to fix this issue.

cor-el
  • Top 10 Contributor
  • Moderator
10749 solutions 96724 answers

Note that such a specific override pref also takes a regular expression for search and replace values, so this should work on all platforms to change xx.0 to 18.0

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi wzdmb, you wrote:

"A website can't block a particular user agent string of a browser."

Actually, websites sniff the useragent string for many reasons, such as choosing between a desktop and mobile style sheet, or working around browser incompatibilities, or simply showing different information. (The Google home page doesn't suggest trying Chrome if you're already running it, for example.)

"Microsoft.com is experiencing the same issue with a combination of Windows 7 and FF 19.0.2."

What URL has the problem on microsoft.com? The new content seems to load a bit more slowly than the old, but it does load for me.

wzdmb 0 solutions 7 answers

Hi jscher2000: Yes, websites do sniff useragent strings to deliver content for specific devices using CSS. You seem to suggest this particular website is targeting the useragent string for Firefox 19 vs. 18. While it is true "every now and then you see a website behave in a bizarre and inexplicable manner", it is apparent this happens when a particular useragent string is involved.

There are multiple reports on this forum of users having issues accessing other sites using WIndows7 and Firefox 19.0.2, including msdn.microsoft.com - see https://support.mozilla.org/en-US/questions/953475

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi wzdmb, I don't know exactly what US Bank's servers are doing or why. I can only confirm that changing a 9 to an 8 in two places avoids the problem. Since we knew Firefox 18 worked, I tried that first, and I didn't bother testing any other variations.

Regarding other sites, MSDN loads for me (Fx19.0.2 on Win7x64). I did have to refresh the page to get the banner to display. Firefox occasionally relies too heavily on the cache and can mismatch old and new files. When sites change, this can lead to load problems. As described in the MSDN thread, the first thing to try when you have a problem with a particular site is to bypass the cached files (Ctrl+Shift+r or full clearance) and clear the site's cookies.

Are you running into problems on a particular site?

malspie 0 solutions 5 answers

I have the same issue of my website not opening in firefox but working well with IE and chrome. I followed all your suggestions and tried to open the site, yet it just sits put with the board PROBLEM LOADING THE WEBSITE

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi malspie, how far can you get on the site? Can you log in but then nothing, or can you not load any pages?

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?

If that doesn't help, can you give the URL of the page that won't load?

malspie 0 solutions 5 answers

I tried your suggestions and am here again to say, the site refuses to open. when I click on the URL all I get the message is.. Connection has timed out, site taking too long to respond. I have following your suggestions for quite a long time. clearing cache, cookies and all that you have suggested is done. But the website does not open... I cannot open to any pages of the site as it does not load at all.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi malspie, is this a page that used to open normally in Firefox and it stopped working after an update or other software change? Can you provide the URL to the problem page?

malspie 0 solutions 5 answers

Hi, Yeah, it was opening normally in Firefox. I have no clue of what made it shut off. Here is the http://www.wdcare.in/wdcsite/.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi malspie, that site works for me (Fx21 on Win7 x64), except for the Facebook integration which lays out in a very peculiar way. I stay logged out of Facebook and if you stay logged in, you might test whether you can access the site when you are logged out of Facebook.

You can find some other suggestions in these articles:

And in case an add-on is interfering, could you also try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

malspie 0 solutions 5 answers

I have done it before, starting on safe mode in firefox, it did not work, tried again, still no luck. I have tried logging out of facebook too. Still not luck.. Can you suggest something else, which must be interfering with the opening of the website and how to clear that.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi malspie, the two articles I linked have a lot of suggestions.

malspie 0 solutions 5 answers

I have understood the problem ( I hope so), I found the mention of the website which does not open in the host file. I am not sure how it remove it from there, as I am worried of shutting of my windows forever.

jscher2000
  • Top 10 Contributor
2357 solutions 20872 answers

Hi malspie, by default, the Windows 7 hosts file (C:\Windows\System32\drivers\etc\hosts) contains only comments (lines starting with #). Unless you need to associate particular domains with particular IP addresses, you can delete the contents of the file.