Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I no longer can access my comcast infinity email account on firefox. I can browse the web. I prefer firefox but now have to use chrome to get my emails. help!

  • 3 replies
  • 1 has this problem
  • 4638 views
  • Last reply by cor-el

more options

One week ago I lost the ability to access my comcast email account using firefox(which is the only browser I have used in years). After entering my username and password it takes me to the the Infinity email preview page. From there I have always clicked on either the" view entire email"link or simply click on the "email" link and this would take me to my inbox. Now when I do that it returns me to the preview page. In fact, any link on the preview page, when clicked on, simply returns me to the preview page. I have deleted firefox from my computer and re-downloaded it and it doesn't change it. I have had a computer technician try everything he knows and can't make this work. Two of my friends use firefox and do not have this issue.I am now using chrome or internet explorer and both allow me access to my comcast email account. I really prefer firefox and would l;ike to get this resolved. Help! Tom Koenig tomkoenig4@comcast.net

Chosen solution

hello, have you tried to reset firefox yet?

Refresh Firefox - reset add-ons and settings

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

hello, have you tried to reset firefox yet?

Refresh Firefox - reset add-ons and settings

more options

That was the fix! Thanks for the quick reply. Great to be back on Firefox!

more options

Note that this can be caused by corrupted cookies.

If it happens again then try to clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"