X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Can't access Acrobat plugin for pdf files since Firefox 19 update

Posted

I don't like the new pdf viewer, which keeps throwing warnings and is not nearly as useable as the Acrobat plugin. I wanted to go back to the old Acrobat plugin installed with Adobe Reader XI. I have searched these forums and support files and have tried the following, none of which worked:

1. Tools/Options/Applications, change pdf setting to "use Adobe Reader." This enables Reader but not the plugin. There is no option listed for "Use Adobe Acrobat (in Firefox)." This option IS listed for other Acrobat file times such as Adobe Acrobat Forms Document.

2. Followed all of the suggestions on this web page, none of which worked: https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them

3. Reinstalled Reader XI. Didn't help.

4. Disabled Acrobat plugin in FF. Restarted. Re-enabled it. Restarted. Didn't help.

5. Changed pdfjs.disabled to true in about:config. Didn't make any difference.

I'm pretty annoyed that I'm having to waste all of this time to get back to something that worked well. Just another lame update of FF that shouldn't have happened. You guys are rolling out the updates too often without enough input from users. And whatever happened to the idea of opting in to optional features instead of just forcing them on us. Will be looking to use IE more, where the plugin is working just fine.

Chosen solution

I think I solved my own problem. I disabled the plugin for Nitro Pro 7 and now the Acrobat plugin is visible again for pdf files.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Citrix Online App Detector Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Google Update
  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • GEPlugin
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • iTunes Detector Plug-in
  • 5.1.10411.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Nitro PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, try this (while firefox is closed): http://helpx.adobe.com/acrobat/kb/cant-view-pdf-web.html#main-pars_heading_8

Question owner

Those instructions do not work for Reader XI since there is no option in Reader XI preference for Internet > Display PDF In Browser. Instead there is a link to this page, http://helpx.adobe.com/acrobat/using/display-pdf-browser-acrobat-xi.html, which I already tried. It did not help.

Chosen Solution

I think I solved my own problem. I disabled the plugin for Nitro Pro 7 and now the Acrobat plugin is visible again for pdf files.

andmalolo 0 solutions 1 answers

I have exactly the same problem. Solution from 'madperson' does not work, since as sthompson says, Acrobat XI has removed the internet preferences option to Display PDF in Browser. I do not have the Nitro Pro 7 plugin, whatever that is, so I still have no solution. Am really annoyed, have tried all the fixes mentioned on both mozilla and Adobe forums and support pages to no avail.

Helpful Reply

Andmalolo: The Nitro Pro plugin was apparently acting as a front end for Acrobat plugin. Nitro Pro is a pdf editing program that uses the Acrobat plugin from Reader for viewing pdf files. If you have other pdf software installed that have their own plugins these may be blocking the Acrobat plugin from appearing in the list of options for pdf files.

tbrinmoz 0 solutions 1 answers

This solution worked for me, but in my case it was part of Sony's MediaGo suite that had installed a plugin (MediaGo detector), which I did not realize had happened until I looked in Add-ons Manager. Once I disabled MediaGo detector, the PDF option again became available within Tools>Options>Applications.