X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of floating social media bar

Posted

Whenever I select text of a webpage a floating social media bar (share FB, G+, Twitter and Gmail) appears over the text - it's a distraction and I want rid of it. Any clues?

Chosen solution

I looked at the addons->extensions as recommended and found something called QuickShare. It leads you to a website for Snap.do (http://www.snapdoapp.com/) and that seems to be the culprit, for me at least. I removed it and the stupid social media bar has gone away. Not sure where it came from but I know where to look in case the problem recurs. Hope that helps.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • GEPlugin
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • DivX Plus Web Player version 2.2.2.14
  • Google Update
  • Spoon Plugin 3.33
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • Winamp Application Detector
  • 5.1.10411.0
  • Spoon Plugin 3.32
  • Spoon Plugin 3.31
  • Spoon Plugin 3.30
  • DivX VOD Helper Plug-in
  • Spoon Plugin 3.26
  • NPWLPG
  • Spoon Plugin 3.25
  • Spoon Plugin 3.23
  • Yahoo Application State Plugin version 1.0.0.7

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2042 solutions 8887 answers

hello, first of all please update your browser version, it is affected by dozens of known security vulnerabilities - firefox 19 is the current version: Update Firefox to the latest version

the issue you've described sounds like an addon that is providing this functionality - you can disable/remove them in firefox > addons > extensions.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

I notice that you have a lot of Spoon plugins showing in the system details list.

  1. Spoon Plugin 3.33
  2. Spoon Plugin 3.32
  3. Spoon Plugin 3.31
  4. Spoon Plugin 3.30
  5. Spoon Plugin 3.26
  6. Spoon Plugin 3.25
  7. Spoon Plugin 3.23

Do you really need all of them or only the latest with the highest number?

See "Manually uninstalling a plugin":

Question owner

Thanks for the replies.

Cor-el: You're right I allowed the spoon plugins to accumulate. Removing the old versions from the system didn't seem to kill anything.

Madperson: I updated my Firefox, then remembered why I hadn't done it before. It just crashes on startup. Nothing after version 12 works. I only returned to FF12 when the latest Chrome update screwed up, but it IS working now So, back to Chrome I go.

Thanks anyway.

Thanks for your consideration.

Cheers,

K.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You can use one of these to start Firefox in Safe mode:

  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox
  • Help > Restart with Add-ons Disabled

Try to disable hardware acceleration in Firefox.


If you have submitted crash reports then please post the IDs of one or more crash reports that have this format:

  • bp-xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx

You can find the IDs of the submitted crash reports on the about:crashes page.

  • You can open the about:crashes page via the location bar, like you open a website.

See:

Jeddak1865 1 solutions 1 answers

Chosen Solution

I looked at the addons->extensions as recommended and found something called QuickShare. It leads you to a website for Snap.do (http://www.snapdoapp.com/) and that seems to be the culprit, for me at least. I removed it and the stupid social media bar has gone away. Not sure where it came from but I know where to look in case the problem recurs. Hope that helps.

Question owner

Thanks Jeddak1865, It was indeed Snap.do's QuickShare that was responsible, as I discovered when it showed up in Internet Explorer. I assume removing QuickShare would also have fixed the nuisance in FF, but as I said FF is dead to me.

I thought I'd marked this as closed, but apparently not - apologies, but the QuickShare answer may help others.

Cheers,

K.

Modified by phaethon

GlobalRoamer 0 solutions 4 answers

August 2013

I have Firefox 23.0.1

I reviewed the posts above and checked my settings accordingly. I don't find any solutions that seem to apply.

I did "pin" a tab to my gmail account and one to my LinkedIn account right before the floating social networking bar started appearing on webpages.

I am a privacy nut. (Yea, I know the WWW is the wrong place for me.) But I try to do everything in my power to cut down exposure. If someone can put up a floating social networking menu bar on this page what else can they do?

I look at the html source code and clearly see the text that was added to set up the menu bar. The HTML also has a series of "if tests" to do things differently depending on the browser I use.

Any suggestions would be greatly appreciated.