X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Text is being distorted

Posted

More and more frequently, when I open a web page, the text is distorted. If I place another window over the text or highlight it, the distortion disappears. If I scroll the web page, the distortion scrolls with the text.

I've attached an image. Does anyone know what this is or how I can fix it?

Modified by Avallon

Chosen solution

Try to disable hardware acceleration in Firefox.

Try to update the graphic display driver.

Read this answer in context 45

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Next Generation Java Plug-in 10.15.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Google Update
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • NPWLPG

Application

  • Firefox 19.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
  • Support URL: http://support.mozilla.org/1/firefox/19.0/WINNT/en-US/

Extensions

  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Default Full Zoom Level 5.0 ({D9A7CBEC-DE1A-444f-A092-844461596C4D})
  • Download Statusbar 0.9.10 ({D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389})
  • Firebug 1.11.2 (firebug@software.joehewitt.com)
  • Reddit Enhancement Suite 4.1.2 (jid1-xUfzOsOFlzSOXg@jetpack)
  • Troubleshooter 1.0a (troubleshooter@mozilla.org)
  • Youtube High Definition 5.2 ({7b1bf0b6-a1b9-42b0-b75d-252036438bdc})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 4200
  • adapterDescription2:
  • adapterDeviceID: 0x9710
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 6-29-2011
  • driverDate2:
  • driverVersion: 8.862.3.0
  • driverVersion2:
  • info: {u'AzureContentBackend': u'direct2d', u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (ATI Radeon HD 4200 )
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://www.google.com/
  • browser.startup.homepage_override.buildID: 20130215130331
  • browser.startup.homepage_override.mstone: 19.0
  • browser.zoom.siteSpecific: False
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 19.0
  • gfx.direct3d.prefer_10_1: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1362074611
  • places.history.expiration.transient_current_max_pages: 100645
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.cpd.siteSettings: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Misc

  • User JS: No
  • Accessibility: No
miker00lz 0 solutions 1 answers

I have also been having this problem since FF 19. It's more than just distorted text, at times the entire webpage turns just black and alternates on and off during scrolling, or when minimizing/restoring. I have attached a screenshot of the window.

It still exists in the very latest Firefox (currently 21), and it's getting very old/annoying. It still hasn't been fixed?? It's crap like this that is why Mozilla is continually losing users to Chrome. I've been a FF-only user since version 1.x, beacuse it has the best UI by far... but I'm getting ready to switch myself if the huge amount of bugs in the software don't get fixed soon, or at least the more annoying ones.

It has nothing to do with my graphics driver. When the problem began in FF 19, I had a Geforce 9800 GT. Recently I upgraded the card to a Radeon HD 7790. The problem remains.

I shouldn't have to turn off hardware acceleration. That is *NOT* a f**king fix! That is a hacky workaround that reduces performance and raises CPU usage considerably. Users should not accept this as the "solution".

FIX YOUR CODE!!!!!!!! PLEASE!!!!!!!!! I even had to make this post from Internet Explorer. The page kept going black and then reappearing as I tried to type it in Firefox.

Most of the time, FF looks fine but something frequently keeps triggering this bug, and I'm not sure what it could be. It usually doesn't happen until I've been browsing in the same window for a couple of hours.

An even bigger problem that gets more severe with every version since as long as I can remember, is Firefox just straight-up crashes randomly. At this point, it happens several times a day. It's not my computer. It happens on every machine I run Firefox on. Most of them don't even have add-ons installed or anything like that.

Modified by miker00lz

Tony 0 solutions 4 answers

I solved this by setting, under TOOLS>OPTIONS>CONTENT>ADVANCED the 'Minimum Font Size' to NONE. This seems to have fixed it for me.

pkicker 0 solutions 17 answers

For those who may have missed this:

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

   http://kb.mozillazine.org/about:config 
   https://support.mozilla.org/kb/how-do-i-upgrade-my-graphics-drivers 
   Anti-Aliasing Tuner: https://addons.mozilla.org/firefox/addon/anti-aliasing-tuner/ Thanks, cor-el!!!
pmc11 0 solutions 1 answers

I've tried with HA enabled and once i changed gfx.direct2d.disabled it fixed the blur but then I noticed the corrupted text boxes as pkicker has shown. Changing gfx.content.azure.enabled didn't seem to do much to anything so I have gone to completely disabling HA to see if that finally fixes it. Still hoping for some news on a permanent fix rather than disabling a feature of FF.

Tony 0 solutions 4 answers

All I can do is re-iterate that I set 'minimum font size' to 'none' and left hardware acceleration 'on ' and the problem went away and hasn't come back....There's also been an FF update recently, but that may be unconnected.

pkicker 0 solutions 17 answers

I have also noticed since the last update when FF is first opened now there is a delay in my homepage opening as well. I am not sure if its a add-on issue or FF issue. I use No-script not sure if its an issue or not?

calmobi 0 solutions 2 answers

The problem occured when I updated the display adapter driver through windows update.

Running Windows 7 Home 64bit on HP Pavilion 6620f with ATI 4200 integrated video.

Reinstall the original display driver fixed the problem. Then to test this, I reinstalled the updated driver and the problem reappeared.

Reinstalling the original driver fixed the problem. It wasn't just Firefox. It appeared on any and all documents.

Modified by calmobi

calmobi 0 solutions 2 answers

The problem occured when I updated the display adapter driver through windows update.

Running Windows 7 Home 64bit on HP Pavilion 6620f with ATI 4200 integrated video.

Reinstall the original display driver fixed the problem. Then to test this, I reinstalled the updated driver and the problem reappeared.

Reinstalling the original driver fixed the problem. It wasn't just Firefox. It appeared on any and all documents.

mandLon 1 solutions 3 answers

I have distorted text too. The problem only affected Firefox. Turning off HA seems to have worked.

What bothers me is that there does not appear to be an "official" reply or acknowledgement that this issue exists. As far as I can see it does not appear in the list of known bugs so will probably not be addressed. So I presume I will have to accept having no HA as long as I use Firefox.

I've used Firefox for as long as I can remember and never even thought of trying a different browser. But this problem, and the lack of response from Firefox, encouraged me to look around. I've found a new browser and am happy with it. I guess I am suggesting that if you have this problem then 'talk with your feet.'

Firefox should have publicly acknowledged the problem, indicated whatever temporary fix(es) were possible and detailed how they were going to solve it. Look at how much time and frustration this could have saved their users. Look at the number of blogs here and elsewhere on this issue and the vast number of entries - all wasted time for the participants.

pkicker 0 solutions 17 answers

For those who may have missed this:

Try to set the gfx.content.azure.enabled pref to false or if this didn't help disable Direct2D by setting the gfx.direct2d.disabled pref to true on the about:config page and leave hardware acceleration otherwise enabled.

  http://kb.mozillazine.org/about:config 
  https://support.mozilla.org/kb/how-do-i-upgrade-my-graphics-drivers 
  Anti-Aliasing Tuner: https://addons.mozilla.org/firefox/addon/anti-aliasing-tuner/ Thanks, cor-el!!!
mandLon 1 solutions 3 answers

pkicker: Thanks for the link. I appreciate your concern. My concern is now more with the lack of official acknowledgement and lack of official support on this issue.

I'm horrified by the number of people and the number of sites on the web discussing this issue - it is even spread over several different forums here. It's sad to see this amount of time and energy wasted on something that could have been solved so simply by Firefox acknowledging that V19 had caused this problem and by them identifying it as a bug that will be addressed.

I've moved to a new browser and am so far happy with the level of support there.