X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Download manager doesn't have option to clear

Posted

Since update to 19 (this morning), the "clear list" button on the Download Manager is greyed out and doesn't work. Also under Privacy settings, I selected "Use custom settings for history" and cannot check button to "clear history when Firefox closes." Running on Windows 7.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • Google Update
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Unity Player 3.5.5f4
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1166 solutions 6649 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

That only helped with the problem I was having with selecting settings in the Privacy Settings menu - I still cannot clear files from the download manager.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy: Use custom settings for history
  • Deselect: [ ] "Always use private browsing mode"

Did you try to do this via the right-click context menu of an entry?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
phazonFox 0 solutions 1 answers

I've done everything suggested in this thread and I still have the same issue as Mia.

When I start a download it doesn't even show up in the download manager. If I start a second download however that one will show up, and any more I do after that will also show up.

Then the downloads that are currently in the download manager aren't registering at all. I cannot pause, nor delete them from the download manager.

Also, as Mia said the clear list button doesn't work.

I've done nothing different in my browsing behavior nor have I added any add ons or anything, it just up and stopped working....

Hope this gets resolved soon.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Can you remove a selected item in the download manager with Delete or Shift+Delete?

Try to delete the downloads.sqlite file in the Firefox profile folder

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

zoee 0 solutions 1 answers

I have this problem as well. I've tried: -Deleting downloads.sqlite -Starting in safe mode -Resetting Firefox -Creating a new profile

The first time I opened Firefox after resetting, the problem was resolved, but it immediately returned. When I created a new profile, it didn't work at all. I did not re-install any add-ons; the only thing I copied was my bookmarks. Running OS X 10.8.2.

I seem to be able to remove items from the Downloads window by right-clicking and selecting "Remove from list." The problem is with the "Clear List" button, which is greyed out.

kocheko 0 solutions 1 answers

same problem here since FF 19.... i dont know what they fix, but i know what they broke: the clear list button

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

We are aware of this issue and it should be fixed in FF 20. Can you give 20 a shot and let us know if that fixes it?