X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

google news buttons no longer working

Posted

I'm still having some problems with Google News that I asked about in an earlier question (https://support.mozilla.org/en-US/questions/947273)

In Firefox 18 and 19, the buttons to expand / contract the news items on http://news.google.com/ are no longer work (and some no longer show up).

A similar issue was (supposedly) fixed as referenced in this thread:

  http://forums.mozillazine.org/viewtopic.php?f=23&t=2576447

But the fix (and workarounds) do not seem to work.

The only way I've found to cure the problem is to change the cookie policy:

   network.cookie.lifetimePolicy set to 1

but that changes my settings to normal (always allow cookies until they expire) instead of to ask me every time.

Any ideas on how to make it work properly or to track down what else should be changed?

Additional System Details

Installed Plug-ins

  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Shockwave Flash 11.5 r502
  • NPWLPG
  • 5.1.10411.0
  • HD View 3.3.0.0 Mozilla plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Application Basics
Name
Firefox
Version
19.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.2.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Bookmark Duplicate Detector
1.0.7
true
{ba243cb0-b824-4a26-9418-73ee795d9b9d}
Bookmark Favicon Changer
1.73
true
bookmarkfaviconchanger@sonthakit
DictionarySearch
10.0.0
true
{a0faa0a4-f1a7-4098-9a74-21efc3a92372}
Feedback
1.2.2
true
testpilot@labs.mozilla.com
Firebug
1.11.1
true
firebug@software.joehewitt.com
HackTheWeb
1.3.20
true
hacktheweb@instantfox.com
IE Tab 2 (FF 3.6+)
4.12.22.2
true
{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}
Image Zoom
0.4.6
true
{1A2D0EC4-75F5-4c91-89C4-3656F6E44B68}
NoScript
2.6.4.4
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Sage++ (Higmmer's Edition)
2.3.17
true
sagepp@himag.blog26.fc2.com
SQLite Manager
0.7.7
true
SQLiteManager@mrinalkant.blogspot.com
Status-4-Evar
2012.07.08.17
true
status4evar@caligonstudios.com
Tab Mix Plus
0.4.0.4
true
{dc572301-7619-498c-a57d-39143191b318}
TinyURL Generator
2.6.1
true
tinyurl.addon@fast-chat.co.uk
User Agent Switcher
0.7.3
true
{e968fc70-8f95-4ab9-9e79-304de2a71ee1}
Web Developer
1.2.2
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
IDS_SS_NAME
IDS_SS_VERSION
false
{D19CA586-DD6C-4a0a-96F8-14644F340D60}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
51200
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.cache.disk.smart_size_cached_value
358400
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.google.com
browser.startup.homepage_override.buildID
20130206083616
browser.startup.homepage_override.mstone
19.0
browser.tabs.autoHide
true
browser.tabs.loadBookmarksInBackground
true
browser.tabs.loadDivertedInBackground
true
browser.tabs.onTop
false
browser.tabs.tabMinWidth
40
browser.tabs.warnOnClose
false
browser.urlbar.default.behavior
1
dom.disable_window_move_resize
true
dom.event.contextmenu.enabled
false
dom.ipc.plugins.enabled.npietab2.dll
true
dom.mozApps.used
true
extensions.lastAppVersion
19.0
general.autoScroll
false
gfx.direct3d.prefer_10_1
true
network.cookie.lifetimePolicy
1
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1360257371
places.history.expiration.transient_current_max_pages
104858
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
security.disable_button.openCertManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
AMD FirePro 2270
Adapter Drivers
aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM
512
Device ID
0x68f2
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
Driver Date
2-14-2012
Driver Version
8.950.0.0
GPU #2 Active
false
GPU Accelerated Windows
1/1 Direct3D 10
Vendor ID
0x1002
WebGL Renderer
Google Inc. -- ANGLE (AMD FirePro 2270)
AzureCanvasBackend
direct2d
AzureContentBackend
direct2d
AzureFallbackCanvasBackend
cairo
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Also make sure that you do not block cookies.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Helpful Reply

Cleared the cache: no effect.

Deleted all cookies: no effect.

Started in safe mode: no effect.

If cookies are set to "ask every time", it does not work. If cookies are set to "keep until they expire" it does not work.

Question owner

The problem still persists after I created a new profile with no add-ins via Help / Trouble Shooting / Reset Firefox.

The only setting I changed was changing the cookies retention policy to "Ask Me Every Time".

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Does it work if you switch to one of the other cookie settings (keep until: I close Firefox)?

The "Ask Me Every Time" cookie setting is known to sometimes set an exception for the wrong (sub) domain and thus can cause issues.

Helpful Reply

Setting it to "Keep Until I Close Firefox" works properly.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Then you will have to stay with that setting and having cookies behave as session cookies (Keep until: I close Firefox) isn't sufficient then you can look on the Add-ons site for a cookie manager extension.

Let all cookies expire when you close Firefox.

  • Tools > Options > Privacy > Cookies: "Keep until": "I close Firefox"

Make an Allow exception for the ones that you want to keep.

  • Tools > Options > Privacy > Cookies: "Exceptions"

You can inspect and modify the permissions for the domain in the current tab in "Tools > Page Info > Permissions" and on the about:permissions page.

Question owner

Is there a proper fix in the works?

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You can check which cookies are created and compare that to the ask me setting to see if you need to add some sub domains.

Question owner

Yes, but it's a royal pain to have to look at the cookies on every page I visit and manually check which cookies I want to allow or block instead of using the built in database that should remember all of that information.