Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable FireFox blocking of page changing on web sites which redirect to other pages on the same site?.

  • 5 replies
  • 5 have this problem
  • 485 views
  • Last reply by captkevin

more options

Going to a frequently used web site, like NewEgg for instance brings up the site home page usually with a menu or pics of featured items. OK so far.

 I want the detailed description of one of the displayed items and click on that item.
 Do I get where I want to go?  NO!  

I get a blank page with a message that Firefox won't let me go to the page selected unless I click the "Allow" button in the upper right on the screen. That is the most frustrating, irritating, and time wasting feature of Firefox and should be done away with! What makes it worse is that there is no clue as how to delete or turn off this feature that can be found on Firefox. The troubleshooting step shown below

All Replies (5)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

more options

Thanks to feer56 for responding to my call for help. I followed the suggested 'rules' to the letter, but guess what? When having to change page within that procedure, Firefox again blocked as usual.

So, I give up, and won't waste anymore time trying to fix the unfixable. Maybe the person(s) responsible for this feature will see the light and undo it, or better yet create a simple and direct method to 'fix' it on an individual basis. Ha ha ha! I can dream, can't I ?

more options

See:

  • Firefox/Tools > Options/Preferences > Advanced > General : Accessibility : [ ] "Warn me when web sites try to redirect or reload the page"

The setting in "Tools > Options > Advanced > General" is meant as an accessibility feature, as you can see by the label of that section, so that people with disabilities or people who use screen readers do not get confused and is not meant as a safety protection to stop redirecting.

See also:

more options

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is triggering the warning...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

otherwise it may be the firefox pop-up blocker in action, you can allow exceptions for it: Pop-up blocker settings, exceptions and troubleshooting

more options

This solution worked on my Mac OS. To navigate there, click the Firefox drop down menu, Preferences/Advanced/General, under Accessibility make sure the 'Warn me when websites try to redirect or reload the page' is not checked.