Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since I installed Firefox, I get CONSTANT "certificate expired" security alerts when I go to most any web site, even ones I regularly visit. HELP!!!

  • 2 replies
  • 2 have this problem
  • 1 view
  • Last reply by finn54

more options

Please see my original question above. Since I switched from IE to Firefox, I cannot even view medical claims on Aetna. Even YOUR help site, had an expired certificate notice come up and I had to click thru the 'override' tabs to continue. I am getting 'Security Alerts' for expired security certificates on almost every single web site I go to. I just keep clicking "yes" when asked do you want to continue. This is horrible. I tried to use a page I found that tells me to go to Tools, then Options, then Web Features to "Allow sites", but there is NO "web feature" choice to click.

Chosen solution

Just to be sure, check your system calender date as it could be not current and some earlier year or such.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Just to be sure, check your system calender date as it could be not current and some earlier year or such.

more options

James, your simple solution (ck system calendar date) fixed it ~ mine for some reason was set January 2007. Thank you so much! My hero :~))