X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Drop Down menus on Kickstarter.com don't work anymore

Posted

I've been using Aurora for a while now, with no issues with this site, I think it even worked fine on an early version of 20.0a2, but a recent update has caused an annoying issue on kickstarter.com. Usually if you click on one of the three icons in the top right corner a drop down menu appears, however now when you click on them they take you to your profile page or your inbox, [whatever the icon corresponds to].

It works with IE, and on my iPhone, but not on Aurora. Not a major issue just an annoyance, as there are some sections you can only access on the drop down menu.

Cheers

Dave

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.13.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • 5.1.10411.0
  • Version 2.8.7.6830
  • Google Talk Plugin Video Accelerator version:0.1.44.15
  • Google Update
  • np-mswmp
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20130204 Firefox/20.0

More Information

flang 0 solutions 4 answers

The problem is even worse than described by the OP. Most Kickstarter pages have a FAQ at the bottom that displays the answers to common questions when you click on them. But now because of the disabled drop-down menus, the answers to these questions cannot be read at all.

In addition, using multiple Kickstarter tabs now is all screwy. For example, let's say I am browsing the various projects and open up three of them in three new tabs (let's call them projects A, B, and C). Then, I navigate to project A (the first new tab I opened), find that it interests me, and select the "Remind Me" button (the star icon located just below the project's main video). Before Firefox 19.0.2, clicking that button would bring up a small pop-up message that reads "Thanks. We'll remind you by email." Now, though, clicking the button causes the page for Project C (the third and final tab I opened) to load in the current tab.

  • Edit: I am actually using 19.0.2 unlike the OP. But the problem is still there.

Modified by flang

Question owner

Hy mate, the Aurora team fixed the issue a while ago, it's working fine in 21 alpha. Have you tried installing the Beta?

flang 0 solutions 4 answers

Helpful Reply

@ditroia

I've just installed the 20b6 beta version of Firefox and the problem is still there. Nothing's improved at all.

EDIT: I've found that the problem is caused by Ghostery and not Firefox itself. I have raised the issue in that community to find a solution.

Modified by flang

Question owner

Still working in Aurora.