X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I change my hijacked defalt search options back to normal?

Posted

Within the last few days I noticed that my default search engine, both on the Firefox homepage and on the search bar, had been changed to Yahoo. I changed both back only to find that the settings reset themselves whenever the browser is closed.

Since then I've browsed scores of help threads on this and other forums looking for a solution. Nothing works. I've checked for yahoo software and AVG, I've booted in safe mode, I've disabled suspect plugins and add-ons, I've deleted the unwanted search options in the browser and on the hard drive. No dice.

I want to know how to change my default search engine back to google.

Chosen solution

For those having similar problems, it appears that the culprit was a program called SearchSettings.exe that was running in the background on my computer. The program is often part of a search bar package. In the case of my machine, though, the search bar is not installed and thus doesn't show up in my browser add ons or my Add/Remove programs menu.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Foxit Reader Plug-In For Firefox and Netscape
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Picasa plugin
  • 4.1.10329.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Question owner

Thanks, but I already ran that (one of the many pieces of advice given to others I followed). It didn't have any impact.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Helpful Reply

Try deleting prefs.js and user.js http://kb.mozillazine.org/Prefs.js_file

Question owner

Thanks, I've just taken your advice. Unfortunately it didn't help though. I deleted the files, restarted the browser, changed the default browser (deleting all other than Google), and then restarted again. On each restart Yahoo was still the default.

Odd side not: whatever is doing this restores the other search options too, not just Yahoo. Ebay, Bing, etc. were deleted and they're back too.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Did you install official Firefox or Firefox with Yahoo?

Question owner

I installed Firefox with Yahoo. Hated its guts and uninstalled it. Then installed ordinary Firefox (which was working without this issue for some time).

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

  • browser.search.defaultenginename

Try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.

Question owner

Thank you, Cor-el. I had already taken both of those steps but I tried them again at your suggestion. I found and deleted the prefs.js file. I could find no user.js file this time (I did before and had deleted it). The deletion didn't alter anything.

I did make sure that my toolbar customizations are being saved (they are) so I take it that the problem isn't that preferences aren't being saved at all.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Did you check for extensions that may be changing the search engine setting?


Check for the presence of a mozilla.cfg file in the Firefox program folder to initialize some prefs.

This also involves the presence of a .js (JScript) file, probably in "defaults\pref" folder, that specifies to read this mozilla.cfg file.

If you have .js files apart from the channel-prefs.js file, that sets app.update.channel, in the defaultspref folder then open this file in an editor like Notepad and please post its content. Also please post the content of the mozilla.cfg file.

If you have this mozilla.cfg file then best is to do a clean reinstall of Firefox and remove the Firefox program folder.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

Yes, I have checked my extensions. I disabled anything I wasn't entirely sure of and it didn't help.

I don't appear to have a mozilla.cfg file.

I may have found a solution though. On another forum is was recommended that I use the profile manager and see if a new profile has this problem. It turns out that a new profile does not. Thus, I'll probably just switch profiles.

Chosen Solution

For those having similar problems, it appears that the culprit was a program called SearchSettings.exe that was running in the background on my computer. The program is often part of a search bar package. In the case of my machine, though, the search bar is not installed and thus doesn't show up in my browser add ons or my Add/Remove programs menu.