X
Tap here to go to the mobile version of the site.

Support Forum

Firefox keeps changing my search engine from google to yahoo. Why is this happening and how do I stop this?

Posted

Firefox 10.0 keeps changing my search engine back to yahoo from google. I've tried eliminating yahoo from the search engines but it keeps coming back. Why is this happening and how do I stop it? I want the google search engine as my default search engine. Period

Firefox 10.0 keeps changing my search engine back to yahoo from google. I've tried eliminating yahoo from the search engines but it keeps coming back. Why is this happening and how do I stop it? I want the google search engine as my default search engine. Period

Modified by Noah_SUMO

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.1 r102
  • iTunes Detector Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • npmnqmp 989898989877
  • DivX Web Player version 1.4.3.4
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Adobe Acrobat Plug-In Version 7.00 for Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0

More Information

Swarnava Sengupta 482 solutions 3210 answers

Hi,

You should take a look at the Knowledge Base article Use the Search bar in Firefox and manage search engines. I'd also be sure that you remove that Obit addon completely and the Yahoo! toolbar if it's installed as well.

If that doesn't work you should look at the article Preferences not saved.


Hopefully this helps!

Hi, You should take a look at the Knowledge Base article [[Search bar]]. I'd also be sure that you remove that Obit addon completely and the Yahoo! toolbar if it's installed as well. If that doesn't work you should look at the article [[Preferences not saved]]. Hopefully this helps!

Modified by Swarnava Sengupta

wombledung 0 solutions 10 answers

Helpful Reply

lesson number one DONT use yahoo search! in the form you have it ( i dont know if yahoo are themselves responsible for this) it appears as if hijacking your default settings .

try this

On Windows:


   Go to C:\Program Files\Mozilla Firefox\searchplugins
   Each search engine has two files; a .src and either a .png or a .gif file. All you have to do is delete the two files for the search engine you wish to remove (for example google.src and google.gif) and restart Firefox.
lesson number one DONT use yahoo search! in the form you have it ( i dont know if yahoo are themselves responsible for this) it appears as if hijacking your default settings . try this On Windows: Go to C:\Program Files\Mozilla Firefox\searchplugins Each search engine has two files; a .src and either a .png or a .gif file. All you have to do is delete the two files for the search engine you wish to remove (for example google.src and google.gif) and restart Firefox.
wombledung 0 solutions 10 answers

except of course, you are looking for any yahoo browser files (.src and/or .png and/or .gif

except of course, you are looking for any yahoo browser files (.src and/or .png and/or .gif
josiebops 0 solutions 3 answers

Helpful Reply

I did what you said but when I got to searchplugins the only extension I found was .xml. I did see yahoo.xml and deleted it. I'll have to restart Firefox to see if that did anything. And you must be right. My browser was recently hijacked and I only recently got it back to where I want it and then Yahoo started showing up. Would uninstalling Firefox and reinstalling do any good?

I did what you said but when I got to searchplugins the only extension I found was .xml. I did see yahoo.xml and deleted it. I'll have to restart Firefox to see if that did anything. And you must be right. My browser was recently hijacked and I only recently got it back to where I want it and then Yahoo started showing up. Would uninstalling Firefox and reinstalling do any good?
cor-el
  • Top 10 Contributor
  • Moderator
12898 solutions 118329 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).


You can try this extension:

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.org/kb/Safe+Mode ---- *https://support.mozilla.org/kb/Search+bar You can try this extension: *https://addons.mozilla.org/firefox/addon/searchreset/