X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

favorites in Hebrew are displayed in jumbled letters

Posted

I have imported favorites, but those not in English but in Hebrew letters are displayed as stars with a question mark. Using and changing kode letters under view had no affect. Hebrew appears in web display alright

Chosen solution

I am aware of some problems that occur while importing bookmarks in the past, but these issues should not impact new bookmarks created directly from inside Firefox and I am not sure if this could be a font issue as Hebrew displayed right on your bookmark folders and the application user interface.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.56 Safari/537.17

More Information

Question owner

Here is an attached file showing what appears on the windows 7

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Does this also happen in the Bookmarks Manager (Library)?

You can do a font test to see if you can identify corrupted font(s).

Tomer Cohen 4 solutions 20 answers

How have you imported your bookmarks? Have you used the automated process when running Firefox for the first time, or manually imported your bookmarks.html file?

Question owner

I think I have done it automatically. But even now entering a new site in Hebrew, the same occurs. Even the search results in "ask" appear the same with question marks

Question owner

cheking the fonts appear only in English, and I am unable to see how they function in Hebrew letters

Tomer Cohen 4 solutions 20 answers

Chosen Solution

I am aware of some problems that occur while importing bookmarks in the past, but these issues should not impact new bookmarks created directly from inside Firefox and I am not sure if this could be a font issue as Hebrew displayed right on your bookmark folders and the application user interface.

Question owner

Strange is the fact that in explorer and in chrome the bookmarks fuction propperly. Using the code menu did not help in fire fox. I think the problem has appeared only recently after updating firefox version.

Question owner

Now I have noticed that even the Emails I recieve I witness the the name of send in Hebrew appears in jumbled letters. vanham

Tomer Cohen 4 solutions 20 answers

Sounds like something is broken in your fonts library, and I suspect it is the famous Arial Black font problem we are facing from time to time on our local support site. Can you read well Hebrew content in the browser, such as this short snippet? — האם הטקסט הזה מופיע אצלך כראוי?‏

We had an issue with importing IE bookmarks containing non-Latin characters back when operating systems such as Windows 98 were relevant, but I don't think this is the case with you.

Can you please start the browser in Safe Mode in order to make sure the problem doesn't occur because an extension or a theme that might be installed on your browser?

Modified by Tomer Cohen

Question owner

I see the Hebrew letters content very well in the Email you had send me. Mind you, I see also the on the tool bar all the Hebrew letters propperly. The problem is only on the email ans also in the search results give in ask search. אני נצרף לך כיתוב בעברית להוכיח שגם זה מעובר כראוי. רק שיהיה לך ברור שהבעיה אינה חוסר שליטה על כתיבה בעברית. באשר להצעתך להתחיל ב- Safe mode- אין אני יודע להפעילו במתכוון אלא לאחר שהופיע בקריסה של המחשב.

Tomer Cohen 4 solutions 20 answers

Please try to keep this discussion in English, as most people here don't Have decent Hebrew knowledge (although you can post questions in Hebrew in the Hebrew community site ☺).


Firefox Safe Mode has nothing to do with the Operating System recovery mode you can access while booting your computer. In order to access Firefox' Safe Mode you have to keep down the Shift key while starting the browser or restart it with addons disabled from the menu item in the browser Help menu.

YanivHaliwa 0 solutions 1 answers

Helpful Reply

http://support.mozilla.org/he/questions/774829

same case [i think]. and there someone say it is a font problem. its depend on encoding file when exporting.

Modified by YanivHaliwa

Question owner

I even watched if UTF-8 is marked, tried all other Hebrew fonts and even used automatic display, but all in vein. Therefore I discontinued with firefox. I will try working with "safe Mode" by pressing the shift button while startin firefox browser.

Question owner

I tried safe mode in launching mozilla (firefox) and the situation of having Jumbled Hebrew letters continued. In all other browsers- explorer and chrome things are fine. Mozilla does not function with android 4.2 as well.

Tomer Cohen 4 solutions 20 answers

Are you sure that new bookmarks created directly in Firefox also having this problem?

Question owner

Hello Tomer Cohen from Haifa Yes, I prformed adding a new bookmark and the same occured. In the internet and before saving the new bookmark and before dessignating the required path- it appeared clearly in Hebew letters. Searching the new bookmark it appearef again in jumbled Hebrew. Thanks for your efford till now.