X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

wont search from start page

Posted

I have the newest version of firefox and the first problem i started getting was connection timed out server not found from searching in the start page. If i searched in the web address page it would pull up. I restarted firefox from the help tab and the first time i search from the start page it works than if i close everything out and start again it does nothing, but if i search in the web address it pulls up.

Additional System Details

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.5 r502
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.01
  • RealNetworks(tm) RealDownloader Chrome Background Extension Plug-In
  • RealNetworks(tm) RealDownloader PepperFlashVideoShim Plug-In
  • RealNetworks(tm) RealDownloader HTML5VideoShim Plug-In
  • RealDownloader Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • 4.1.10329.0
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 1.9.0009.1
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Yeah I tried that and it comes up and i can search once than when i close out firfox and start a new window it does nothing and wont search in the search window but if i open a new tab in that start page it will look for things in the web address but nothing in the search

timothyhiland 0 solutions 2 answers

i have this problen also and cant get help from mozilla did you have you had any luck

Question owner

Not yet

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.


Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

Has anyone tried the steps from cor-el? We are investigating this issue and want to know if that helps. Please give it a shot and let us know!

guiltyxbyxdesign 0 solutions 5 answers

nothing i have tried has worked... the reset, the addon, and the browser.search.defaultenginename is set to its default.

i have also uninstalled and reinstalled to no avail

Modified by guiltyxbyxdesign

timothyhiland 0 solutions 2 answers

im a beginner

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Did you try a clean reinstall and removed the Firefox program folder?

  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

Did you try a new profile?

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

If you keep having problems then also create a new profile.


guiltyxbyxdesign 0 solutions 5 answers

Yes i made a backup of my bookmarks, did an uninstall with the Firefox uninstaller and deleted personal info because i have a backup of my accounts and passwords and had only changed a few settings in Firefox, then deleted the Mozilla folder in in program files (x86). downloaded a new installer for Firefox using ie. installed custom no desktop icon but one on the tool bar with maintenance tools set as default browser and without importing anything from ie or from my backups of my bookmarks or passwords.

First i searched for "Facebook" it worked, i closed my browser Second search was "misfile" it also worked so i closed my browser The third time i opened my browser click the search bar click 'Facebook' from the history drop down and hit enter and nothing happens click search and nothing happens i try the same with "misfile" again nothing. I type in yahoo click search and nothing, hit enter and nothing.


I do notice on the failed attempts that the little advert from Mozilla is not under the search bar... you know the one, gives helpful hints or tells you of upcoming features or fundraisers.

Again this is on a clean install with all personal info deleted, Mozilla folder deleted from Program files (x86), nothing imported, and no settings changed.

pcoombes 0 solutions 4 answers

I too have gone through each step suggested here including creating a new profile. Even with a blank new profile after opening and closing Firefox the Search on the page stop working. It simply does not respond.

the search bar continues to work.

pcoombes 0 solutions 4 answers

I was going to post the image of how the page looks different but don't know how to post images here.

When it works on the home page it reads Google with the blank space followed by the Search button in black and underneath is a short thing telling the user they can customize Firefox

When it resets and is not working Google disappears and so does the description below. The search box now has a blue outline and the Search button is blue

Don't know if that helps.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

  • browser.search.defaultenginename
guiltyxbyxdesign 0 solutions 5 answers

browser.search.defaultenginename status=default type=string value=Google

Still unable to search.


Edit: Went back to about:config to double check browser.search.defaultenginename this time status=user set and value was blank... i changed it back to default and closed firefox. it is now working and i have now opened and closed it multiple time just to check, but i don't know how or why that would have been changed when i had just checked it moments before.

Have ran both MalwareBytes and AVG both set to full scan and both came back clean.

Modified by guiltyxbyxdesign

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Do you have a firewall, content filter, anti-virus, etc. that could be blocking? at this point this is some third-party program blocking firefox from searching.

guiltyxbyxdesign 0 solutions 5 answers

AVG firewall is the only thing active and i have never had a problem like this until just recently. I do believe the problem has been fixed now and i thank you all for the help and i will recheck AVG to make sure it is not blocking Firefox. Thank you again for the help.

Question owner

I still have not found a fix to my problem and am still looking for one. It still doesn't search from the start page it just sits idle when you enter a search. I have been reading some info on this and am a little confused on how some of these issues have been resolved. If someone could help me on how they fixed their problem step by step i am willing to try it and see if it works and would be very greatful for the hospitality. thanx

guiltyxbyxdesign 0 solutions 5 answers

in a new tab in the address bar type it about:config hit enter

click ill be careful i promise on the warning that pops up

search for browser.search.defaultenginename

right click browser.search.defaultenginename and choose reset

close browser and reopen to see if it has fixed the problem


This is what worked for me in the end.

pcoombes 0 solutions 4 answers

I tried resetting browser.search.defaultenginename in about:config but it still does not work for me. (In fact I even reset all items that had been changed.)

I'm guessing it is a third party software problem. I run Norton 360 which can be a problem every so often.

If anyone has other ideas I'll take you up on it... thank you

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Check for the presence of a mozilla.cfg file in the Firefox program folder to initialize some prefs.

This also involves the presence of a .js (JScript) file, probably in "defaults\pref" folder, that specifies to read this mozilla.cfg file.

If you have .js files apart from the channel-prefs.js file, that sets app.update.channel, in the defaultspref folder then open this file in an editor like Notepad and please post its content.
Also please post the content of the mozilla.cfg file.

If you have this mozilla.cfg file then best is to do a clean reinstall of Firefox and remove the Firefox program folder.