X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox properly goes to my set home pages; how do I get it to use my preferred SEARCH ENGINE (without having to be able to PROGRAM)?

Posted

I want to choose the search engine; Firefox goes to Google. My home pages are properly set. The only solution offered to this question earlier would have you go to Web Developer and instantly was WAY over my head. How can an ordinary person change this? Thank you.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • iTunes Detector Plug-in
  • 5.1.10411.0
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2050 solutions 8916 answers

hello msprof, you can set a custom homepage by going to firefox > options > general.

How to set the home page

Question owner

I have easily set my home page(s) -- that isn't the problem. The problem is, how do you set a default SEARCH ENGINE? (without being a programmer) I have Bing set on the right-side search box. The problem is the left-hand-side box -- that's where you type in a url, but also works as a search box, so if you type something there that isn't recognized as a url the browser will do a search. Firefox seems to default there to Google. How do I change that if I do not WANT that to default to Google? (Or do I have to avoid using that as another search box, which I was accustomed to doing with IE? Or go back to IE, which I only left because on my new computer, with Windows 7, IE wouldn't open up: Hotmail! Really, shouldn't THAT work seamlessly?) Thanks, madperson, for taking a crack at it.

philipp
  • Top 10 Contributor
  • Moderator
2050 solutions 8916 answers

ok sorry, then i've misinterpreted your original post.

you can set bing as default search provider in the location bar like this:

  1. enter about:config into the firefox location bar (confirm the info message in case it shows up)
  2. search for the preference named keyword.URL. double-click it and change its value to http://www.bing.com/search?q=
cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97022 answers

Helpful Reply

See also:

Question owner

Thanks, madperson! Of course I had to figure out what the "location bar" was ... lots like it is "fixed." Now I just have to figure out why I'm not getting sound from Mozilla while I am getting sound via IE. WHY are these things made so hard????????????????? (I think it may be a need for a Flash upgrade, but Flash keeps throwing Google/Chrome at me -- without asking.)

Question owner

Thanks - from your link I confirmed what a "location bar" was so I could put in the information that madperson wanted me to type somewhere. Who knew I could get to some underlying programming there? (And why would this have to be so hard?)

cor-el
  • Top 10 Contributor
  • Moderator
10780 solutions 97022 answers

You can click the Volume icon on the Windows Taskbar near the clock and click the Mixer link at the bottom to open the mixer.

You can adjust the volume level for each application in that window, so make sure that Firefox is not muted or set at a low level.

Current Firefox versions use the plugin-container process to run plugins, so you need to check the volume setting for the plugin-container process.
You will only see the Firefox program or the Plugin Container in the Mixer if you are on a website that plays sound.

Modified by cor-el