X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox takes too long to load initial page (homepage) nothing has fixed it.

Posted

For the last 3 months, I have had a major problem with Firefox taking forever to startup my home page. After the initial startup , all websites load fine. So here is what I have tried. I have cleared temp files, cache and etc... I have tried the dns prefetching. I have tried changing the value in the about config option. I have changed my profile to a clean new fresh one with no history or bookmarks. I have disabled plugins and restarted in safe mode. I have updated all existing plugins/ add ons.I have deinstalled and reinstalled Firefox ( I have the latest version) I have tried Pale Moon and Internet Explorer. Both are slow but Internet Explorer seems to be the fastest right now. I have done a restore point to a time before major updates when the problem first started. I have tried all changes recommended in the aboutconfig: option. I have scanned with numerous adware and antivirus programs and nothing turns up. I have contacted my service provider (ATT Uverse) and everything of course checks out on their end. I suspect there is something with their particular server they have me on because that is the only thing in common with the browsers. Any other suggestions?

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.8.638
  • Amazon MP3 Downloader Plugin 1.0.17
  • Unity Player 3.5.5f4
  • Shockwave Flash 11.3 r300
  • 5.1.10411.0
  • 3DVIA player(5.0.0.20). For more information, visit the 3DVIA player web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.4.634
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

philipp
  • Top 10 Contributor
  • Moderator
2043 solutions 8891 answers

hello RelicHunter78, i'm not sure if it is related to the issue you're describing, but there are two different versions of adobe shockwave flash shown in your list of installed plugins (11.3 r300 & 11.5 r502 ), which can cause problems...

please see if the older flash is listed in the windows control panel & removable from there or else use the uninstaller provided on the adobe website to remove the old plugin: http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

Question owner

I have disabled the older version in my add on options but in my control panel for windows there is only the active x flash player and flash player plug in installed. The active x is for internet explorer and the other I believe is for non IE browsers. So there are two different versions in my control panel but no duplicates of the same. I disabled the r300 assuming it's the older version and left the r502. I will give it some time to see if this has any affect and will post a reply . Thanks

Question owner

Unfortunately, this wasn't the problem. Thanks for the suggestion though.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96743 answers

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Question owner

I tried your suggestion and firefox.exe was not on the firewall's allowed programs list. So I added it and thought this fixed it. The first couple of times it was back to normal speed. Then, it started back to what it has been lately. It's taking 30 seconds to load first page. I have even tried changing homepages and it's like this on any homepage I designate. I have had my PC professionally inspected every which way and my PC is clean and gets a grade A in health. Really baffled right now.

meganos 0 solutions 5 answers

Easy. Uninstall Hola Unblocker or something like that.

Modified by meganos

Question owner

I don't have Hola Unblocker installed. I am not really sure what that is but it's not currently installed on my pc.

meganos 0 solutions 5 answers

I had the same problem, i removed the extension called hola unblocker and it helped

Question owner

I have disabled every extension I have and have totally removed firefox and reinstalled it and that didn't work either.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello RelicHunter78, can you provide us your homepage(the one with the problem)?

thank you

Question owner

I have tried over 100 homepages, all homepages do the same thing. If my browser sets closed or not in use for over 15 to 20 minutes it takes too long to reopen. I started leaving my browser open instead of closing it everytime I get off. That doesn't help because when I refresh my brower to bring the page backup , it does the same thing. It still takes a long time for the page to start backup.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Do you have in about:config the cache enable ?


thanks again

meganos 0 solutions 5 answers

And uninstall some programs like netflix, or apps that makes your internet "faster"

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96743 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

I have tried safe mode, no change

Question owner

I checked all my browser settings with ones listed or above or suggested, the only one I had to change was Browser.cache.check_doc_frequency to value 2. No difference yet.

Question owner

I don't have any netflix add ons or extensions installed. I only have necessary plug ins installed. I have turned off all add ons and restarted so this issue is not related to an add on, plug in or extension. I also can rule out my dsl provider as I have hooked my pc up to other family members connections with the same provider on the same server and it did the same thing, However their pc has no issue. I have taken my pc to 3 technicians and there are no problems they can find with my registry or any infections or spyware. The PC does the same thing on their connections.All hardware passes every test they can throw at it. I have tried other browsers and reinstalling this one as well and the same thing happens. This really is mind boggling. I have ATT/uverse beta 6.0. There should be no delay in starting up my browser. After startup, it works great no problems but the speed starting up is on par with old fashioned dial up right now. I have 3 gigs of ram available and I have 85 percent capacity left on hard drive , processor speed of 3.4 with dual core processor. Makes no sense at all.

meganos 0 solutions 5 answers

Format your PC and it should help :)

Question owner

I don't think reformatting is the route to go because if it is indeed a server issue , I will be right back where I started with the pain of reinstalling everything again added on top. I have seen numerous people online have had this issue as well but no solutions they have tried have worked either.

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Did you try cor-el's reply to : boot the computer in Windows Safe mode, not firefox in safe mode ?