X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Unable to play youtube videos unless on youtube.

Posted

Recently my system seems to nolonger be able to play any youtube videos unless on youtube. any other site the video could be embedded in it just sits at 00.00 with out loading the file. I have tryed disableing all addons. and the videos still refuse to load or be played unless I got to youtube to do so.

Chosen solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 10.10.2 for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.0
  • Winamp Application Detector
  • 5.1.10411.0
  • BitCometAgent v1.30 for Firefox

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

{
"application": {
"name": "Firefox",
"version": "18.0",
"userAgent": "Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0",
"supportURL": "http://support.mozilla.org/1/firefox/18.0/WINNT/en-US/"
},
"modifiedPreferences": {
"browser.cache.disk.capacity": 358400,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size.use_old_max": false,
"browser.cache.disk.smart_size_cached_value": 358400,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage_override.buildID": "20130104151925",
"browser.startup.homepage_override.mstone": "18.0",
"extensions.lastAppVersion": "18.0",
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_current_max_pages": 104858,
"places.database.lastMaintenance": 1357680735,
"privacy.sanitize.migrateFx3Prefs": true,
"security.warn_viewing_mixed": false
},
"graphics": {
"numTotalWindows": 3,
"numAcceleratedWindows": 3,
"windowLayerManagerType": "Direct3D 10",
"adapterDescription": "NVIDIA GeForce GTS 250",
"adapterVendorID": "0x10de",
"adapterDeviceID": "0x0615",
"adapterRAM": "1024",
"adapterDrivers": "nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um",
"driverVersion": "9.18.13.1061",
"driverDate": "11-18-2012",
"adapterDescription2": "",
"adapterVendorID2": "",
"adapterDeviceID2": "",
"adapterRAM2": "",
"adapterDrivers2": "",
"driverVersion2": "",
"driverDate2": "",
"isGPU2Active": false,
"direct2DEnabled": true,
"directWriteEnabled": true,
"directWriteVersion": "6.1.7601.17789",
"webglRenderer": "Google Inc. -- ANGLE (NVIDIA GeForce GTS 250)",
"info": {
"AzureCanvasBackend": "direct2d",
"AzureFallbackCanvasBackend": "cairo",
"AzureContentBackend": "direct2d"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9.4",
"version": "4.9.4"
},
"NSS": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSUTIL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSSL": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
},
"NSSSMIME": {
"minVersion": "3.14.1.0 Basic ECC",
"version": "3.14.1.0 Basic ECC"
}
},
"extensions": [
{
"name": "Adblock Plus",
"version": "2.2.1",
"isActive": true,
"id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"
},
{
"name": "NoScript",
"version": "2.6.4.2",
"isActive": true,
"id": "{73a6fe31-595d-460b-a920-fcc0f8843232}"
},
{
"name": "Skype Click to Call",
"version": "6.5.0.11422",
"isActive": false,
"id": "{82AF8DCA-6DE9-405D-BD5E-43525BDAD38A}"
}
]
}

iamjayakumars
  • Top 10 Contributor
418 solutions 4938 answers

Please check if all your plugins are up-to-date. To do this, go to the Mozilla Plugin Check site.

Once you're there, the site will check if all your plugins have the latest versions. If you see plugins in the list that have a yellow Update button or a red Update now button, please update these immediately.

To do so, please click each red or yellow button. Then you should see a site that allows you to download the latest version. Double-click the downloaded file to start the installation and follow the steps mentioned in the installation procedure. _________________________________________________________________________________

Could you try disabling graphics hardware acceleration? Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Question owner

Had already done that before come here. The only ones not showing up-to date are the ones not traced by Firefox.

Tried the disabling hardware acceleration on advice from some one else in another thread. However the videos play just fine when viewed on YouTube page. or any page when using IE.

They will not play on Firefox when viewing from any site other then YouTube.

Windows updated several things today as well as an update for my video card came out. Not sure if any of the above was the fix or if it was just a matter of the system restart required after updating cleared out what ever was acting up,but it is now working.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97064 answers

Chosen Solution

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Will keep that in mind should it happen again Cor-el thanks. But for now the problem is fixed.